summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVladimir Krivopalov2018-06-08 18:16:46 -0700
committerVladimir Krivopalov2018-06-08 18:16:46 -0700
commit257e3ab293a1542e790c7ce8319e294c26f3ea52 (patch)
treef3ef869daba72dbafbadee1b863668e694e8eaa6
parent10a6ee3b40eaa5e891fe1da6f706bdabb63bb0f6 (diff)
downloadaur-257e3ab293a1542e790c7ce8319e294c26f3ea52.tar.gz
Use gcc7 and gcc7-libs to build Scylla as GCC 8.1 is known to be buggy
and fail with it. Signed-off-by: Vladimir Krivopalov <vladimir.krivopalov@gmail.com>
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD4
2 files changed, 5 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7b80ee2f553e..5adea4e12b9a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = scylla
pkgdesc = Scylla is an open source NoSQL drop-in replacement for Apache Cassandra with fast throughput and low latency
pkgver = 2.1.3
- pkgrel = 1
+ pkgrel = 2
url = http://www.scylladb.com/
install = .install
arch = x86_64
license = AGPL
makedepends = git
- makedepends = gcc
+ makedepends = gcc7
+ makedepends = gcc7-libs
makedepends = antlr3-cpp-headers-git
makedepends = libyaml
makedepends = yaml-cpp
diff --git a/PKGBUILD b/PKGBUILD
index 8473f2155b9e..e8d8283f5171 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Main package information
pkgname=scylla
pkgver=2.1.3
-pkgrel=1
+pkgrel=2
pkgdesc="Scylla is an open source NoSQL drop-in replacement for Apache Cassandra with fast throughput and low latency"
arch=('x86_64')
url="http://www.scylladb.com/"
@@ -17,7 +17,7 @@ depends=('hwloc' 'systemd' 'collectd' 'python-yaml' 'python2-yaml' 'python-urwid
optdepends=('scylla-jmx: JMX interface for compatibility with tooling such as nodetool'
'scylla-tools: Tools to be used with ScyllaDB, such as cqlsh, nodetool and others')
-makedepends=('git' 'gcc' 'antlr3-cpp-headers-git' 'libyaml' 'yaml-cpp'
+makedepends=('git' 'gcc7' 'gcc7-libs' 'antlr3-cpp-headers-git' 'libyaml' 'yaml-cpp'
'lz4' 'zlib' 'snappy' 'jsoncpp' 'gnutls' 'ninja'
'ragel' 'libaio' 'crypto++' 'xfsprogs' 'jre8-openjdk-headless'
'numactl' 'libpciaccess' 'libxml2' 'thrift-0.10.0' 'lksctp-tools'