summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAli Molaei2023-11-15 13:41:33 +0330
committerAli Molaei2023-11-15 13:41:33 +0330
commit267a04c4daaecc8d0d41dddef99ab09c01b825c4 (patch)
tree6c4da185883a63b291f9f556481e85b8cf3ccb31
parent56056066a2347b325131702e6bde32a015586d85 (diff)
downloadaur-267a04c4daaecc8d0d41dddef99ab09c01b825c4.tar.gz
Fix gitignore
-rw-r--r--.gitignore6
-rw-r--r--modern-icu.patch31
-rw-r--r--qt-dir.patch21
3 files changed, 55 insertions, 3 deletions
diff --git a/.gitignore b/.gitignore
index 75b0133ee352..889c61a303b1 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,6 +1,6 @@
*
!PKGBUILD
!.SRCINFO
-!.patch
-!.desktop
-!.install
+!*.patch
+!*.desktop
+!*.install
diff --git a/modern-icu.patch b/modern-icu.patch
new file mode 100644
index 000000000000..a942d5d287d8
--- /dev/null
+++ b/modern-icu.patch
@@ -0,0 +1,31 @@
+From: Ben Westover <me@benthetechguy.net>
+CMake is hard coded to look for libicu version 56, since their Windows
+install of Qt6 is bundled with it. Since we're using system Qt, we can
+use the system version of libicu.
+---
+
+diff --git a/internal/frontend/bridge-gui/bridge-gui/DeployLinux.cmake b/internal/frontend/bridge-gui/bridge-gui/DeployLinux.cmake
+index 10e1ea1..53a336a 100644
+--- a/internal/frontend/bridge-gui/bridge-gui/DeployLinux.cmake
++++ b/internal/frontend/bridge-gui/bridge-gui/DeployLinux.cmake
+@@ -25,6 +25,7 @@ set(CMAKE_INSTALL_RPATH "${CMAKE_INSTALL_BINDIR}" "${CMAKE_INSTALL_LIBDIR}" "."
+ install(DIRECTORY "${QT_DIR}/qml" "${QT_DIR}/plugins"
+ DESTINATION "${CMAKE_INSTALL_PREFIX}")
+
++find_package(ICU 56.0 COMPONENTS i18n uc data REQUIRED)
+ macro( AppendLib LIB_NAME HINT_PATH)
+ string(TOUPPER ${LIB_NAME} UP_NAME)
+
+@@ -54,9 +55,9 @@ AppendQt6Lib("libQt6Gui.so.6")
+ AppendQt6Lib("libQt6Core.so.6")
+ AppendQt6Lib("libQt6QuickTemplates2.so.6")
+ AppendQt6Lib("libQt6DBus.so.6")
+-AppendQt6Lib("libicui18n.so.56")
+-AppendQt6Lib("libicuuc.so.56")
+-AppendQt6Lib("libicudata.so.56")
++AppendQt6Lib("libicui18n.so")
++AppendQt6Lib("libicuuc.so")
++AppendQt6Lib("libicudata.so")
+ AppendQt6Lib("libQt6XcbQpa.so.6")
+ AppendQt6Lib("libQt6WaylandClient.so.6")
+ AppendQt6Lib("libQt6WlShellIntegration.so.6")
diff --git a/qt-dir.patch b/qt-dir.patch
new file mode 100644
index 000000000000..4c4045c6eee1
--- /dev/null
+++ b/qt-dir.patch
@@ -0,0 +1,21 @@
+From: Ben Westover <me@benthetechguy.net>
+$QT_DIR is set to the Qt install prefix, which works fine for bundled Qt,
+but we're using a system Qt install, so everything is spread out. Correct
+the path to the qml and plugin directories for a system install.
+---
+
+diff --git a/internal/frontend/bridge-gui/bridge-gui/DeployLinux.cmake b/internal/frontend/bridge-gui/bridge-gui/DeployLinux.cmake
+index 10e1ea16..8a116690 100644
+--- a/internal/frontend/bridge-gui/bridge-gui/DeployLinux.cmake
++++ b/internal/frontend/bridge-gui/bridge-gui/DeployLinux.cmake
+@@ -22,8 +22,8 @@ cmake_minimum_required(VERSION 3.22)
+ #*****************************************************************************************************************************************************
+
+ set(CMAKE_INSTALL_RPATH "${CMAKE_INSTALL_BINDIR}" "${CMAKE_INSTALL_LIBDIR}" "." "../lib")
+-install(DIRECTORY "${QT_DIR}/qml" "${QT_DIR}/plugins"
+- DESTINATION "${CMAKE_INSTALL_PREFIX}")
++install(DIRECTORY "${QT_DIR}/lib/qt6/qml" "${QT_DIR}/lib/qt6/plugins"
++ DESTINATION "${CMAKE_INSTALL_PREFIX}/lib/qt6")
+
+ macro( AppendLib LIB_NAME HINT_PATH)
+ string(TOUPPER ${LIB_NAME} UP_NAME)