summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdam Goldsmith2019-11-13 09:29:07 -0500
committerAdam Goldsmith2019-11-13 09:29:07 -0500
commit27888a531f591a0227b7077fe00b59f605db7522 (patch)
treedc45c29f001d262d7108216b60f7af449eac5d9e
parent7580db32612e0db30e10656b7100e76a4fd67efb (diff)
downloadaur-27888a531f591a0227b7077fe00b59f605db7522.tar.gz
Strip 'v' prefix from git tags for pkgver
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
2 files changed, 3 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b1b3cabcb5bf..d001cedc1449 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = cura-git
pkgdesc = A full software solution for 3D printing aimed at RepRaps and the Ultimaker.
- pkgver = 4.0.0.442.gf6dd3f922
+ pkgver = 4.4.beta.r183.gebea5fbd1
pkgrel = 1
url = https://github.com/Ultimaker/Cura
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index aeec6af59beb..238d7e85f52a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Adam Goldsmith <contact@adamgoldsmith.name>
pkgname=cura-git
-pkgver=4.0.0.442.gf6dd3f922
+pkgver=4.4.beta.r183.gebea5fbd1
pkgrel=1
pkgdesc="A full software solution for 3D printing aimed at RepRaps and the Ultimaker."
arch=('any')
@@ -30,7 +30,7 @@ md5sums=('SKIP')
pkgver() {
cd Cura
- git describe --tags | sed 's/-/./g'
+ git describe --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {