summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKrzysztof AS (3ED)2021-01-08 16:18:59 +0100
committerKrzysztof AS (3ED)2021-01-08 16:18:59 +0100
commit2799faf8a8d43e73ff1f72edcf434487be94ca68 (patch)
treed372c899b9df61b521ad14529e3dc4963f179f7d
parent3d9c35be8ced10d9b26b2bfb7329708ec3b94b75 (diff)
downloadaur-2799faf8a8d43e73ff1f72edcf434487be94ca68.tar.gz
update
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD70
-rw-r--r--fix-gcc10-compilation.patch65
-rw-r--r--org.ddccontrol.pkexec.gddccontrol.policy22
4 files changed, 36 insertions, 133 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5f5dbca93590..bb17b3f1e75e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ddccontrol
pkgdesc = Control your monitor by software using the DDC/CI protocol
- pkgver = 0.4.4
- pkgrel = 8
+ pkgver = 0.5.0
+ pkgrel = 1
url = https://github.com/ddccontrol/ddccontrol
arch = i686
arch = x86_64
@@ -15,12 +15,8 @@ pkgbase = ddccontrol
depends = libxml2
depends = icu
options = !libtool
- source = ddccontrol-0.4.4.tar.gz::https://github.com/ddccontrol/ddccontrol/archive/0.4.4.tar.gz
- source = org.ddccontrol.pkexec.gddccontrol.policy
- source = fix-gcc10-compilation.patch
- sha256sums = aafbb16ac4f4edfe3fcc5feec1eb5729aaf86e3b0f31f9d707ba1406bb404817
- sha256sums = ef84637e512496a37fe3b50f64020f11aafaa7bc8ab821e90e81256439c2069a
- sha256sums = 86b560a674ddfca7d8d7a30eb5ebf57d135e81eb8eea3808a0492010a9059995
+ source = ddccontrol-0.5.0.tar.gz::https://github.com/ddccontrol/ddccontrol/archive/0.5.0.tar.gz
+ sha256sums = 41d7c4fbcd1c2fa33bc6993c44527e98a1af7233903f6b362f41b99f977224df
pkgname = ddccontrol
install = ddccontrol.install
diff --git a/PKGBUILD b/PKGBUILD
index 31bdc398b706..1595a06116e3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,68 +5,62 @@
pkgbase=ddccontrol
pkgname=(ddccontrol gddccontrol)
-pkgver=0.4.4
-pkgrel=8
+pkgver=0.5.0
+pkgrel=1
pkgdesc="Control your monitor by software using the DDC/CI protocol"
arch=('i686' 'x86_64')
url="https://github.com/ddccontrol/ddccontrol"
license=('GPL')
depends=('pciutils' 'ddccontrol-db-git' 'perl-xml-parser' 'libxml2' 'icu')
makedepends=('gtk2' 'autoconf' 'intltool')
-source=("$pkgbase-$pkgver.tar.gz::https://github.com/ddccontrol/ddccontrol/archive/${pkgver}.tar.gz"
- 'org.ddccontrol.pkexec.gddccontrol.policy'
- 'fix-gcc10-compilation.patch')
+source=("$pkgbase-$pkgver.tar.gz::https://github.com/ddccontrol/ddccontrol/archive/${pkgver}.tar.gz")
options=('!libtool')
-sha256sums=('aafbb16ac4f4edfe3fcc5feec1eb5729aaf86e3b0f31f9d707ba1406bb404817'
- 'ef84637e512496a37fe3b50f64020f11aafaa7bc8ab821e90e81256439c2069a'
- '86b560a674ddfca7d8d7a30eb5ebf57d135e81eb8eea3808a0492010a9059995')
+sha256sums=('41d7c4fbcd1c2fa33bc6993c44527e98a1af7233903f6b362f41b99f977224df')
prepare() {
cd "${srcdir}"/${pkgbase}-${pkgver}
- patch -Np1 -i ../fix-gcc10-compilation.patch
test -f configure || INTLTOOLIZE='intltoolize --force' autoreconf --install
}
build() {
- cd "${srcdir}"/${pkgbase}-${pkgver}
- ./configure \
- --prefix=/usr \
- --disable-gnome-applet
- make
+ cd "${srcdir}"/${pkgbase}-${pkgver}
+ ./configure \
+ --prefix=/usr \
+ --disable-gnome-applet
+ make
}
package_ddccontrol() {
- install=ddccontrol.install
+ install=ddccontrol.install
- cd "${srcdir}"/${pkgbase}-${pkgver}
+ cd "${srcdir}"/${pkgbase}-${pkgver}
- for i in src/lib src/ddcpci src/ddccontrol po man; do
- make DESTDIR="${pkgdir}" install -C $i
- done
+ for i in src/lib src/ddcpci src/daemon src/ddccontrol po man; do
+ make DESTDIR="${pkgdir}" install -C $i
+ done
- # cleanups
- rm "$pkgdir/usr/share/man/man1/gddccontrol.1"
-}
+ # fix bad path
+ install -Dm644 \
+ "$pkgdir/usr/etc/dbus-1/system.d/ddccontrol.DDCControl.conf" \
+ "$pkgdir/usr/share/dbus-1/system.d/ddccontrol.DDCControl.conf"
-package_gddccontrol() {
- depends=('gtk2' 'ddccontrol')
- pkgdesc="Control your monitor by software using the DDC/CI protocol (GUI)"
- conflicts=("ddccontrol-git")
+ rm -rf "$pkgdir/usr/etc/"
- cd "${srcdir}"/${pkgbase}-${pkgver}
+ # cleanups
+ rm "$pkgdir/usr/share/man/man1/gddccontrol.1"
+}
- for i in src/gddccontrol man; do
- make DESTDIR="${pkgdir}" install -C $i
- done
+package_gddccontrol() {
+ depends=('gtk2' 'ddccontrol')
+ pkgdesc="Control your monitor by software using the DDC/CI protocol (GUI)"
+ conflicts=("ddccontrol-git")
- # cleanups
- rm "$pkgdir/usr/share/man/man1/ddccontrol.1"
+ cd "${srcdir}"/${pkgbase}-${pkgver}
- # policykit
- install -Dm644 \
- "$srcdir/org.ddccontrol.pkexec.gddccontrol.policy" \
- "${pkgdir}/usr/share/polkit-1/actions/org.ddccontrol.pkexec.gddccontrol.policy"
+ for i in src/gddccontrol man; do
+ make DESTDIR="${pkgdir}" install -C $i
+ done
- sed -e 's/Exec=gddccontrol/Exec=pkexec gddccontrol/' \
- -i "${pkgdir}/usr/share/applications/gddccontrol.desktop"
+ # cleanups
+ rm "$pkgdir/usr/share/man/man1/ddccontrol.1"
}
diff --git a/fix-gcc10-compilation.patch b/fix-gcc10-compilation.patch
deleted file mode 100644
index 0f451e28da98..000000000000
--- a/fix-gcc10-compilation.patch
+++ /dev/null
@@ -1,65 +0,0 @@
-diff -Naur a/src/gddccontrol/main.c b/src/gddccontrol/main.c
---- a/src/gddccontrol/main.c 2018-04-26 19:06:28.000000000 +0200
-+++ b/src/gddccontrol/main.c 2020-05-18 12:07:55.295305191 +0200
-@@ -45,6 +45,21 @@
- GtkWidget* profile_hbox = NULL;
- GtkWidget* bottom_hbox = NULL;
-
-+GtkWidget* main_app_window = NULL;
-+
-+GtkWidget* monitor_manager = NULL;
-+GtkWidget* profile_manager = NULL;
-+
-+GtkWidget* profile_manager_button = NULL;
-+GtkWidget* saveprofile_button = NULL;
-+GtkWidget* cancelprofile_button = NULL;
-+GtkWidget* refresh_controls_button = NULL;
-+
-+struct monitor* mon;
-+
-+int current_monitor; /* current monitor */
-+int num_monitor; /* total number of monitors */
-+
- struct monitorlist* monlist;
-
- GtkTooltips *tooltips;
-diff -Naur a/src/gddccontrol/notebook.h b/src/gddccontrol/notebook.h
---- a/src/gddccontrol/notebook.h 2018-04-26 19:06:28.000000000 +0200
-+++ b/src/gddccontrol/notebook.h 2020-05-18 12:11:52.632860270 +0200
-@@ -43,12 +43,12 @@
- #endif
-
- /* globals */
--struct monitor* mon;
-+extern struct monitor* mon;
-
--GtkWidget* main_app_window;
-+extern GtkWidget* main_app_window;
-
--GtkWidget* monitor_manager;
--GtkWidget* profile_manager;
-+extern GtkWidget* monitor_manager;
-+extern GtkWidget* profile_manager;
-
- /* notebook.c */
-
-@@ -91,13 +91,13 @@
-
- GtkWidget *stock_label_button(const gchar * stockid, const gchar *label_text, const gchar *tool_tip);
-
--GtkWidget* profile_manager_button;
--GtkWidget* saveprofile_button;
--GtkWidget* cancelprofile_button;
--GtkWidget* refresh_controls_button;
-+extern GtkWidget* profile_manager_button;
-+extern GtkWidget* saveprofile_button;
-+extern GtkWidget* cancelprofile_button;
-+extern GtkWidget* refresh_controls_button;
-
- /* Multimonitor support */
--int current_monitor; /* current monitor */
--int num_monitor; /* total number of monitors */
-+extern int current_monitor; /* current monitor */
-+extern int num_monitor; /* total number of monitors */
-
- #endif //NOTEBOOK_H
diff --git a/org.ddccontrol.pkexec.gddccontrol.policy b/org.ddccontrol.pkexec.gddccontrol.policy
deleted file mode 100644
index 50b4f80bb849..000000000000
--- a/org.ddccontrol.pkexec.gddccontrol.policy
+++ /dev/null
@@ -1,22 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE policyconfig PUBLIC
- "-//freedesktop//DTD PolicyKit Policy Configuration 1.0//EN"
- "http://www.freedesktop.org/standards/PolicyKit/1/policyconfig.dtd">
-<policyconfig>
- <vendor>DDCcontrol</vendor>
- <vendor_url>https://github.com/ddccontrol/ddccontrol</vendor_url>
-
- <action id="org.ddccontrol.pkexec.gddccontrol">
- <message>Authentication is required to run the Monitor Settings</message>
- <icon_name>gddccontrol</icon_name>
- <defaults>
- <allow_any>no</allow_any>
- <allow_inactive>no</allow_inactive>
- <allow_active>yes</allow_active>
- </defaults>
- <annotate key="org.freedesktop.policykit.exec.path">/usr/bin/gddccontrol</annotate>
- <annotate key="org.freedesktop.policykit.exec.allow_gui">true</annotate>
- </action>
-
-</policyconfig>
-