summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2021-07-23 11:23:19 +0300
committerCaleb Maclennan2021-07-23 11:23:19 +0300
commit27e9a136d5c1f6b8a923d857ad4ae66870925f58 (patch)
tree873f75499124a076a831f12cbc089129220235a8
parent60148537f20cbd5b3839849441742b8dc19ef554 (diff)
downloadaur-27e9a136d5c1f6b8a923d857ad4ae66870925f58.tar.gz
upgpkg: mattermost-desktop 4.7.0-2
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
-rw-r--r--mattermost-desktop.sh2
3 files changed, 8 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 64fdfde21f2a..70fa87dd0e02 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mattermost-desktop
pkgdesc = Mattermost Desktop application for Linux
pkgver = 4.7.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/mattermost/desktop
arch = x86_64
arch = i686
@@ -15,7 +15,7 @@ pkgbase = mattermost-desktop
source = mattermost-desktop.sh
source = mattermost.desktop
sha256sums = f327d8560bebeb2075c7369898c3ed6c2d11be952a44853822a663ba42144055
- sha256sums = 0f18f87764465f1fc5a9fdfb6ef2834af4623c13bc95fce58da6cb0d8d39a75e
+ sha256sums = 1c2bf48b6397d04a5a536c5c9f4960db53249c838c380f03f808c612b00ba4c6
sha256sums = e628268d3393aac0d5b7237c6b8818d2e362c373f99874a19171bf96a25e4ffa
pkgname = mattermost-desktop
diff --git a/PKGBUILD b/PKGBUILD
index 16e91cadee50..b41d03249e0b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,10 +3,11 @@
# Contributor: Aleksandar Trifunović <akstrfn at gmail dot com>
# Contributor: Jan Was <janek dot jan at gmail dot com>
# Contributor: Bruno Pagani <archange at archlinux dot org>
+# Contributor: AUR[Severus]
pkgname=mattermost-desktop
pkgver=4.7.0
-pkgrel=1
+pkgrel=2
pkgdesc='Mattermost Desktop application for Linux'
arch=(x86_64 i686)
url="https://github.com/${pkgname/-//}"
@@ -20,13 +21,14 @@ source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz"
"$pkgname.sh"
"${pkgname/-/.}")
sha256sums=('f327d8560bebeb2075c7369898c3ed6c2d11be952a44853822a663ba42144055'
- '0f18f87764465f1fc5a9fdfb6ef2834af4623c13bc95fce58da6cb0d8d39a75e'
+ '1c2bf48b6397d04a5a536c5c9f4960db53249c838c380f03f808c612b00ba4c6'
'e628268d3393aac0d5b7237c6b8818d2e362c373f99874a19171bf96a25e4ffa')
prepare() {
cd "desktop-$pkgver"
sed -i -e "s/git rev-parse --short HEAD/echo $pkgver/" webpack.config.base.js
+ sed -e "s/@ELECTRON@/$_electron/" "../$pkgname.sh" > "$pkgname.sh"
# Depending on the architecture, in order to accelerate the build process,
# removes the compilation of ia32 or x64 build.
@@ -92,6 +94,6 @@ package() {
install -Dm0644 -t "$pkgdir/usr/lib/$pkgname/" release/linux*unpacked/resources/app.asar
install -Dm0644 -t "$pkgdir/usr/share/licenses/$pkgname" LICENSE.txt
install -Dm0644 src/assets/linux/icon.svg "$pkgdir/usr/share/icons/hicolor/scalable/apps/$pkgname.svg"
- install -Dm0755 "../$pkgname".sh "$pkgdir/usr/bin/$pkgname"
+ install -Dm0755 "$pkgname.sh" "$pkgdir/usr/bin/$pkgname"
install -Dm0644 -t "$pkgdir/usr/share/applications/" "../${pkgname/-/.}"
}
diff --git a/mattermost-desktop.sh b/mattermost-desktop.sh
index 32009a8f9e0b..bd95581cd38b 100644
--- a/mattermost-desktop.sh
+++ b/mattermost-desktop.sh
@@ -1,2 +1,2 @@
#!/bin/sh
-exec electron7 /usr/lib/mattermost-desktop/app.asar --disable-dev-mode "$@"
+exec @ELECTRON@ /usr/lib/mattermost-desktop/app.asar --disable-dev-mode "$@"