summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMorgenstern2022-01-14 11:04:02 +1300
committerMorgenstern2022-01-14 11:04:02 +1300
commit2892c87daf9b1de2e107588518a3d9ed3f2f5628 (patch)
treebdf48277f02ddc104f197ff5390a6a4f348f5e2f
parentb95308bcc31519b16d4ac0039fda3c8c572ce444 (diff)
downloadaur-2892c87daf9b1de2e107588518a3d9ed3f2f5628.tar.gz
Remove usage of nginx configure flags from the build() function to prevent breakage when building for custom nginx packages that provide nginx-mainline
See --> https://aur.archlinux.org/packages/nginx-mainline-mod-fancyindex/#comment-846490
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
2 files changed, 9 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d145852ccb07..cf3281b8c68d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = nginx-mainline-mod-fancyindex
- pkgdesc = Fancy indexes module for the nginx web server
+ pkgdesc = Fancy index module for the nginx-mainline web server
pkgver = 0.5.2
- pkgrel = 1
+ pkgrel = 2
url = https://www.nginx.com/resources/wiki/modules/fancy_index/
arch = x86_64
license = BSD
diff --git a/PKGBUILD b/PKGBUILD
index 2b028548daf3..247148f9224e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,9 +5,9 @@
pkgname=nginx-mainline-mod-fancyindex
pkgver=0.5.2
-pkgrel=1
+pkgrel=2
_modname="${pkgname#nginx-mainline-mod-}"
-pkgdesc="Fancy indexes module for the nginx web server"
+pkgdesc="Fancy index module for the nginx-mainline web server"
arch=('x86_64')
url="https://www.nginx.com/resources/wiki/modules/fancy_index/"
license=('BSD')
@@ -16,6 +16,7 @@ makedepends=('nginx-mainline-src')
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/aperezdc/ngx-$_modname/archive/v$pkgver.tar.gz")
sha256sums=('c3dd84d8ba0b8daeace3041ef5987e3fb96e9c7c17df30c9ffe2fe3aa2a0ca31')
+# Required for compilation with /usr/src/nginx/configure
prepare() {
install -d nginx
ln -sf /usr/src/nginx/auto nginx/auto
@@ -24,17 +25,17 @@ prepare() {
build() {
cd "${srcdir}/nginx"
- _opts=$(nginx -V 2>&1 | grep 'configure arguments' | sed -r 's/^[^:]+: //')
- IFS=$'\n' _opts=( $(xargs -n1 <<< "$_opts") )
- /usr/src/nginx/configure "${_opts[@]}" \
+ /usr/src/nginx/configure --with-compat \
--add-dynamic-module=../ngx-"$_modname-$pkgver"
make modules
}
package() {
+ local _mod
+
cd "${srcdir}/nginx/objs"
for _mod in *.so; do
- install -D $_mod "$pkgdir/usr/lib/nginx/modules/$_mod"
+ install -D "${_mod}" "$pkgdir/usr/lib/nginx/modules/$_mod"
done
install -Dm0644 "$srcdir/ngx-$_modname-$pkgver/LICENSE" \
"$pkgdir/usr/share/licenses/$pkgname/LICENSE"