summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicola Murino2020-05-19 22:07:37 +0200
committerNicola Murino2020-05-19 22:07:37 +0200
commit2c4c8d758fd8525d5130b22b7e954fcfb8e15b17 (patch)
tree0eaf839a7e7196a8310f9396654f9adbc276aa42
parent23fa17916196684765807b329cda86e7451e9477 (diff)
downloadaur-2c4c8d758fd8525d5130b22b7e954fcfb8e15b17.tar.gz
properly override build flags
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD12
2 files changed, 10 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ebcf486c5730..c290fd946794 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = mingw-w64-libsoup
pkgdesc = HTTP client/server library (mingw-w64)
pkgver = 2.70.0
- pkgrel = 1
+ pkgrel = 2
url = https://download.gnome.org/sources/libsoup
arch = any
license = LGPL
makedepends = mingw-w64-meson
makedepends = git
- makedepends = python
+ makedepends = mingw-w64-environment
depends = mingw-w64-glib2
depends = mingw-w64-glib-networking
depends = mingw-w64-sqlite
diff --git a/PKGBUILD b/PKGBUILD
index f9b44c20a1b2..87dc49f63e02 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: drakkan <nicola.murino at gmail dot com>
pkgname=mingw-w64-libsoup
pkgver=2.70.0
-pkgrel=1
+pkgrel=2
pkgdesc="HTTP client/server library (mingw-w64)"
arch=(any)
url="https://download.gnome.org/sources/libsoup"
license=("LGPL")
depends=('mingw-w64-glib2' 'mingw-w64-glib-networking' 'mingw-w64-sqlite' 'mingw-w64-libxml2' 'mingw-w64-libpsl')
-makedepends=('mingw-w64-meson' 'git' 'python')
+makedepends=('mingw-w64-meson' 'git' 'mingw-w64-environment')
options=(!strip !buildflags staticlibs)
_commit=3857ea93dd3775d68010efed7ad3245714fee379 # tags/2.70.0^0
source=("git+https://gitlab.gnome.org/GNOME/libsoup.git#commit=$_commit")
@@ -16,11 +16,15 @@ sha256sums=('SKIP')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
build() {
- # workaround to fix build with gcc 10
- export CFLAGS="-fcommon"
for _arch in ${_architectures}; do
mkdir -p "${srcdir}/libsoup/build-${_arch}"
cd "${srcdir}/libsoup/build-${_arch}"
+ unset CPPFLAGS
+ unset CXXFLAGS
+ unset LDFLAGS
+ # workaround to fix build with gcc 10
+ export CFLAGS="-fcommon"
+ source mingw-env ${_arch}
meson-cross-file-generator --arch ${_arch} --output-file cross_file
export CROSS_FILE=${srcdir}/libsoup/build-${_arch}/cross_file
${_arch}-meson \