summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJerome M. BERGER2015-07-08 20:32:14 +0200
committerJerome M. BERGER2015-07-08 20:32:14 +0200
commit2d281db7506bfdb568a71a2747cdad35460b63a1 (patch)
tree8da797ebe5e834aab602215b94963c3026cb723e
downloadaur-2d281db7506bfdb568a71a2747cdad35460b63a1.tar.gz
First inclusion into repos.
-rw-r--r--.SRCINFO16
-rw-r--r--.hgignore4
-rw-r--r--PKGBUILD19
3 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dbd7ef8ce0ae
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = abi-compliance-checker
+ pkgdesc = Check ABI compatibility between library versions
+ pkgver = 1.99.9
+ pkgrel = 1
+ url = http://ispras.linuxbase.org/index.php/ABI_compliance_checker
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = gcc
+ depends = binutils
+ depends = perl
+ source = abi-compliance-checker-1.99.9.tar.gz::https://github.com/lvc/abi-compliance-checker/archive/1.99.9.tar.gz
+ md5sums = a9163668236cae5e33c606f51c7f8173
+
+pkgname = abi-compliance-checker
+
diff --git a/.hgignore b/.hgignore
new file mode 100644
index 000000000000..75c0a042c561
--- /dev/null
+++ b/.hgignore
@@ -0,0 +1,4 @@
+^abi-compliance-checker.*\.pkg\.tar\.xz$
+
+^pkg/
+^src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9106ffca9caf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# $Id: PKGBUILD 119577 2011-04-12 14:21:49Z eric $
+# Maintainer: Jérôme M. Berger <jerome.berger@sagemcom.com>
+
+pkgname=abi-compliance-checker
+pkgver=1.99.9
+pkgrel=1
+pkgdesc="Check ABI compatibility between library versions"
+arch=('i686' 'x86_64')
+url="http://ispras.linuxbase.org/index.php/ABI_compliance_checker"
+license=('GPL')
+depends=(gcc binutils perl)
+source=(${pkgname}-${pkgver}.tar.gz::https://github.com/lvc/abi-compliance-checker/archive/${pkgver}.tar.gz)
+md5sums=('a9163668236cae5e33c606f51c7f8173')
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ mkdir -p "${pkgdir}/usr"
+ perl Makefile.pl -install --prefix=/usr --destdir="${pkgdir}"
+}