summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMikołaj "D1SoveR" Banasik2022-11-19 14:04:24 +0000
committerMikołaj "D1SoveR" Banasik2022-11-19 14:05:21 +0000
commit2e69df7183c1cfbe6ce341b299c6bea181fae10a (patch)
treee0b8df389ac6e5f02dcb851b35f489d58025031b
parentba24e0a45bc5061a770bd56db4390699181ab2c0 (diff)
downloadaur-2e69df7183c1cfbe6ce341b299c6bea181fae10a.tar.gz
Updated patches to account for changes to Cargo.toml and the Makefile.
-rw-r--r--PKGBUILD4
-rw-r--r--reproducible-build.patch12
-rw-r--r--size-optimisations.patch12
3 files changed, 15 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 45ee4a0c297d..9c4fbc790d68 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,8 +16,8 @@ source=("git+${url}.git"
'reproducible-build.patch'
'size-optimisations.patch')
sha256sums=('SKIP'
- 'e97cf95dedcf60c97edb3a693052964e4ce6da795631ca5c9f04182462f67895'
- '1aea00fecd857e8d7b8a3d4c3a5d2f9ef18007bb9366461b4f16878d64a7bf40')
+ '38a0cc7ec879a2f2dec10adf98d9d76ad7ea9a66a097122031f1759a2c4761d1'
+ '02fe3f63b7ff6e3f020c61ce02b2f91a8129668bc06aa16ba37709ed755b9334')
pkgver() {
cd "${pkgname%-git}"
diff --git a/reproducible-build.patch b/reproducible-build.patch
index 1ec6caeec3ea..cfa4f0d0e5a1 100644
--- a/reproducible-build.patch
+++ b/reproducible-build.patch
@@ -1,15 +1,17 @@
diff --git a/Makefile b/Makefile
-index 475c85b..2800d44 100644
+index 268c112..87873dc 100644
--- a/Makefile
+++ b/Makefile
-@@ -37,13 +37,13 @@ build:
- cargo build
+@@ -43,7 +43,7 @@ build:
+ $(GODOT) --path . --export "Linux/X11" target/debug/luxtorpeda.x86_64 --no-window
release:
- cargo build --release
+ cargo build --release --locked
-
- lint:
+ mkdir -p target/debug
+ cp -r target/release/* target/debug
+ $(GODOT) --path . --export "Linux/X11" target/release/luxtorpeda.x86_64 --no-window
+@@ -52,7 +52,7 @@ lint:
cargo clippy -- -D warnings
test:
diff --git a/size-optimisations.patch b/size-optimisations.patch
index e60f9e6d960f..7c7c1902011f 100644
--- a/size-optimisations.patch
+++ b/size-optimisations.patch
@@ -1,10 +1,10 @@
diff --git a/Cargo.toml b/Cargo.toml
-index 558ceb5..913630d 100644
+index 5541e99..cda7add 100644
--- a/Cargo.toml
+++ b/Cargo.toml
-@@ -6,6 +6,11 @@ edition = "2018"
-
- # See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+@@ -9,6 +9,11 @@ edition = "2021"
+ [lib]
+ crate-type = ["cdylib"]
+[profile.release]
+panic = 'abort'
@@ -12,5 +12,5 @@ index 558ceb5..913630d 100644
+lto = true
+
[dependencies]
- serde = { version = "1.0", features = ["derive"] }
- serde_json = "1.0"
+ serde = { version = "1.0.137", features = ["derive"] }
+ serde_json = "1.0.81"