summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Lagnese2023-06-03 12:13:14 -0700
committerTim Lagnese2023-06-03 12:13:14 -0700
commit337883fffcbbf9af6d08dc4501ddecf010d33fa8 (patch)
treee1c9debb55f93535007e077de7a035dc9c97b189
parentec81c6c6987ed05546c5c0fd89bce73f44d4131e (diff)
downloadaur-337883fffcbbf9af6d08dc4501ddecf010d33fa8.tar.gz
Fix build on GCC 13.1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD11
-rw-r--r--gcc13.1.patch68
-rw-r--r--toml_slicer.gcc13.1.patch12
4 files changed, 95 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 80cc2a0c5c5f..5a5b7d4b3d96 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = alire
pkgdesc = A catalog of ready-to-use Ada libraries plus a command-line tool (alr) to obtain, build, and incorporate them into your own projects. It aims to fulfill a similar role to Rust's cargo or OCaml's opam.
pkgver = 1.2.2
- pkgrel = 1
+ pkgrel = 2
url = https://alire.ada.dev/
arch = i686
arch = x86_64
@@ -12,13 +12,15 @@ pkgbase = alire
depends = unzip
source = alire-1.2.2.tar.gz::https://github.com/alire-project/alire/archive/refs/tags/v1.2.2.tar.gz
source = alire.patch
+ source = gcc13.1.patch
+ source = toml_slicer.gcc13.1.patch
source = git+https://github.com/alire-project/xmlezout.git#commit=1fcbd0b9303d044d8f09a8ef652afa8c0400ee8b
source = git+https://github.com/mosteo/ajunitgen.git#commit=e5d01db5e7834d15c4066f0a8e33d780deae3cc9
source = git+https://github.com/mosteo/aaa.git#commit=906d9eaf4fb8efabfbc3d8cfb34d04ceec340e13
source = git+https://github.com/alire-project/semantic_versioning.git#commit=fe4e72e40786589a66d53662639f894fcdb3419c
source = git+https://github.com/alire-project/simple_logging.git#commit=02a7de7568af6af7cedd1048901fae8e9477b1d9
source = git+https://github.com/pmderodat/ada-toml.git#commit=2a671ffb1039a036f2bb68bdc88afc8d3dc68c10
- source = git+https://github.com/alire-project/gnatcoll-core.git#commit=92bb91130a9ec628b4c48b7ef9fe7f24d9dc25fa
+ source = git+https://github.com/alire-project/gnatcoll-core.git#commit=403efe11405113cf12ae3d014df474cf7a046176
source = git+https://github.com/mosteo/ansi-ada#commit=acf9afca3afe1f8b8843c061f3cef860d7567307
source = git+https://github.com/mosteo/uri-ada.git#commit=b61eba59099b3ab39e59e228fe4529927f9e849e
source = git+https://github.com/mosteo/minirest#commit=4550aa356d55b9cd55f26acd34701f646021c5ff
@@ -30,6 +32,8 @@ pkgbase = alire
source = git+https://github.com/mosteo/toml_slicer#commit=8b9dff0f450394b07ea71f0eb9b39d9c20e21f9c
b2sums = fc70ab6ba89dbe9d949700ad57dd9dce2f215c92731010a1bd255ef63e1beaddae852183a9cf2018eb2b054c69504d7785441356ab4299b1d0043896265ee8a7
b2sums = 15799818a362547fa67bc9e614a3ff5b4645e268f48a8a2fe451592410be3d1fae0ff0cc96853e22813e6aa5a2a9a434f8585e26cb4bb1d5b75263177b7b81a6
+ b2sums = aa6e4b91e7445eadf9ed4df1198a68067e590ebb4e394fe2ad476a7467b6c6dffe4fa22b6c12c0d94ae9e248f4ab93587dd948543c7d92da3a515558f221e323
+ b2sums = c1a012f0e421ea5fc1e07eea74920d64b5abd04a5073b346be9a3322ce489803c17f163377756398f0b592773e11befc9a505506ddbf53db138a5efec1142865
b2sums = SKIP
b2sums = SKIP
b2sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index e2f46eb32811..f7f1af1d6b8b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=alire
pkgver=1.2.2
-pkgrel=1
+pkgrel=2
pkgdesc="A catalog of ready-to-use Ada libraries plus a command-line tool (alr) to obtain, build, and incorporate them into your own projects. It aims to fulfill a similar role to Rust's cargo or OCaml's opam."
arch=('i686' 'x86_64')
url="https://alire.ada.dev/"
@@ -11,13 +11,15 @@ depends=(gnatcoll-core unzip)
makedepends=(git gprbuild)
source=("$pkgname-$pkgver.tar.gz::https://github.com/alire-project/alire/archive/refs/tags/v$pkgver.tar.gz"
alire.patch
+gcc13.1.patch
+toml_slicer.gcc13.1.patch
git+https://github.com/alire-project/xmlezout.git#commit=1fcbd0b9303d044d8f09a8ef652afa8c0400ee8b
git+https://github.com/mosteo/ajunitgen.git#commit=e5d01db5e7834d15c4066f0a8e33d780deae3cc9
git+https://github.com/mosteo/aaa.git#commit=906d9eaf4fb8efabfbc3d8cfb34d04ceec340e13
git+https://github.com/alire-project/semantic_versioning.git#commit=fe4e72e40786589a66d53662639f894fcdb3419c
git+https://github.com/alire-project/simple_logging.git#commit=02a7de7568af6af7cedd1048901fae8e9477b1d9
git+https://github.com/pmderodat/ada-toml.git#commit=2a671ffb1039a036f2bb68bdc88afc8d3dc68c10
-git+https://github.com/alire-project/gnatcoll-core.git#commit=92bb91130a9ec628b4c48b7ef9fe7f24d9dc25fa
+git+https://github.com/alire-project/gnatcoll-core.git#commit=403efe11405113cf12ae3d014df474cf7a046176
git+https://github.com/mosteo/ansi-ada#commit=acf9afca3afe1f8b8843c061f3cef860d7567307
git+https://github.com/mosteo/uri-ada.git#commit=b61eba59099b3ab39e59e228fe4529927f9e849e
git+https://github.com/mosteo/minirest#commit=4550aa356d55b9cd55f26acd34701f646021c5ff
@@ -30,6 +32,8 @@ git+https://github.com/mosteo/toml_slicer#commit=8b9dff0f450394b07ea71f0eb9b39d9
)
b2sums=('fc70ab6ba89dbe9d949700ad57dd9dce2f215c92731010a1bd255ef63e1beaddae852183a9cf2018eb2b054c69504d7785441356ab4299b1d0043896265ee8a7'
'15799818a362547fa67bc9e614a3ff5b4645e268f48a8a2fe451592410be3d1fae0ff0cc96853e22813e6aa5a2a9a434f8585e26cb4bb1d5b75263177b7b81a6'
+ 'aa6e4b91e7445eadf9ed4df1198a68067e590ebb4e394fe2ad476a7467b6c6dffe4fa22b6c12c0d94ae9e248f4ab93587dd948543c7d92da3a515558f221e323'
+ 'c1a012f0e421ea5fc1e07eea74920d64b5abd04a5073b346be9a3322ce489803c17f163377756398f0b592773e11befc9a505506ddbf53db138a5efec1142865'
'SKIP'
'SKIP'
'SKIP'
@@ -52,6 +56,9 @@ prepare()
# Get the submodules from the sources above
cd "$srcdir/$pkgname-$pkgver"
patch --strip=1 < "$srcdir/alire.patch"
+ patch --strip=1 < "$srcdir/gcc13.1.patch"
+ cd "../toml_slicer"
+ patch --strip=1 < "$srcdir/toml_slicer.gcc13.1.patch"
}
build() {
diff --git a/gcc13.1.patch b/gcc13.1.patch
new file mode 100644
index 000000000000..e150bff9e59c
--- /dev/null
+++ b/gcc13.1.patch
@@ -0,0 +1,68 @@
+Index: alire-1.2.2/alire.toml
+===================================================================
+--- alire-1.2.2.orig/alire.toml
++++ alire-1.2.2/alire.toml
+@@ -46,7 +46,7 @@ ada_toml = { url = "https://github.com/p
+ ajunitgen = { url = "https://github.com/mosteo/ajunitgen.git", commit = "e5d01db5e7834d15c4066f0a8e33d780deae3cc9" }
+ ansiada = { url = "https://github.com/mosteo/ansi-ada.git", commit = "acf9afca3afe1f8b8843c061f3cef860d7567307" }
+ clic = { url = "https://github.com/alire-project/clic.git", commit = "185519d65b089c3238e24cfe87f1d22db1f3e0d9" }
+-gnatcoll = { url = "https://github.com/alire-project/gnatcoll-core.git", commit = "92bb91130a9ec628b4c48b7ef9fe7f24d9dc25fa" }
++gnatcoll = { url = "https://github.com/alire-project/gnatcoll-core.git", commit = "403efe11405113cf12ae3d014df474cf7a046176" }
+ minirest = { url = "https://github.com/mosteo/minirest.git", commit = "4550aa356d55b9cd55f26acd34701f646021c5ff" }
+ optional = { url = "https://github.com/mosteo/optional.git", commit = "0c7d20c0c8b48ccb6b25fb648d48382e598c25c3" }
+ semantic_versioning = { url = "https://github.com/alire-project/semantic_versioning.git", commit = "fe4e72e40786589a66d53662639f894fcdb3419c" }
+Index: alire-1.2.2/src/alire/alire-index_on_disk-loading.adb
+===================================================================
+--- alire-1.2.2.orig/src/alire/alire-index_on_disk-loading.adb
++++ alire-1.2.2/src/alire/alire-index_on_disk-loading.adb
+@@ -236,7 +236,6 @@ package body Alire.Index_On_Disk.Loading
+ Indexes := Find_All (From, Result);
+ if not Result.Success then
+ Raise_Checked_Error (Message (Result));
+- return;
+ end if;
+
+ if Indexes.Is_Empty then
+@@ -248,7 +248,6 @@ package body Alire.Index_On_Disk.Loading
+ if not Outcome.Success then
+ Raise_Checked_Error
+ ("Could not add community index: " & Message (Outcome));
+- return;
+ end if;
+ end;
+ end if;
+Index: alire-1.2.2/src/alire/alire-solutions.ads
+===================================================================
+--- alire-1.2.2.orig/src/alire/alire-solutions.ads
++++ alire-1.2.2/src/alire/alire-solutions.ads
+@@ -420,6 +420,17 @@ package Alire.Solutions is
+ -- a safe-order traversal of a solution. This procedure is currently
+ -- sequential but it could be parallelized in the future.
+
++ function Pin_Dependencies (This : Solution;
++ Crate : Crate_Name;
++ Props : Alire.Properties.Vector)
++ return Conditional.Dependencies
++ is (if This.State (Crate).Has_Release
++ then This.State (Crate).Release.Dependencies (Props)
++ else Conditional.No_Dependencies);
++ -- If Crate is pinned in This and it has a release, return its
++ -- dependencies; otherwise return Empty. WORKAROUND FOR VISIBILITY BUG
++ -- IN GCC 13.1
++
+ private
+
+ type Solution is new Interfaces.Tomifiable with record
+Index: alire-1.2.2/src/alr/alr-commands-search.adb
+===================================================================
+--- alire-1.2.2.orig/src/alr/alr-commands-search.adb
++++ alire-1.2.2/src/alr/alr-commands-search.adb
+@@ -91,8 +91,6 @@ package body Alr.Commands.Search is
+ Tab.Append (Alire.Index.Crate (Name).TTY_Description);
+ Tab.Append (Ext.Image);
+ end List_Undetected;
+-
+- use Alire.Releases.Containers.Release_Sets;
+ begin
+
+ -- First, simpler case of search into crates
diff --git a/toml_slicer.gcc13.1.patch b/toml_slicer.gcc13.1.patch
new file mode 100644
index 000000000000..3cee5efd6900
--- /dev/null
+++ b/toml_slicer.gcc13.1.patch
@@ -0,0 +1,12 @@
+Index: toml_slicer/src/toml_slicer.adb
+===================================================================
+--- toml_slicer.orig/src/toml_slicer.adb
++++ toml_slicer/src/toml_slicer.adb
+@@ -207,7 +207,6 @@ package body TOML_Slicer is
+ raise Slicing_Error with
+ "Could not find removable entry " & Entry_Name
+ & " in array " & Array_Name & " in file " & File_Name;
+- return;
+ end if;
+ end Remove_Target;
+