summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrançois Magimel2015-07-09 11:31:51 +0200
committerFrançois Magimel2015-07-09 11:31:51 +0200
commit33e8bde7986ac138cb31332667179277f1b1be5e (patch)
tree9d0928c55879da56aedaf6bce6030da29facddd4
downloadaur-33e8bde7986ac138cb31332667179277f1b1be5e.tar.gz
Initial import
-rw-r--r--.SRCINFO37
-rw-r--r--PKGBUILD52
-rwxr-xr-xfofix-git.desktop10
-rwxr-xr-xfofix-git.install12
-rw-r--r--fofix-git.pngbin0 -> 5940 bytes
5 files changed, 111 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9055af30f67f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,37 @@
+# Generated by makepkg 4.2.0
+# Tue Feb 24 01:52:02 UTC 2015
+pkgbase = fofix-git
+ pkgdesc = fretsonfire X (FoFiX). Highly improved version of Frets on Fire (GIT Version)
+ pkgver = v4.0.0alpha1.607.g3fe0f93
+ pkgrel = 1
+ epoch = 1
+ url = http://code.google.com/p/fofix/
+ install = fofix-git.install
+ arch = i686
+ arch = x86_64
+ groups = games
+ license = GPL
+ makedepends = git
+ depends = ffmpeg
+ depends = python2
+ depends = python2-pygame
+ depends = python2-opengl
+ depends = python2-numpy
+ depends = python2-imaging
+ depends = pyogg
+ depends = pyvorbis
+ depends = python2-pysqlite
+ depends = libffi
+ depends = cython2
+ depends = soundtouch
+ depends = glu
+ optdepends = pyaudio: microphone support
+ source = fofix-git.desktop
+ source = fofix-git.png
+ source = git+http://github.com/fofix/fofix.git
+ md5sums = b7f141bb1045159e5075ecdb3f59adff
+ md5sums = f886a7fdfa7592b50aa9f62901910e03
+ md5sums = SKIP
+
+pkgname = fofix-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..09a0d00231b6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: François Magimel <magimel.francois@gmail.com>
+# Contributor: Austin <doorknob60 at gmail dot com>
+pkgname=fofix-git
+pkgver=v4.0.0alpha1.607.g3fe0f93
+epoch=1
+pkgrel=1
+pkgdesc="fretsonfire X (FoFiX). Highly improved version of Frets on Fire (GIT Version)"
+arch=('i686' 'x86_64')
+url="http://code.google.com/p/fofix/"
+license=('GPL')
+groups=('games')
+depends=('ffmpeg' 'python2' 'python2-pygame' 'python2-opengl'
+'python2-numpy'
+'python2-imaging' 'pyogg' 'pyvorbis' 'python2-pysqlite' 'libffi' 'cython2' 'soundtouch' 'glu')
+optdepends=('pyaudio: microphone support')
+makedepends=('git')
+install=${pkgname}.install
+source=('fofix-git.desktop' 'fofix-git.png' 'git+http://github.com/fofix/fofix.git')
+md5sums=('b7f141bb1045159e5075ecdb3f59adff' 'f886a7fdfa7592b50aa9f62901910e03' 'SKIP')
+
+pkgver() {
+ cd "$_gitname"
+ git describe --always | sed 's|-|.|g'
+ }
+
+_gitname="fofix"
+
+build() {
+ cd "$srcdir/fofix"
+
+
+python2 setup.py build_ext --inplace --force
+}
+
+package() {
+install -d $pkgdir/usr/
+install -d $pkgdir/usr/share/
+install -d $pkgdir/usr/share/applications/
+install -d $pkgdir/usr/share/pixmaps/
+install -d $pkgdir/usr/bin/
+install -d $pkgdir/opt/
+cd ${srcdir}
+cp ${startdir}/fofix-git.desktop ${pkgdir}/usr/share/applications/
+cp ${startdir}/fofix-git.png ${pkgdir}/usr/share/pixmaps/
+mv ${srcdir}/fofix $pkgdir/opt/fofix-git
+cd $pkgdir/usr/bin/
+echo "#/bin/sh" > fofix-git
+echo "cd /opt/fofix-git/" >> fofix-git
+echo "python2 ./FoFiX.py" >> fofix-git
+chmod +x fofix-git
+chmod -R 777 $pkgdir/opt/fofix-git
+}
diff --git a/fofix-git.desktop b/fofix-git.desktop
new file mode 100755
index 000000000000..300d395bda24
--- /dev/null
+++ b/fofix-git.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Type=Application
+Name=FoFiX (GIT)
+Comment=A great Guitar Hero clone!
+Exec=/usr/bin/fofix-git
+Encoding=UTF-8
+Icon=/usr/share/pixmaps/fofix-git.png
+Categories=Game;ArcadeGame;
+Terminal=false
+StartupNotify=false
diff --git a/fofix-git.install b/fofix-git.install
new file mode 100755
index 000000000000..9f82a0793da0
--- /dev/null
+++ b/fofix-git.install
@@ -0,0 +1,12 @@
+post_install() {
+
+
+echo
+echo "Run 'fofix-git' to start the game. To add songs to the game, add them to '/opt/fofix-git/data/songs' (I don't think it works in ~/.fofix/songs anymore)"
+echo
+echo "If it ever doesn't work, try removing ~/.fofix/fofix.ini"
+echo
+echo "3.020 and higher only include the Megalight themes by default. For more themes, go to http://www.fretsonfire.net/forums/viewtopic.php?f=32&t=24976 and add the themes to /opt/fofix-git/data/themes/"
+}
+
+
diff --git a/fofix-git.png b/fofix-git.png
new file mode 100644
index 000000000000..66fc712f4612
--- /dev/null
+++ b/fofix-git.png
Binary files differ