summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPlaton Pronko2020-10-24 11:13:46 +0300
committerPlaton Pronko2020-10-24 11:14:18 +0300
commit3467dcf16831df4e70c125f84dcff95154edbaf5 (patch)
tree4467b38902779cece4de53f6f147692c3c4bb1df
parent15410f7b9e07268d790f7cf0c6eb845c8d14cd0a (diff)
downloadaur-3467dcf16831df4e70c125f84dcff95154edbaf5.tar.gz
do not depend on glade-sharp
gtk-sharp-2 disabled building glade-sharp bindings (see https://github.com/archlinux/svntogit-packages/commit/9eefa5aa5b21b4e11990c89cc311a65bdc79d212). Seems that the only feature that depends on glade-sharp is EditorShell helper in Gconf.PropertyEditor. I added a patch to skip building that feature, because it seems to be unused.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD9
-rw-r--r--remove_glade_dependency.patch33
3 files changed, 41 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 89e154830c49..da299df6b43c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -11,10 +11,12 @@ pkgbase = gnome-sharp
source = 06_fix_mono_path.patch
source = 02_fix_pkg-config_paths.patch
source = 04_initialize_dbus_glib_threading.patch
+ source = remove_glade_dependency.patch
md5sums = c3da83bfaa81eb8bac39d7b2232e2604
md5sums = 923434786ec049eed71a68a0825a3d60
md5sums = a8c1bf57a384f5fc20a5890f9f1cef5a
md5sums = 90cd7ea88aaa3011522376153433d115
+ md5sums = 3b2fe30de4265a2cba32a5bd0506b6d8
pkgname = gnome-sharp
pkgdesc = GNOME bindings for C#
diff --git a/PKGBUILD b/PKGBUILD
index e8c257575bb1..582b87d257ed 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ pkgvermajor=2
pkgverminor=24
pkgverpatch=4
pkgver=${pkgvermajor}.${pkgverminor}.${pkgverpatch}
-pkgrel=6
+pkgrel=7
arch=(any)
license=(LGPL)
url="http://gtk-sharp.sourceforge.net"
@@ -15,17 +15,20 @@ makedepends=('gtk-sharp-2' 'libgnomeui' 'monodoc')
source=(https://github.com/mono/${pkgbase}/archive/${pkgver}.tar.gz
06_fix_mono_path.patch
02_fix_pkg-config_paths.patch
- 04_initialize_dbus_glib_threading.patch)
+ 04_initialize_dbus_glib_threading.patch
+ remove_glade_dependency.patch)
md5sums=('c3da83bfaa81eb8bac39d7b2232e2604'
'923434786ec049eed71a68a0825a3d60'
'a8c1bf57a384f5fc20a5890f9f1cef5a'
- '90cd7ea88aaa3011522376153433d115')
+ '90cd7ea88aaa3011522376153433d115'
+ '3b2fe30de4265a2cba32a5bd0506b6d8')
prepare() {
cd "${srcdir}/${pkgbase}-${pkgver}"
patch -Np1 < ../06_fix_mono_path.patch
patch -Np1 < ../04_initialize_dbus_glib_threading.patch
patch -Np1 < ../02_fix_pkg-config_paths.patch
+ patch -Np1 < ../remove_glade_dependency.patch
}
build() {
diff --git a/remove_glade_dependency.patch b/remove_glade_dependency.patch
new file mode 100644
index 000000000000..b26d83a3245a
--- /dev/null
+++ b/remove_glade_dependency.patch
@@ -0,0 +1,33 @@
+--- gnome-sharp-2.24.4.orig/configure.in.in 2017-05-10 17:25:41.000000000 +0300
++++ gnome-sharp-2.24.4/configure.in.in 2020-10-24 10:55:35.458416249 +0300
+@@ -168,10 +168,6 @@
+ AC_SUBST(GTKSHARP_CFLAGS)
+ AC_SUBST(GTKSHARP_LIBS)
+
+-PKG_CHECK_MODULES(GLADESHARP, glade-sharp-2.0 >= $GTK_SHARP_REQUIRED_VERSION)
+-AC_SUBST(GLADESHARP_CFLAGS)
+-AC_SUBST(GLADESHARP_LIBS)
+-
+ PKG_CHECK_MODULES(GAPI, gapi-2.0 >= $GTK_SHARP_REQUIRED_VERSION)
+ AC_PATH_PROG(GAPI_PARSER, gapi2-parser, no)
+ AC_SUBST(GAPI_PARSER)
+--- gnome-sharp-2.24.4.orig/sample/Makefile.am 2017-05-10 17:25:41.000000000 +0300
++++ gnome-sharp-2.24.4/sample/Makefile.am 2020-10-24 10:59:31.879546610 +0300
+@@ -1,4 +1,4 @@
+-SUBDIRS = gconf gnomevfs
++SUBDIRS = gnomevfs
+
+ if ENABLE_GNOME
+ GNOME_TARGETS=gnome-hello-world.exe canvas-example.exe fifteen.exe
+--- gnome-sharp-2.24.4.orig/gconf/GConf.PropertyEditors/Makefile.am 2017-05-10 17:25:41.000000000 +0300
++++ gnome-sharp-2.24.4/gconf/GConf.PropertyEditors/Makefile.am 2020-10-24 10:54:53.915470149 +0300
+@@ -34,8 +34,7 @@
+ PropertyEditorOptionMenu.cs \
+ PropertyEditorRadioButton.cs \
+ PropertyEditorSpinButton.cs \
+- PropertyEditorToggleButton.cs \
+- EditorShell.cs
++ PropertyEditorToggleButton.cs
+
+ build_sources = $(addprefix $(srcdir)/, $(sources)) $(top_builddir)/AssemblyInfo.cs
+