summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBaptiste Jonglez2016-05-31 16:46:08 +0200
committerBaptiste Jonglez2016-05-31 16:46:41 +0200
commit349ea6f1e347f44e48445a691cf0acfb84b1a93b (patch)
tree13c5eee9c164d3120c100f20133bdb3b31b94737
parent1f3ec8d13fa314b6d9f6afa2e8199e0d7a215da0 (diff)
downloadaur-349ea6f1e347f44e48445a691cf0acfb84b1a93b.tar.gz
opendht: Switch to CMake instead of autotools
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD24
2 files changed, 12 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e4c4c57a8462..175122c470f4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sun Apr 24 21:18:47 UTC 2016
+# Tue May 31 14:46:40 UTC 2016
pkgbase = opendht-git
pkgdesc = A C++11 implementation of the Kademlia DHT (Distributed Hash Table)
- pkgver = 20160421
+ pkgver = 20160530
pkgrel = 1
url = https://github.com/savoirfairelinux/opendht
arch = i686
@@ -10,6 +10,7 @@ pkgbase = opendht-git
license = GPL3
makedepends = git
makedepends = msgpack-c
+ makedepends = cmake
depends = gnutls
depends = nettle
depends = readline
diff --git a/PKGBUILD b/PKGBUILD
index 3ebe1da8e5d4..4928919b9c48 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
# Maintainer: Baptiste Jonglez <baptiste--aur at jonglez dot org>
# Contributor: Andy Weidenbaum <archbaum@gmail.com>
pkgname=opendht-git
-pkgver=20160421
+pkgver=20160530
pkgrel=1
pkgdesc="A C++11 implementation of the Kademlia DHT (Distributed Hash Table)"
arch=('i686' 'x86_64')
depends=('gnutls' 'nettle' 'readline')
-makedepends=('git' 'msgpack-c')
+makedepends=('git' 'msgpack-c' 'cmake')
url="https://github.com/savoirfairelinux/opendht"
license=('GPL3')
source=("git://github.com/savoirfairelinux/opendht")
@@ -23,19 +23,11 @@ build() {
cd "${pkgname%-git}"
msg2 'Building...'
- ./autogen.sh
- # Python bindings are disabled as of 2015-08-24 because they don't
- # build. See https://github.com/savoirfairelinux/opendht/issues/15
- ./configure \
- --prefix=/usr \
- --sbindir=/usr/bin \
- --libexecdir=/usr/bin \
- --sysconfdir=/etc \
- --sharedstatedir=/usr/share/opendht \
- --localstatedir=/var/lib/opendht \
- --with-gnu-ld \
- --disable-python \
- --disable-doc
+ mkdir -p build
+ cd build
+ cmake .. \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr
make
}
@@ -43,7 +35,9 @@ package() {
cd "${pkgname%-git}"
msg2 'Installing...'
+ cd build
make DESTDIR="$pkgdir" install
+ cd ..
msg2 'Installing documentation...'
install -D -m655 README.md "${pkgdir}/usr/share/doc/opendht/README.md"