summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRasmus Karlsson2023-12-24 15:44:34 +0100
committerRasmus Karlsson2023-12-24 15:52:01 +0100
commit34c667e55229a3e4b0a875f4138cd93de5c4f763 (patch)
tree09be0ceadbaa8ab9b08b1386b1efa732bb5cbd01
parent2fffca37aa6dae671e89bddf8c1ac239eeff86ef (diff)
downloadaur-34c667e55229a3e4b0a875f4138cd93de5c4f763.tar.gz
Update submodules for the crashpad -> crash-handler switch
New submodule is located here: https://github.com/Chatterino/crash-handler and is not active for Linux projects, so nothing has really changed
-rw-r--r--.SRCINFO4
-rw-r--r--Makefile2
-rw-r--r--PKGBUILD10
3 files changed, 7 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 62b5a8db1ea1..2004e4110716 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = chatterino2-git
pkgdesc = Second installment of the Twitch chat client series "Chatterino", dev/git version
- pkgver = 2.4.5.r91.g7d145e3
+ pkgver = 2.4.5.r152.g25add89
pkgrel = 1
url = https://chatterino.com
install = chatterino2-git.install
@@ -24,7 +24,6 @@ pkgbase = chatterino2-git
source = git+https://github.com/Chatterino/chatterino2
source = git+https://github.com/arsenm/sanitizers-cmake
source = git+https://github.com/Chatterino/libcommuni#branch=chatterino-cmake
- source = git+https://github.com/getsentry/crashpad
source = git+https://github.com/pajlada/settings
source = git+https://github.com/pajlada/signals
source = git+https://github.com/pajlada/serialize
@@ -32,6 +31,7 @@ pkgbase = chatterino2-git
source = git+https://github.com/zaphoyd/websocketpp
source = git+https://github.com/Neargye/magic_enum
source = git+https://github.com/mackron/miniaudio
+ source = git+https://github.com/Chatterino/crash-handler
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
diff --git a/Makefile b/Makefile
index a424f10dfa53..0e3e851b824f 100644
--- a/Makefile
+++ b/Makefile
@@ -27,7 +27,7 @@ clean:
chatterino2-*.log \
libcommuni \
humanize \
- crashpad \
+ crash-handler \
settings \
signals \
serialize \
diff --git a/PKGBUILD b/PKGBUILD
index 14299d1857d3..ce8c74e70447 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Ckat <ckat@teknik.io>
pkgname=chatterino2-git
_pkgname=chatterino2
-pkgver=2.4.5.r91.g7d145e3
+pkgver=2.4.5.r152.g25add89
pkgrel=1
pkgdesc='Second installment of the Twitch chat client series "Chatterino", dev/git version'
arch=('any')
@@ -17,14 +17,14 @@ install=$pkgname.install
source=("git+https://github.com/Chatterino/chatterino2"
"git+https://github.com/arsenm/sanitizers-cmake"
"git+https://github.com/Chatterino/libcommuni#branch=chatterino-cmake"
- "git+https://github.com/getsentry/crashpad"
"git+https://github.com/pajlada/settings"
"git+https://github.com/pajlada/signals"
"git+https://github.com/pajlada/serialize"
"git+https://github.com/Tencent/rapidjson"
"git+https://github.com/zaphoyd/websocketpp"
"git+https://github.com/Neargye/magic_enum"
- "git+https://github.com/mackron/miniaudio")
+ "git+https://github.com/mackron/miniaudio"
+ "git+https://github.com/Chatterino/crash-handler")
md5sums=('SKIP'
'SKIP'
'SKIP'
@@ -47,9 +47,6 @@ prepare () {
git submodule init
git config submodule.cmake/sanitizers-cmake.url "$srcdir/sanitizers-cmake"
git config submodule.lib/libcommuni.url "$srcdir/libcommuni"
- git config submodule.lib/crashpad.url "$srcdir/crashpad"
- # TODO: crashpad contains its own submodules, this needs to be resolved
- # crashpad is currently not used by this build
git config submodule.lib/settings.url "$srcdir/settings"
git config submodule.lib/signals.url "$srcdir/signals"
git config submodule.lib/serialize.url "$srcdir/serialize"
@@ -57,6 +54,7 @@ prepare () {
git config submodule.lib/websocketpp.url "$srcdir/websocketpp"
git config submodule.lib/miniaudio.url "$srcdir/miniaudio"
git config submodule.lib/magicenum.url "$srcdir/magicenum"
+ git config submodule.tools/crash-handler.url "$srcdir/crash-handler"
git -c protocol.file.allow=always submodule update
}