summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTaijian2020-08-22 14:42:21 +0200
committerTaijian2020-08-22 14:42:21 +0200
commit351a3c5dfd377b05172012c934075c87ad0d0cc3 (patch)
treef760ad5a9cf5795d52589e653832b18edaa4f3bf
parenta6f9735fc5632931e8fe83c43bba63d631c66f23 (diff)
downloadaur-351a3c5dfd377b05172012c934075c87ad0d0cc3.tar.gz
fix errors with lightdm and sddm - sorry, I screwed up!
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
-rw-r--r--gdm-plymouth.service16
-rw-r--r--lightdm-plymouth.service3
-rw-r--r--sddm-plymouth.service5
5 files changed, 16 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f2bc940a9493..aca73c62f945 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = plymouth
pkgdesc = A graphical boot splash screen with kernel mode-setting support
pkgver = 0.9.5
- pkgrel = 4
+ pkgrel = 5
url = https://www.freedesktop.org/wiki/Software/Plymouth/
arch = i686
arch = x86_64
@@ -23,7 +23,9 @@ pkgbase = plymouth
source = plymouth.encrypt_hook
source = plymouth.encrypt_install
source = lxdm-plymouth.service
+ source = lightdm-plymouth.service
source = slim-plymouth.service
+ source = sddm-plymouth.service
source = plymouth-deactivate.service
source = plymouth-start.service.in.patch
source = plymouth-start.path
@@ -37,7 +39,9 @@ pkgbase = plymouth
sha256sums = 7afa97d21444cbac7a6213edda09d9fa73ecbef1a6cea1e745f56669760c6120
sha256sums = 373ec20fe4c47e693a0c45cc06dd906e35dd1d70a85546bd1d571391de11763a
sha256sums = 06b31999cf60f49e536c7a12bc1c4f75f2671feb848bf5ccb91a963147e2680d
+ sha256sums = 4b7e47fb8d1e00d8b550c1fa21c193480643dfc40965bc7b925657f720bd189f
sha256sums = 9b5534921c5bf92a9285ba53b323209e812145c204ac5fed6899b7aad78300ef
+ sha256sums = e22c526ea25a3ff508a91eccfa1681341dd21186666aa60c8b473aa16c58a0fe
sha256sums = 3b17ed58b59a4b60d904c60bba52bae7ad685aa8273f6ceaae08a15870c0a9eb
sha256sums = 3a46f7faced877a913506d59757f0af60ad3d5f0bc365c56ed7ecc7aef75c5eb
sha256sums = ce3d62f4c5a1b5c0ccadd15406c7430251d1a42b232721bfbfc747da1b13e3ff
diff --git a/PKGBUILD b/PKGBUILD
index 492b7593ae32..4b2368455d79 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname=plymouth
pkgver=0.9.5
-pkgrel=4
+pkgrel=5
pkgdesc="A graphical boot splash screen with kernel mode-setting support"
url="https://www.freedesktop.org/wiki/Software/Plymouth/"
arch=('i686' 'x86_64')
@@ -27,7 +27,9 @@ source=("https://gitlab.freedesktop.org/${pkgname}/${pkgname}/-/archive/${pkgver
'plymouth.encrypt_hook'
'plymouth.encrypt_install'
'lxdm-plymouth.service'
+ 'lightdm-plymouth.service'
'slim-plymouth.service'
+ 'sddm-plymouth.service'
'plymouth-deactivate.service'
'plymouth-start.service.in.patch'
'plymouth-start.path'
@@ -43,7 +45,9 @@ sha256sums=('55a461003ece0a4daeffb8b7ac2178977c5ce024a7e688d24f6d2230465b50ba'
'7afa97d21444cbac7a6213edda09d9fa73ecbef1a6cea1e745f56669760c6120'
'373ec20fe4c47e693a0c45cc06dd906e35dd1d70a85546bd1d571391de11763a'
'06b31999cf60f49e536c7a12bc1c4f75f2671feb848bf5ccb91a963147e2680d'
+ '4b7e47fb8d1e00d8b550c1fa21c193480643dfc40965bc7b925657f720bd189f'
'9b5534921c5bf92a9285ba53b323209e812145c204ac5fed6899b7aad78300ef'
+ 'e22c526ea25a3ff508a91eccfa1681341dd21186666aa60c8b473aa16c58a0fe'
'3b17ed58b59a4b60d904c60bba52bae7ad685aa8273f6ceaae08a15870c0a9eb'
'3a46f7faced877a913506d59757f0af60ad3d5f0bc365c56ed7ecc7aef75c5eb'
'ce3d62f4c5a1b5c0ccadd15406c7430251d1a42b232721bfbfc747da1b13e3ff'
@@ -101,13 +105,11 @@ package() {
install -Dm644 "$srcdir/plymouth.initcpio_install" "$pkgdir/usr/lib/initcpio/install/plymouth"
install -Dm644 "$srcdir/sd-plymouth.initcpio_install" "$pkgdir/usr/lib/initcpio/install/sd-plymouth"
- for i in {lxdm,slim}-plymouth.service; do
+ for i in {sddm,lxdm,slim,lightdm}-plymouth.service; do
install -Dm644 "$srcdir/$i" "$pkgdir/usr/lib/systemd/system/$i"
done
- for i in {gdm,sddm,lightdm}; do
- ln -s "/usr/lib/systemd/system/$i.service" "$pkgdir/usr/lib/systemd/system/$i-plymouth.service"
- done
+ ln -s "/usr/lib/systemd/system/gdm.service" "$pkgdir/usr/lib/systemd/system/gdm-plymouth.service"
install -Dm644 "$srcdir/plymouth-deactivate.service" "$pkgdir/usr/lib/systemd/system/plymouth-deactivate.service"
install -Dm644 "$srcdir/plymouth-start.path" "$pkgdir/usr/lib/systemd/system/plymouth-start.path"
diff --git a/gdm-plymouth.service b/gdm-plymouth.service
deleted file mode 100644
index e1bd77b4d628..000000000000
--- a/gdm-plymouth.service
+++ /dev/null
@@ -1,16 +0,0 @@
-[Unit]
-Description=GNOME Display Manager
-Conflicts=getty@tty1.service plymouth-quit.service
-Wants=plymouth-deactivate.service
-After=systemd-user-sessions.service getty@tty1.service plymouth-deactivate.service plymouth-quit.service
-
-[Service]
-ExecStart=/usr/bin/gdm
-Restart=always
-IgnoreSIGPIPE=no
-BusName=org.gnome.DisplayManager
-StandardOutput=syslog
-StandardError=inherit
-
-[Install]
-Alias=display-manager.service
diff --git a/lightdm-plymouth.service b/lightdm-plymouth.service
index a845498fddf5..c3d4acb926ef 100644
--- a/lightdm-plymouth.service
+++ b/lightdm-plymouth.service
@@ -1,7 +1,8 @@
[Unit]
Description=Light Display Manager
+Documentation=man:lightdm(1)
Conflicts=getty@tty1.service plymouth-quit.service
-After=systemd-user-sessions.service getty@tty1.service plymouth-quit.service
+After=getty@tty1.service systemd-user-sessions.service plymouth-quit.service acpid.service
[Service]
ExecStart=/usr/bin/lightdm
diff --git a/sddm-plymouth.service b/sddm-plymouth.service
index 6217b2638239..674e9e10eca0 100644
--- a/sddm-plymouth.service
+++ b/sddm-plymouth.service
@@ -1,9 +1,8 @@
[Unit]
Description=Simple Desktop Display Manager
Documentation=man:sddm(1) man:sddm.conf(5)
-Conflicts=getty@tty1.service
-Wants=plymouth-deactivate.service
-After=systemd-user-sessions.service getty@tty1.service plymouth-deactivate.service plymouth-quit.service systemd-logind.service
+Conflicts=getty@tty1.service plymouth-quit.service
+After=systemd-user-sessions.service getty@tty1.service plymouth-quit.service systemd-logind.service
[Service]
ExecStart=/usr/bin/sddm