summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorL.G. Sarmiento2018-12-11 11:31:07 +0100
committerL.G. Sarmiento2018-12-11 11:31:07 +0100
commit3605da75e74acf916a414a9c4717cd856c1d97f3 (patch)
tree27f46ce0662aaa44505067ce6eabb47bd81fb653
parentb8082ea46655372b83724b2b288f9cbee29c547b (diff)
downloadaur-3605da75e74acf916a414a9c4717cd856c1d97f3.tar.gz
accounting for newly deprecated environment variable
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD2
-rw-r--r--geant4.install28
3 files changed, 21 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ce35723cffa8..d20e1dd765ee 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Mon Dec 10 18:01:42 UTC 2018
+# Tue Dec 11 10:28:55 UTC 2018
pkgbase = geant4
pkgdesc = A simulation toolkit for particle physics interactions.
pkgver = 10.5
@@ -33,7 +33,7 @@ pkgbase = geant4
source = http://cern.ch/geant4-data/releases/geant4.10.05.tar.gz
source = geant4.install
sha256sums = 4b05b4f7d50945459f8dbe287333b9efb772bd23d50920630d5454ec570b782d
- sha256sums = 36e2d2bff5fc753e8abaa1a5da10710c030512b926d33c1977687d7b47672bd4
+ sha256sums = 173be29c04cb4aae249cbb59a2fc01549150db6bca314aac9dd9e24c603d3f5b
pkgname = geant4
diff --git a/PKGBUILD b/PKGBUILD
index 80225e8693f4..bb0129f03011 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -36,7 +36,7 @@ install="${pkgname}.install"
source=("http://cern.ch/geant4-data/releases/${pkgname}.${_pkgver}.tar.gz"
"${pkgname}.install")
sha256sums=('4b05b4f7d50945459f8dbe287333b9efb772bd23d50920630d5454ec570b782d'
- '36e2d2bff5fc753e8abaa1a5da10710c030512b926d33c1977687d7b47672bd4')
+ '173be29c04cb4aae249cbb59a2fc01549150db6bca314aac9dd9e24c603d3f5b')
## Remove this if you want to keep an even smaller package
## No need to wait for compression when just installing it.
diff --git a/geant4.install b/geant4.install
index 55c0a6ee5416..295e50da5538 100644
--- a/geant4.install
+++ b/geant4.install
@@ -1,16 +1,20 @@
#!/bin/sh
_init() {
- variables=("G4ABLADATA" \
- "G4ENSDFSTATEDATA" \
- "G4LEDATA" \
- "G4LEVELGAMMADATA" \
- "G4NEUTRONHPDATA" \
- "G4NEUTRONXSDATA" \
- "G4PIIDATA" \
- "G4RADIOACTIVEDATA" \
- "G4REALSURFACEDATA" \
- "G4SAIDXSDATA" )
+ variables=( "G4NEUTRONHPDATA" \
+ "G4LEDATA" \
+ "G4LEVELGAMMADATA" \
+ "G4RADIOACTIVEDATA" \
+ "G4PARTICLEXSDATA" \
+ "G4PIIDATA" \
+ "G4REALSURFACEDATA" \
+ "G4SAIDXSDATA" \
+ "G4ABLADATA" \
+ "G4INCLDATA" \
+ "G4ENSDFSTATEDATA" \
+ "G4PARTICLEHPDATA" \ # not included by default anyway
+ "G4NEUTRONXS" \ # to be removed
+ )
shell=("sh" "csh")
@@ -27,6 +31,10 @@ _read() {
_init
for _varname in ${variables[*]}
do
+ if [ "$_varname" == "G4NEUTRONXS" ] # to be removed
+ then
+ continue
+ fi
for _ext in ${shell[*]}
do
sed -n /${_varname}/p ${path}/geant4.${_ext} >> $existing.${_ext}