summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMageJohn2017-06-17 14:31:45 +0100
committerMageJohn2017-06-17 14:43:27 +0100
commit372a77c01dac0c06de0f7324fea811396cf06380 (patch)
treec74c2e4766d02f76d7fea05aae912f8f4c44e5be
parentd9d05d62c70b064c2ebd0dd90a0d4462d14dd863 (diff)
downloadaur-372a77c01dac0c06de0f7324fea811396cf06380.tar.gz
Line up with the latest script from spotify package
There were recent problems with openssl, which required several changes to the spotify package to solve. This lines up the changes.
-rw-r--r--PKGBUILD5
-rwxr-xr-xspotify-adkiller-dns-block2
2 files changed, 3 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 44bc287b2ae8..2e534b75f8c8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=spotify-adkiller-dns-block-git
pkgver=r82.1184e1e
-pkgrel=2
+pkgrel=3
pkgdesc='Experimental dns blocking from Spotify AdKiller'
arch=('i686' 'x86_64')
url=https://github.com/SecUpwN/Spotify-AdKiller
@@ -15,9 +15,8 @@ source=("git+$url.git#branch=dns-block"
"${pkgname%-git}"
"${pkgname%-git}.desktop")
sha512sums=('SKIP'
- 'e123b737cc4360eaf57f2fd75db733b735d61d4b738d32f93de93d94da246923b97c0c90541c6719593702292e0f746d2e60b8205ef45eacfd82901251dfae5c'
+ 'da8d84b492ec11e97bd24bee38c3483e5da065fa1b936c8b37fa8bf1c756c16f282a4ac5c2ec667684b31c08ea14d451e38fab64d012cd565ed2b137b699264b'
'3a38a5634ef8fb82212f44b021b614bbad2682129ec21a5e90fd00fc60f66da025cb61a3960d7b16b12e7d54773bb3cc4f9c14b867febabb3e2cd232a7455686')
-
pkgver() {
cd "${url##*/}"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
diff --git a/spotify-adkiller-dns-block b/spotify-adkiller-dns-block
index 33358a5fe244..4eec7aa19268 100755
--- a/spotify-adkiller-dns-block
+++ b/spotify-adkiller-dns-block
@@ -1,3 +1,3 @@
#!/bin/sh
-export LD_PRELOAD="/usr/lib/spotify-adkiller-dns-block/dns-block.so libcrypto-compat.so.1.0.0 libssl-compat.so.1.0.0 libcurl-openssl-1.0.so"
+export LD_PRELOAD="/usr/lib/spotify-adkiller-dns-block/dns-block.so libcurl.so.3"
/usr/share/spotify/spotify "$@"