summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Matson2017-04-22 21:39:38 -0700
committerDavid Matson2017-04-23 15:00:36 -0700
commit38ebb06f0fb9adf15c108c5493320ec6cb7ae785 (patch)
treea2d46b86d83bf8585a0125718e0c3912f440ba01
parent07067d4a6a374fc7c295a8ef57982d1036fafca7 (diff)
downloadaur-38ebb06f0fb9adf15c108c5493320ec6cb7ae785.tar.gz
Simplify configure arguments.
Move libfreeswitch.so to /usr/lib per Arch packaging standards.
-rw-r--r--PKGBUILD24
1 files changed, 9 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3ac35d521004..43eb278a1368 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -135,22 +135,16 @@ build() {
cp "${srcdir}"/modules.conf .
- ./configure --enable-optimization --disable-debug --prefix=/usr \
- --sysconfdir=/etc --localstatedir=/var --libdir=/usr/lib/freeswitch \
- --includedir=/usr/include/freeswitch \
- --with-modinstdir=/usr/lib/freeswitch/mod --with-rundir=/run \
- --with-logfiledir=/var/log/freeswitch --with-dbdir=/var/lib/freeswitch/db \
- --with-htdocsdir=/usr/share/freeswitch/htdocs \
- --with-fontsdir=/usr/share/freeswitch/fonts \
- --with-soundsdir=/usr/share/freeswitch/sounds \
- --with-grammardir=/usr/share/freeswitch/grammar \
- --with-certsdir=/etc/freeswitch/tls \
- --with-scriptdir=/usr/share/freeswitch/scripts \
- --with-recordingsdir=/var/lib/freeswitch/recordings \
- --with-imagesdir=/usr/share/freeswitch/images \
- --with-storagedir=/var/lib/freeswitch/storage \
+ ./configure \
+ --enable-optimization \
+ --disable-debug \
+ --prefix=/usr \
+ --localstatedir=/var \
+ --sysconfdir=/etc \
+ --with-rundir=/run \
+ --with-logfiledir=/var/log/freeswitch \
--with-cachedir=/var/cache/freeswitch \
- --with-pkgconfigdir=/usr/lib/pkgconfig \
+ --with-imagesdir=/usr/share/freeswitch/images \
${_mod_options[@]}
make