summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrien Smith2023-11-26 16:26:16 -0700
committerAdrien Smith2023-11-26 16:26:16 -0700
commit3a58d25af08a7feb49d425975c08d61dc9685a3d (patch)
tree84084e6bdb28dd34617b41a16af1aaa35dae62e1
parentd54ba3dbacd64b5ed1c1824b3f8a759af80e9f8a (diff)
downloadaur-3a58d25af08a7feb49d425975c08d61dc9685a3d.tar.gz
upgpkg: mlat-client-git 0.2.13.r0.gfe70767-1
upstream release removed old patch, switching to new packaging method
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD25
-rw-r--r--mlat-client-git.changelog12
-rw-r--r--python-function-names.patch31
4 files changed, 29 insertions, 52 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2a0b5b6e912f..e3b5dd233335 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mlat-client-git
pkgdesc = Mode S multilateration client by Mutability
- pkgver = 0.2.12.r0.g16924db
- pkgrel = 2
+ pkgver = 0.2.13.r0.gfe70767
+ pkgrel = 1
url = https://github.com/mutability/mlat-client
changelog = mlat-client-git.changelog
arch = i686
@@ -11,16 +11,17 @@ pkgbase = mlat-client-git
arch = aarch64
license = GPL3
makedepends = git
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
+ makedepends = python-setuptools
depends = python
provides = mlat-client
provides = fa-mlat-client
conflicts = mlat-client
conflicts = fa-mlat-client
- source = mlat-client::git+https://github.com/mutability/mlat-client.git#branch=dev
- source = python-function-names.patch
+ source = git+https://github.com/mutability/mlat-client.git#branch=dev
sha256sums = SKIP
- sha256sums = c3645a1535418c1c0b083f101c07b8243c1ac947e21f07a501c868d95c3bf43c
b2sums = SKIP
- b2sums = 123f866478b0100dce0efbca8db88a302ddc50aedf82153da6aa097874f6319908eceb1edb274f16edc8c6f09a51d56800d687c44aaf57dda2b698f4885e2a14
pkgname = mlat-client-git
diff --git a/PKGBUILD b/PKGBUILD
index 0313c4df944d..aff8fbe42ae0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,23 +4,20 @@
# Contributor: Dan Schaper <dschaper at ganymeade dot com>
pkgname=mlat-client-git
-pkgver=0.2.12.r0.g16924db
-pkgrel=2
+pkgver=0.2.13.r0.gfe70767
+pkgrel=1
pkgdesc="Mode S multilateration client by Mutability"
arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
url="https://github.com/mutability/${pkgname%-git}"
license=('GPL3')
depends=('python')
-makedepends=('git')
+makedepends=('git' python-{build,installer,wheel} python-setuptools)
provides=("${pkgname%-git}" "fa-${pkgname%-git}")
conflicts=("${pkgname%-git}" "fa-${pkgname%-git}")
changelog="$pkgname.changelog"
-source=("${pkgname%-git}::git+$url.git#branch=dev"
- "python-function-names.patch")
-sha256sums=('SKIP'
- 'c3645a1535418c1c0b083f101c07b8243c1ac947e21f07a501c868d95c3bf43c')
-b2sums=('SKIP'
- '123f866478b0100dce0efbca8db88a302ddc50aedf82153da6aa097874f6319908eceb1edb274f16edc8c6f09a51d56800d687c44aaf57dda2b698f4885e2a14')
+source=("git+$url.git#branch=dev")
+sha256sums=('SKIP')
+b2sums=('SKIP')
pkgver() {
cd "${pkgname%-git}"
@@ -29,18 +26,16 @@ pkgver() {
prepare() {
cd "${pkgname%-git}"
- patch --forward --strip=1 --input="${srcdir}/python-function-names.patch"
+ git -C "${srcdir}/${pkgname%-git}" clean -dfx # ensure no old build artifacts
}
build() {
cd "${pkgname%-git}"
- ./setup.py build
+ python -m build -wn
}
package() {
cd "${pkgname%-git}"
- ./setup.py install --prefix="${pkgdir}/usr"
- install -Dm755 -t "${pkgdir}/usr/lib/piaware/helpers/" fa-mlat-client
- install -Dm755 -t "${pkgdir}/usr/bin/" mlat-client
- rm -f "${pkgdir}/usr/bin/fa-mlat-client"
+ python -m installer --destdir="$pkgdir" dist/*.whl
+ install -Dm755 -t "${pkgdir}/usr/lib/piaware/helpers/" "${pkgdir}/usr/bin/fa-mlat-client"
}
diff --git a/mlat-client-git.changelog b/mlat-client-git.changelog
index 7e67ad00721b..2ecccddfe9a1 100644
--- a/mlat-client-git.changelog
+++ b/mlat-client-git.changelog
@@ -1,3 +1,15 @@
+mlat-client (0.2.13) stable; urgency=medium
+
+ * Support for Python 3.11 PyFloat_Unpack4 API change
+ * Move the CLI scripts {fa-,}mlat-client into their respective packages;
+ replace the existing scripts with setuptools APIs
+ * Add a pyproject.toml with most of the build metadata. setup.py is still needed
+ for building with older Python and for the extension module.
+ * Switch package builds to use pybuild, since everything should be recent enough
+ for that now.
+
+ -- Oliver Jowett <oliver.jowett@flightaware.com> Mon, 23 Oct 2023 19:52:21 +0800
+
mlat-client (0.2.12) stable; urgency=medium
* Treat a wider range of timestamps as synthetic
diff --git a/python-function-names.patch b/python-function-names.patch
deleted file mode 100644
index d8b3b1cb3757..000000000000
--- a/python-function-names.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-diff --unified --recursive --text mlat-client/modes_reader.c mlat-client.new/modes_reader.c
---- mlat-client/modes_reader.c 2023-07-29 19:28:28.326973012 -0600
-+++ mlat-client.new/modes_reader.c 2023-07-29 19:34:48.801995009 -0600
-@@ -503,6 +503,19 @@
- {
- float lat, lon, alt;
-
-+#if PY_MAJOR_VERSION >= 3 && PY_MINOR_VERSION >=11
-+ lat = PyFloat_Unpack4(data + 4, 1);
-+ if (lat == -1.0 && PyErr_Occurred())
-+ return NULL;
-+
-+ lon = PyFloat_Unpack4(data + 8, 1);
-+ if (lon == -1.0 && PyErr_Occurred())
-+ return NULL;
-+
-+ alt = PyFloat_Unpack4(data + 12, 1);
-+ if (alt == -1.0 && PyErr_Occurred())
-+ return NULL;
-+#else
- lat = _PyFloat_Unpack4(data + 4, 1);
- if (lat == -1.0 && PyErr_Occurred())
- return NULL;
-@@ -514,6 +527,7 @@
- alt = _PyFloat_Unpack4(data + 12, 1);
- if (alt == -1.0 && PyErr_Occurred())
- return NULL;
-+#endif
-
- return Py_BuildValue("{s:f,s:f,s:f}",
- "lat", lat,