summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick Northon2023-09-10 03:10:19 -0400
committerPatrick Northon2023-09-10 03:10:19 -0400
commit3a988cf6bc4ed3fa66899dca7862ee1b82e7868c (patch)
tree5f6715fd06bc3be4f884b3c1cd975fdcf9688c37
parent2ede184a5c14303697e6ad9ac02b41080b8fd329 (diff)
downloadaur-3a988cf6bc4ed3fa66899dca7862ee1b82e7868c.tar.gz
Bump version, fix dependencies and compile.
-rw-r--r--.AURINFO16
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD40
3 files changed, 30 insertions, 36 deletions
diff --git a/.AURINFO b/.AURINFO
deleted file mode 100644
index 44ba313bfb27..000000000000
--- a/.AURINFO
+++ /dev/null
@@ -1,16 +0,0 @@
-pkgbase = cloog
- pkgdesc = Library that generates loops for scanning polyhedra
- pkgver = 0.18.1
- pkgrel = 3
- url = http://www.bastoul.net/cloog/
- arch = i686
- arch = x86_64
- license = GPL
- depends = isl
- source = http://www.bastoul.net/cloog/pages/download/cloog-0.18.1.tar.gz
- source = cloog-0.18.1-isl-compat.patch
- md5sums = e34fca0540d840e5d0f6427e98c92252
- md5sums = 976c999b44c6e364455a670d12523242
-
-pkgname = cloog
-
diff --git a/.SRCINFO b/.SRCINFO
index 510799e07299..6edf522aac1b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = cloog
pkgdesc = Library that generates loops for scanning polyhedra
- pkgver = 0.20.0
- pkgrel = 2
+ pkgver = 0.21.1
+ pkgrel = 1
url = http://www.bastoul.net/cloog/
arch = i686
arch = x86_64
@@ -9,9 +9,11 @@ pkgbase = cloog
license = GPL
makedepends = texlive-core
makedepends = texlive-bin
+ makedepends = texlive-plaingeneric
depends = osl
depends = libisl
- source = https://github.com/periscop/cloog/releases/download/cloog-0.20.0/cloog-0.20.0.tar.gz
- sha512sums = d00cbefd348b45d9d482320a088f7ae736440046b99469cbdfbb177a38dcef182c3305f0a567a1f5699c23b7108db6fd5ad6dfbc071d63ccca1d6bfc1b198565
+ depends = gmp
+ source = https://github.com/periscop/cloog/releases/download/cloog-0.21.1/cloog-0.21.1.tar.gz
+ sha512sums = bfb76bc69941ba0ddd81f1d52d807c02cd24e5baf3d8b774148712494e256709531e4ceb0402309ed2596a2a3ee951dc6bcc4e21502199942e2bd9dab705c9f2
pkgname = cloog
diff --git a/PKGBUILD b/PKGBUILD
index 11bdcfbb9dce..9ce9a1e2f5f9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,41 @@
-# Maintainer: Aaron Fischer <mail@aaron-fischer.net>
+# Maintainer: Patrick Northon <northon_patrick3@yahoo.ca>
+# Contributor: Aaron Fischer <mail@aaron-fischer.net>
# Contributor: Allan McRae <allan@archlinux.org>
pkgname=cloog
-pkgver=0.20.0
-pkgrel=2
+pkgver=0.21.1
+pkgrel=1
pkgdesc="Library that generates loops for scanning polyhedra"
arch=('i686' 'x86_64' 'armv7h')
url="http://www.bastoul.net/cloog/"
license=('GPL')
-depends=('osl' 'libisl')
-makedepends=('texlive-core' 'texlive-bin')
-source=(https://github.com/periscop/cloog/releases/download/$pkgname-$pkgver/$pkgname-$pkgver.tar.gz)
-sha512sums=('d00cbefd348b45d9d482320a088f7ae736440046b99469cbdfbb177a38dcef182c3305f0a567a1f5699c23b7108db6fd5ad6dfbc071d63ccca1d6bfc1b198565')
+depends=('osl' 'libisl' 'gmp')
+makedepends=('texlive-core' 'texlive-bin' 'texlive-plaingeneric')
+source=("https://github.com/periscop/cloog/releases/download/$pkgname-$pkgver/$pkgname-$pkgver.tar.gz")
+sha512sums=('bfb76bc69941ba0ddd81f1d52d807c02cd24e5baf3d8b774148712494e256709531e4ceb0402309ed2596a2a3ee951dc6bcc4e21502199942e2bd9dab705c9f2')
+
+_srcdir="${pkgname}-${pkgver}"
+
+prepare() {
+ cd "${_srcdir}"
+ sed -i 's/OSL_CPPFLAGS+="/OSL_CPPFLAGS="$OSL_CPPFLAGS/' 'configure'
+}
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- ./configure --prefix=/usr --with-isl=system --with-osl=system
- make
+ cd "${_srcdir}"
+ ./configure --prefix=/usr --with-cloog-int=gmp --with-isl=system --with-osl=system --with-osl-prefix=/usr
+ make
}
check() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- # There are certain race conditions on running the tests, so we restrict
- # it to one job (one CPU core).
+ cd "${_srcdir}"
+ # There are certain race conditions on running the tests, so we restrict
+ # it to one job (one CPU core).
- make -j1 check
+ make -j1 check
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- make DESTDIR=$pkgdir/ install
+ cd "${_srcdir}"
+ DESTDIR="$pkgdir" make install
}