summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVladimír Vondruš2023-08-02 16:28:41 +0200
committerVladimír Vondruš2023-08-02 16:29:07 +0200
commit3bed6737f5c71425cb5a1d636630d6fc01819861 (patch)
tree961f25c078b31abf244212a1fa98103243b2df64
parentd768c8511a4d6d74888a0827182c885381b5733e (diff)
downloadaur-3bed6737f5c71425cb5a1d636630d6fc01819861.tar.gz
Version 0.19.
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD15
-rw-r--r--no-error.patch13
3 files changed, 8 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bdcc87652ae9..f0cd16af169e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,13 @@
pkgbase = meshoptimizer
pkgdesc = Mesh optimization library that makes meshes smaller and faster to render
- pkgver = 0.18
- pkgrel = 2
+ pkgver = 0.19
+ pkgrel = 1
url = https://github.com/zeux/meshoptimizer
arch = x86_64
license = MIT
makedepends = cmake
makedepends = ninja
- source = https://github.com/zeux/meshoptimizer/archive/v0.18.tar.gz
- source = no-error.patch
- sha256sums = f5bc07d7322e6292fe0afce03462b5c394d111386236f926fdc44d2aff3b854b
- sha256sums = edeadacc492247229d8558bea91b16610171b36ca68caa680f8680f7952d7af6
+ source = https://github.com/zeux/meshoptimizer/archive/v0.19.tar.gz
+ sha256sums = e334292ef29351387a79767e348f4bedb7645a0a9169be6bfa23bafa8ddc6ed4
pkgname = meshoptimizer
diff --git a/PKGBUILD b/PKGBUILD
index 0b42536532e3..65594262a6dd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,14 @@
# Author: mosra <mosra@centrum.cz>
pkgname=meshoptimizer
-pkgver=0.18
-pkgrel=2
+pkgver=0.19
+pkgrel=1
pkgdesc='Mesh optimization library that makes meshes smaller and faster to render'
arch=(x86_64)
url='https://github.com/zeux/meshoptimizer'
license=(MIT)
makedepends=(cmake ninja)
-source=("https://github.com/zeux/meshoptimizer/archive/v$pkgver.tar.gz"
- "no-error.patch")
-sha256sums=('f5bc07d7322e6292fe0afce03462b5c394d111386236f926fdc44d2aff3b854b'
- 'edeadacc492247229d8558bea91b16610171b36ca68caa680f8680f7952d7af6')
-
-prepare() {
- cd "$srcdir/meshoptimizer-$pkgver"
- patch -p1 < $srcdir/no-error.patch
-}
+source=("https://github.com/zeux/meshoptimizer/archive/v$pkgver.tar.gz")
+sha256sums=('e334292ef29351387a79767e348f4bedb7645a0a9169be6bfa23bafa8ddc6ed4')
build() {
mkdir -p build && cd build
diff --git a/no-error.patch b/no-error.patch
deleted file mode 100644
index 157dcced15ff..000000000000
--- a/no-error.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index b13d946..dc20be0 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -57,7 +57,7 @@ set(GLTF_SOURCES
- if(MSVC)
- add_compile_options(/W4 /WX)
- else()
-- add_compile_options(-Wall -Wextra -Wshadow -Wno-missing-field-initializers -Werror)
-+ add_compile_options(-Wall -Wextra -Wshadow -Wno-missing-field-initializers)
- endif()
-
- if(MESHOPT_BUILD_SHARED_LIBS)