summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Wells2022-12-03 08:18:27 -0500
committerDavid Wells2022-12-03 08:18:27 -0500
commit3cf290ce85f5d6defed3f99f65107f1cd17c2ee5 (patch)
treef8947d72b36e8fe84daa0bcf0595bacc6b74f08a
parentf55c4f7572d34317c7d793fafa9068e269b4ccce (diff)
downloadaur-3cf290ce85f5d6defed3f99f65107f1cd17c2ee5.tar.gz
Update to 9.4.1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a4310df4e004..36aa06ecdc3e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = deal-ii
pkgdesc = An Open Source Finite Element Differential Equations Analysis Library
- pkgver = 9.4.0
+ pkgver = 9.4.1
pkgrel = 1
url = http://www.dealii.org/
install = deal-ii.install
@@ -32,7 +32,7 @@ pkgbase = deal-ii
optdepends = trilinos: object-oriented software framework for the solution of large-scale, complex multi-physics engineering and scientific problems
optdepends = suitesparse: A collection of sparse matrix libraries
optdepends = zlib: Compression library implementing the deflate compression method found in gzip and PKZIP
- source = https://github.com/dealii/dealii/releases/download/v9.4.0/dealii-9.4.0.tar.gz
- sha1sums = fd8ff7b934026b144cde2a904f21a8ad7d8244df
+ source = https://github.com/dealii/dealii/releases/download/v9.4.1/dealii-9.4.1.tar.gz
+ sha1sums = c49bb0d3f0341674b5e3865df730fbef7a2a9d5c
pkgname = deal-ii
diff --git a/PKGBUILD b/PKGBUILD
index 68d3e4452626..71ab4a8e9297 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=deal-ii
_realname=dealii
-pkgver=9.4.0
+pkgver=9.4.1
pkgrel=1
pkgdesc="An Open Source Finite Element Differential Equations Analysis Library"
arch=("i686" "x86_64")
@@ -31,7 +31,6 @@ optdepends=(
'petsc: Portable, extensible toolkit for scientific computation'
'scalapack: subset of scalable LAPACK routines redesigned for distributed memory MIMD parallel computers'
'slepc: Scalable library for Eigenvalue problem computations'
- # deal.II is not compatible with sundials 6.0 or newer yet
'sundials: Suite of nonlinear differential/algebraic equation solvers'
'symengine: Fast symbolic manipulation library'
'tbb: High level abstract threading library'
@@ -42,7 +41,7 @@ optdepends=(
makedepends=('cmake')
install=deal-ii.install
source=(https://github.com/dealii/dealii/releases/download/v$pkgver/${_realname}-$pkgver.tar.gz)
-sha1sums=('fd8ff7b934026b144cde2a904f21a8ad7d8244df')
+sha1sums=('c49bb0d3f0341674b5e3865df730fbef7a2a9d5c')
# where to install deal.II: change to something else (e.g., /opt/deal.II/)
# if desired.
_installation_prefix=/usr
@@ -112,6 +111,9 @@ build() {
sed -i '122ifedisableexcept(FE_INVALID);\n' \
${srcdir}/${_realname}-$pkgver/tests/quick_tests/scalapack.cc
+ sed -i '146i#include <boost/algorithm/string/case_conv.hpp>\n' \
+ ${srcdir}/${_realname}-$pkgver/examples/step-70/step-70.cc
+
# Also remove from LDFLAGS if necessary
LDFLAGS=$(echo $LDFLAGS | sed 's/--as-needed,//')
@@ -129,7 +131,6 @@ build() {
-DCMAKE_INSTALL_MESSAGE=NEVER -DCMAKE_CXX_FLAGS=" $extra_warning_flags" \
-DDEAL_II_SHARE_RELDIR=share/${pkgname}/ \
-DDEAL_II_EXAMPLES_RELDIR=share/${pkgname}/examples/ \
- -DDEAL_II_WITH_SUNDIALS=OFF \
-DDEAL_II_COMPONENT_DOCUMENTATION=OFF ${srcdir}/${_realname}-$pkgver
# deal.II needs about 3 GB/compilation process so use fewer jobs if your