summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorScore_Under2022-12-21 22:20:31 +0000
committerScore_Under2022-12-21 22:20:31 +0000
commit3d4658f3997427a4bac8a9cfedfbc2a52fd46fd0 (patch)
tree55564c582f576f0d2fd717055e4138493c6e1bc4
parentad62ea53b9ba6f3420eb84ea242f35a8f5cc9e94 (diff)
downloadaur-3d4658f3997427a4bac8a9cfedfbc2a52fd46fd0.tar.gz
Update for v511
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rw-r--r--paths-in-opt.patch14
3 files changed, 13 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 15f15464d6ca..86681406ab87 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = hydrus
pkgdesc = Danbooru-like image tagging and searching system for the desktop
- pkgver = 510
+ pkgver = 511
pkgrel = 1
url = http://hydrusnetwork.github.io/hydrus/
install = hydrus.install
@@ -38,13 +38,13 @@ pkgbase = hydrus
conflicts = hydrus-docs
conflicts = hydrus-sources
options = !strip
- source = hydrus::git+https://github.com/hydrusnetwork/hydrus.git#commit=d4913d8d43229b482d34db9e0c9a87e6eb1bb025
+ source = hydrus::git+https://github.com/hydrusnetwork/hydrus.git#commit=9b2d5f53b8d7bd36c3b95b89071d820b5e867e6f
source = paths-in-opt.patch
source = hydrus-client
source = hydrus-server
source = hydrus.desktop
sha256sums = SKIP
- sha256sums = 0607fdbcd9d4e7115c0cc3b533c68a72b45a631a2d15f838e05cc15654a26345
+ sha256sums = 061490f052086dadf453c208834f14b48f101eb1a95e29e8dee4960f8a72e74d
sha256sums = d2cb826ce0dd1892ab95fc3b14dbe6bd312210f653d0aea31938eeb7e361fdc5
sha256sums = 463841cc16059b516cc327cfbc30d3383e2236b085ba2d503e82f5be39444806
sha256sums = 9b8c2603a8040ae80152ff9a718ad3e8803fdc3029a939e3c0e932ea35ded923
diff --git a/PKGBUILD b/PKGBUILD
index 9829b0ea3c88..4d38debb5599 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ DOC_DIRS=(opt/hydrus/help)
pkgname=hydrus
_pkgname=hydrus
-pkgver=510
+pkgver=511
pkgrel=1
pkgdesc="Danbooru-like image tagging and searching system for the desktop"
arch=(any)
@@ -24,13 +24,13 @@ optdepends=('ffmpeg: show duration and other information on video thumbnails'
'python-cloudscraper: bypass cloudflare "checking your browser" challenges'
'python-pyqt6-charts: display bandwidth usage charts'
'python-pyopenssl: to generate certificates for accessing client API and server via HTTPS')
-source=("${_pkgname}::git+https://github.com/hydrusnetwork/${_pkgname}.git#commit=d4913d8d43229b482d34db9e0c9a87e6eb1bb025"
+source=("${_pkgname}::git+https://github.com/hydrusnetwork/${_pkgname}.git#commit=9b2d5f53b8d7bd36c3b95b89071d820b5e867e6f"
paths-in-opt.patch
hydrus-client
hydrus-server
hydrus.desktop)
sha256sums=('SKIP'
- '0607fdbcd9d4e7115c0cc3b533c68a72b45a631a2d15f838e05cc15654a26345'
+ '061490f052086dadf453c208834f14b48f101eb1a95e29e8dee4960f8a72e74d'
'd2cb826ce0dd1892ab95fc3b14dbe6bd312210f653d0aea31938eeb7e361fdc5'
'463841cc16059b516cc327cfbc30d3383e2236b085ba2d503e82f5be39444806'
'9b8c2603a8040ae80152ff9a718ad3e8803fdc3029a939e3c0e932ea35ded923')
diff --git a/paths-in-opt.patch b/paths-in-opt.patch
index ab18ff928b54..82c7c5b5f399 100644
--- a/paths-in-opt.patch
+++ b/paths-in-opt.patch
@@ -1,8 +1,8 @@
diff --git a/hydrus/client/gui/ClientGUI.py b/hydrus/client/gui/ClientGUI.py
-index 4b5b1d84..687142fe 100644
+index 95b81fc6..73b02fbf 100644
--- a/hydrus/client/gui/ClientGUI.py
+++ b/hydrus/client/gui/ClientGUI.py
-@@ -6102,7 +6102,7 @@ class FrameGUI( ClientGUITopLevelWindows.MainFrameThatResizes, CAC.ApplicationCo
+@@ -6184,7 +6184,7 @@ class FrameGUI( ClientGUITopLevelWindows.MainFrameThatResizes, CAC.ApplicationCo
python_executable = python_executable.replace( 'pythonw', 'python' )
@@ -12,12 +12,12 @@ index 4b5b1d84..687142fe 100644
cmd = [ python_executable, server_script_path, db_param ]
diff --git a/hydrus/core/HydrusConstants.py b/hydrus/core/HydrusConstants.py
-index 17d995c9..785922d2 100644
+index fab89f7f..21a89dea 100644
--- a/hydrus/core/HydrusConstants.py
+++ b/hydrus/core/HydrusConstants.py
-@@ -7,34 +7,9 @@ import yaml
- # old method of getting frozen dir, doesn't work for symlinks looks like:
- # BASE_DIR = getattr( sys, '_MEIPASS', None )
+@@ -10,34 +10,9 @@ import yaml
+ RUNNING_CLIENT = False
+ RUNNING_SERVER = False
-RUNNING_FROM_FROZEN_BUILD = getattr( sys, 'frozen', False )
-
@@ -53,7 +53,7 @@ index 17d995c9..785922d2 100644
muh_platform = sys.platform.lower()
-@@ -46,32 +21,16 @@ PLATFORM_HAIKU = muh_platform == 'haiku1'
+@@ -49,32 +24,16 @@ PLATFORM_HAIKU = muh_platform == 'haiku1'
RUNNING_FROM_SOURCE = sys.argv[0].endswith( '.py' ) or sys.argv[0].endswith( '.pyw' )
RUNNING_FROM_MACOS_APP = os.path.exists( os.path.join( BASE_DIR, 'running_from_app' ) )