summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAmish2020-04-14 11:46:12 +0530
committerAmish2020-04-14 11:46:12 +0530
commit3e072cda412b52feb76dccc5cfb8c3354643d407 (patch)
treef35f1e26eee82006bbb759c6e114c23e20f56252
parentfe284c41ddacdf5a72c8d92acf8e9a0fa5a3d93e (diff)
downloadaur-3e072cda412b52feb76dccc5cfb8c3354643d407.tar.gz
Update to 2.9.16 and Update latest OpenAppID
-rw-r--r--.SRCINFO12
-rw-r--r--001-gettid.patch17
-rw-r--r--PKGBUILD19
3 files changed, 11 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f73f669f446e..51ebf456dba3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = snort-nfqueue
pkgdesc = A lightweight network IDS / IPS with NFQUEUE and OpenAppID support.
- pkgver = 2.9.15
+ pkgver = 2.9.16
pkgrel = 1
url = https://www.snort.org
install = snort.install
@@ -37,16 +37,14 @@ pkgbase = snort-nfqueue
backup = etc/snort/reference.config
backup = etc/snort/classification.config
backup = etc/logrotate.d/snort
- source = https://www.snort.org/downloads/snort/snort-2.9.15.tar.gz
- source = snort-openappid.tar.gz::https://snort.org/downloads/openappid/11581
- source = 001-gettid.patch
+ source = https://www.snort.org/downloads/snort/snort-2.9.16.tar.gz
+ source = snort-openappid-12159.tar.gz::https://snort.org/downloads/openappid/12159
source = snort.logrotate
source = snort.sysusers
source = snort.tmpfiles
source = snort.service
- sha256sums = bfb437746446ef72a03c501db13cd6da5edd2b41f55c80c437ba288be6da7dba
- sha256sums = 7582fc56d1412881d21eafaa081cc93a586ca7f68e8e00e62c77da37de8c5424
- sha256sums = a1e451b8e580645a60314781c75ba57502e9a1539b28f29b10a46ddc411dceba
+ sha256sums = 9688d8edf1da09dec6574000fb3c0e62f99c56428587616e17c60103c0bcbad7
+ sha256sums = 5a90c213dcc1f6f2de3702b816ef4f97b76b59bb16c6da80b6275dc030335b0b
sha256sums = 7fe712141f651254b8e5aa0b3b7d73622d2d1d89bf53d7a522f8c1a067938421
sha256sums = ae3245c5de527fb487c459f2f4a9c78803ae6341e9c81b9a404277679cdee051
sha256sums = a92c591c409fc06661865988795093b0fb0447f614ac77951dbf9b1f6a8cf139
diff --git a/001-gettid.patch b/001-gettid.patch
deleted file mode 100644
index 00873b919e60..000000000000
--- a/001-gettid.patch
+++ /dev/null
@@ -1,17 +0,0 @@
---- a/src/util.h
-+++ b/src/util.h
-@@ -374,6 +374,7 @@ static inline int IsEmptyStr(const char *str)
- return 0;
- }
-
-+#if !defined(__GLIBC__) || !defined(__GLIBC_PREREQ) || !__GLIBC_PREREQ(2, 30)
- static inline pid_t gettid(void)
- {
- #if defined(LINUX) && defined(SYS_gettid)
-@@ -382,5 +383,6 @@ static inline pid_t gettid(void)
- return getpid();
- #endif
- }
-+#endif
-
- #endif /*__UTIL_H__*/
diff --git a/PKGBUILD b/PKGBUILD
index 78d6d1681242..002f63e905a2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,8 @@
pkgname=snort-nfqueue
_pkgname=snort
-pkgver=2.9.15
+_openappid=12159
+pkgver=2.9.16
pkgrel=1
pkgdesc='A lightweight network IDS / IPS with NFQUEUE and OpenAppID support.'
arch=('i686' 'x86_64')
@@ -29,30 +30,22 @@ backup=('etc/snort/snort.conf'
options=('!makeflags' '!libtool')
install=snort.install
source=("https://www.snort.org/downloads/snort/${_pkgname}-${pkgver}.tar.gz"
- 'snort-openappid.tar.gz::https://snort.org/downloads/openappid/11581'
- '001-gettid.patch'
+ "snort-openappid-${_openappid}.tar.gz::https://snort.org/downloads/openappid/${_openappid}"
'snort.logrotate'
'snort.sysusers'
'snort.tmpfiles'
'snort.service')
-sha256sums=('bfb437746446ef72a03c501db13cd6da5edd2b41f55c80c437ba288be6da7dba'
- '7582fc56d1412881d21eafaa081cc93a586ca7f68e8e00e62c77da37de8c5424'
- 'a1e451b8e580645a60314781c75ba57502e9a1539b28f29b10a46ddc411dceba'
+sha256sums=('9688d8edf1da09dec6574000fb3c0e62f99c56428587616e17c60103c0bcbad7'
+ '5a90c213dcc1f6f2de3702b816ef4f97b76b59bb16c6da80b6275dc030335b0b'
'7fe712141f651254b8e5aa0b3b7d73622d2d1d89bf53d7a522f8c1a067938421'
'ae3245c5de527fb487c459f2f4a9c78803ae6341e9c81b9a404277679cdee051'
'a92c591c409fc06661865988795093b0fb0447f614ac77951dbf9b1f6a8cf139'
'b904ed172ea0c1a4eeaddb30745aadb8db21e333eb9faaf93400ce3db166f90d')
-prepare() {
- cd "${srcdir}/${_pkgname}-${pkgver}"
- patch -p1 -i ../001-gettid.patch
-}
-
build() {
cd "${srcdir}/${_pkgname}-${pkgver}"
./configure --prefix=/usr --sysconfdir=/etc/snort --with-libpcap-includes=/usr/include/pcap \
- --with-daq-includes=/usr/include --with-daq-libraries=/usr/lib/daq/ \
- --enable-zlib --disable-static-daq \
+ --with-daq-includes=/usr/include --with-daq-libraries=/usr/lib/daq/ --disable-static-daq \
CPPFLAGS="$CPPFLAGS -I/usr/include/tirpc/"
make
}