summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorendorfina2023-11-08 22:56:43 +0100
committerendorfina2023-11-08 23:00:29 +0100
commit40add07ab86fdef786572757df689c69c22cf9de (patch)
tree21847231066b43acd916da63de7576cb55432575
parenteff217972604891a7df7e455299d5cc6e97d9969 (diff)
downloadaur-40add07ab86fdef786572757df689c69c22cf9de.tar.gz
Updated to 5.8:
evdi dependency was set to <1.15 to avoid breaking the driver in the future
-rw-r--r--.SRCINFO20
-rw-r--r--99-displaylink.rules20
-rw-r--r--PKGBUILD25
-rw-r--r--displaylink-release-notes-5.8.txt (renamed from displaylink-release-notes-5.7.txt)37
4 files changed, 62 insertions, 40 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 38165da27b38..78175a6f8f72 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
pkgbase = displaylink
- pkgdesc = Linux driver for DL-6xxx, DL-5xxx, DL-41xx and DL-3x00
- pkgver = 5.7
- pkgrel = 1
+ pkgdesc = Linux driver for DisplayLink devices
+ pkgver = 5.8
+ pkgrel = 0
url = https://www.synaptics.com/products/displaylink-graphics
- changelog = displaylink-release-notes-5.7.txt
+ changelog = displaylink-release-notes-5.8.txt
arch = i686
arch = x86_64
arch = arm
@@ -16,20 +16,20 @@ pkgbase = displaylink
makedepends = grep
makedepends = gawk
makedepends = wget
- depends = evdi
+ depends = evdi<1.15
depends = libusb
- source = displaylink-driver-5.7.zip::https://www.synaptics.com/sites/default/files/exe_files/2023-04/DisplayLink%20USB%20Graphics%20Software%20for%20Ubuntu5.7-EXE.zip
- source = displaylink-release-notes-5.7.txt
+ source = displaylink-driver-5.8.zip::https://www.synaptics.com/sites/default/files/exe_files/2023-08/DisplayLink%20USB%20Graphics%20Software%20for%20Ubuntu5.8-EXE.zip
+ source = displaylink-release-notes-5.8.txt
source = DISPLAYLINK-EULA
source = udev.sh
source = 99-displaylink.rules
source = displaylink.service
source = displaylink-sleep.sh
- sha256sums = 807f1c203ac1e71c6f1f826493b9bb32e277f07cb2cf48537bf8cfdc68dd1515
- sha256sums = 24e6c5f72f38252bdd3eab1777c418e2490dc5f7606400baa4d956ec425e002f
+ sha256sums = 22c552ead448c80d9e8dd48a842bb511184d07a74180ac76bd89dd144ddda816
+ sha256sums = 83167d307d030abc42f2bbe6ad6a23802433cf5d8fab50afb0d519036518f22b
sha256sums = 2f81fea43332a62b2cf1dd47e56ea01caf1e886bcd16c3f82b18bfe148fb21a9
sha256sums = dc41ae8a2c287fc50fdda65bad8b0ffd76726f7773c25e1b0c5b7de95cecbdb6
- sha256sums = c08a4726cf4e2f92c7cab00168ae9cc8d69d36a67c570609396a4a674934245a
+ sha256sums = 530c488fa9b2833ff64611ff2b533f63212a85f8ebed446d5a4d51cf9a52c7ea
sha256sums = 342e83abfe2a38d5635ea928345e933d2ad127ebd3f7caca476663d4f583684b
sha256sums = 8be4ab7616e38f91746bdd3e7fafe9004322a8be8e6722389746df9868d576e0
diff --git a/99-displaylink.rules b/99-displaylink.rules
index 3d2cc078917f..db2035a8623b 100644
--- a/99-displaylink.rules
+++ b/99-displaylink.rules
@@ -1,5 +1,19 @@
-# Copyright (c) 2016 DisplayLink (UK) Ltd.
+# Copyright (c) 2016 - 2022 DisplayLink (UK) Ltd.
# File autogenerated by udev-installer.sh script
-ACTION=="add", SUBSYSTEM=="usb", DRIVERS=="usb", ATTRS{idVendor}=="17e9", ATTR{bInterfaceClass}=="ff", ATTR{bInterfaceProtocol}=="03", ENV{ID_DISPLAYLINK_DEVICE}="1", RUN+="/opt/displaylink/udev.sh START"
-ACTION=="remove", ENV{ID_DISPLAYLINK_DEVICE}=="1", RUN+="/opt/displaylink/udev.sh STOP $env{DEVPATH}"
+ACTION=="add|change", SUBSYSTEM=="usb", DRIVERS=="usb", ATTR{idVendor}=="17e9", IMPORT{builtin}="usb_id", ENV{DISPLAYLINK_DEVNAME}="$env{DEVNAME}", ENV{DISPLAYLINK_DEVICE_ID}="$env{ID_BUS}-$env{BUSNUM}-$env{DEVNUM}-$env{ID_SERIAL}"
+
+ACTION=="add", SUBSYSTEM=="usb", DRIVERS=="usb", ATTRS{idVendor}=="17e9", \
+ ATTR{bInterfaceClass}=="ff", ATTR{bInterfaceProtocol}=="03", IMPORT{parent}="DISPLAYLINK*", \
+ RUN+="/opt/displaylink/udev.sh $root $devpath $env{DISPLAYLINK_DEVICE_ID} $env{DISPLAYLINK_DEVNAME}"
+
+ACTION=="remove", ENV{PRODUCT}=="17e9/*", RUN+="/opt/displaylink/udev.sh $root $env{DEVNAME}"
+
+# udev rules configuring DisplayLink usb ethernet device
+IMPORT{builtin}="usb_id"
+
+ACTION=="add|move|bind", ENV{ID_USB_DRIVER}=="cdc_ncm", ATTRS{idVendor}=="17e9", \
+ ATTR{cdc_ncm/rx_max}=="?*", ATTR{cdc_ncm/dwNtbInMaxSize}=="?*", ATTR{cdc_ncm/rx_max}="$attr{cdc_ncm/dwNtbInMaxSize}"
+ACTION=="add|move|bind", ENV{ID_USB_DRIVER}=="cdc_ncm", ATTRS{idVendor}=="17e9", \
+ ATTR{cdc_ncm/tx_max}=="?*", ATTR{cdc_ncm/dwNtbOutMaxSize}=="?*", ATTR{cdc_ncm/tx_max}="$attr{cdc_ncm/dwNtbOutMaxSize}"
+
diff --git a/PKGBUILD b/PKGBUILD
index 64208d7244cb..a6e0e09fead1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,19 @@
-# Maintainer: rHermes <teodor_spaeren@riseup.net>
-# Maintainer: bnavigator <code@bnavigator.de>
+# Maintainer: endorfina <emilia@carcosa.space>
+# Contributor: rHermes <teodor_spaeren@riseup.net>
+# Contributor: bnavigator <code@bnavigator.de>
# Contributor: PlusMinus
# Contributor: rhabbachi
pkgname=displaylink
-pkgver=5.7
-_releasedate=2023-04
-_pkgfullver=5.7.0-61.129
-pkgrel=1
-pkgdesc="Linux driver for DL-6xxx, DL-5xxx, DL-41xx and DL-3x00"
+pkgver=5.8
+_releasedate=2023-08
+_pkgfullver=5.8.0-63.33
+pkgrel=0
+pkgdesc="Linux driver for DisplayLink devices"
arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h' 'aarch64')
url="https://www.synaptics.com/products/displaylink-graphics"
license=('custom' 'GPL2' 'LGPL2.1')
-depends=('evdi'
+depends=('evdi<1.15'
'libusb')
makedepends=('grep' 'gawk' 'wget')
changelog="displaylink-release-notes-${pkgver}.txt"
@@ -23,11 +24,11 @@ source=(displaylink-driver-${pkgver}.zip::https://www.synaptics.com/sites/defaul
99-displaylink.rules
displaylink.service
displaylink-sleep.sh)
-sha256sums=('807f1c203ac1e71c6f1f826493b9bb32e277f07cb2cf48537bf8cfdc68dd1515'
- '24e6c5f72f38252bdd3eab1777c418e2490dc5f7606400baa4d956ec425e002f'
+sha256sums=('22c552ead448c80d9e8dd48a842bb511184d07a74180ac76bd89dd144ddda816'
+ '83167d307d030abc42f2bbe6ad6a23802433cf5d8fab50afb0d519036518f22b'
'2f81fea43332a62b2cf1dd47e56ea01caf1e886bcd16c3f82b18bfe148fb21a9'
'dc41ae8a2c287fc50fdda65bad8b0ffd76726f7773c25e1b0c5b7de95cecbdb6'
- 'c08a4726cf4e2f92c7cab00168ae9cc8d69d36a67c570609396a4a674934245a'
+ '530c488fa9b2833ff64611ff2b533f63212a85f8ebed446d5a4d51cf9a52c7ea'
'342e83abfe2a38d5635ea928345e933d2ad127ebd3f7caca476663d4f583684b'
'8be4ab7616e38f91746bdd3e7fafe9004322a8be8e6722389746df9868d576e0')
@@ -42,7 +43,7 @@ prepare() {
}
package() {
- echo "Adding udev rule for DisplayLink DL-3xxx/5xxx devices"
+ echo "Adding udev rule for DisplayLink devices"
install -D -m644 99-displaylink.rules "$pkgdir/etc/udev/rules.d/99-displaylink.rules"
install -D -m755 udev.sh "$pkgdir/opt/displaylink/udev.sh"
diff --git a/displaylink-release-notes-5.7.txt b/displaylink-release-notes-5.8.txt
index c8b4adb6e327..f7ad2791619d 100644
--- a/displaylink-release-notes-5.7.txt
+++ b/displaylink-release-notes-5.8.txt
@@ -3,12 +3,12 @@
DisplayLink Ubuntu Software Release Note
-Version: v5.7.0
-Build: posix/61-1827-g47ede9c19c2 (129)
+Version: v5.8.0
+Build: posix/63-3581-g15996285140 (33)
-Date: 24th March 2023
+Date: 21st July 2023
-Extensible Virtual Display Interface version included: v1.13-6 (85a347a)
+Extensible Virtual Display Interface version included: v1.14.1 (83bb793)
=============================================================================
=============================================================================
@@ -16,23 +16,23 @@ Extensible Virtual Display Interface version included: v1.13-6 (85a347a)
A. Introduction
===============
-This is DisplayLink Driver Software v5.7.0 for Ubuntu. It provides production quality support for DisplayLink USB 3.0 devices on specific variants of desktop Ubuntu Linux.
+This is DisplayLink Driver Software v5.8.0 for Ubuntu. It provides production quality support for DisplayLink USB 3.0 devices on specific variants of desktop Ubuntu Linux.
-The driver enables video support for products using DisplayLink USB 3.0 technology. Standard native Ubuntu drivers provide support for DisplayLink audio and Ethernet interfaces.
+The driver enables video support for products using DisplayLink USB 3.0 technology. Standard native Ubuntu drivers provide support for DisplayLink audio and ethernet interfaces.
-A1. Important notes about DL-6xxx, DL5xxx, DL-3x00 and DL-41xx Firmware
+A1. Important notes about DisplayLink firmware
=======================================================================
-This software release contains an embedded firmware image. DL-6xxx, DL-5xxx, DL-3xxx and DL-41xx devices will be automatically upgraded with this firmware upon connection if required.
+This software release contains an embedded firmware image. DL-7xxx, DL-6xxx, DL-5xxx, DL-3xxx and DL-41xx devices will be automatically upgraded with this firmware upon connection if required.
-The upgrade is silent, therefore screens connected to DL-6xxx, DL-5xxx, DL-3xxx or DL-41xx devices may require a few seconds to appear when devices are connected for the first time, or after devices have been used on other platforms and OSes.
+The upgrade is silent, therefore screens connected to DisplayLink devices may require a few seconds to appear when devices are connected for the first time, or after devices have been used on other platforms and OSes.
B. Contents
===========
A. Introduction
-A1. Important notes about DL-6xxx, DL-5xxx, DL-3xxx and DL-41xx firmware
+A1. Important notes about DisplayLink firmware
B. Contents
C. Changes in this release
D. Supported O/S variants
@@ -45,6 +45,13 @@ I. Future development
C. Bugs fixed in this release
==============================
+C.8 Changes in 5.8 release
+-----------------------------
+- Alpha support for DisplayLink DL-7400 products
+- Support for new DisplayLink DL-6150 products
+- Support for Ubuntu 23.04
+- Added preliminary support for kernel 6.5
+
C.7 Changes in 5.7 release
-----------------------------
- New driver distribution channel via Synaptics apt repository (https://www.synaptics.com/sites/default/files/Ubuntu/)
@@ -116,7 +123,7 @@ This release has been prepared to be compatible with Ubuntu 23.04, 22.04, 21.10,
Other variants and editions may be compatible if they meet minimum O/S requirements, but are not supported by DisplayLink.
The Software contains binaries which work on i686, amd64, armv7 and aarch64 architectures.
-Supported Linux Kernel version range is from 4.15 to 6.2.
+Supported Linux Kernel version range is from 4.15 to 6.5.
Minimum supported Xorg version is 1.16, minimum supported Mutter (Wayland) version is 3.32.
E. Release components
@@ -146,6 +153,7 @@ This driver will support up to 2 displays connected to DisplayLink devices. More
Resolutions up to 4K are supported on the appropriate DisplayLink hardware.
Device families supported:
+- DL-7xxx
- DL-6xxx
- DL-5xxx
- DL-41xx
@@ -159,15 +167,14 @@ H. Limitations & known issues
A list of limitations and known issues can be found here:
http://support.displaylink.com/knowledgebase/articles/641668
+- Gnome with Wayland or X11 desktop support up to four 4k display in a row. (PS-2955)
+Anything wider might cause mouse issues or video glitches.
+
- Fail to rotate display on three-monitor desktop on Ubuntu 22.10 (PS-2230)
https://gitlab.gnome.org/GNOME/gnome-control-center/-/issues/2113
Please make selected monitor layout rightmost (or leftmost) first, apply the preferred orientation, then setup correct
monitor order as a mitigation.
-- DisplayLink display is black on plug-in and user is logged-out when moving cursor on DisplayLink display on Ubuntu 22.10 (PS-2397)
-https://gitlab.gnome.org/GNOME/mutter/-/issues/2481
-Please update to Ubuntu 23.04.
-
- When displayLink-driver debian package is installed first time with GUI application like Synaptic and Secure Boot is
enabled then installation will fail.
How to use DisplayLink Ubuntu driver with UEFI Secure Boot (https://support.displaylink.com/knowledgebase/articles/1181617-how-to-use-displaylink-ubuntu-driver-with-uefi-sec)