summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorScore_Under2023-05-11 01:33:12 +0100
committerScore_Under2023-05-11 01:33:12 +0100
commit414baa16f7d5efcb49a3a1acb06c0dc3629fe754 (patch)
treef33672bdcd689a2aab975df08b4ecbcc480ff34e
parentcef22508e8b89763a36fdd096184e5dae221446e (diff)
downloadaur-414baa16f7d5efcb49a3a1acb06c0dc3629fe754.tar.gz
Update for v527
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD12
-rw-r--r--hydrus-client2
-rw-r--r--hydrus-server2
-rw-r--r--paths-in-opt.patch8
5 files changed, 18 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3f7346aa71db..4f16878ae99b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = hydrus
pkgdesc = Danbooru-like image tagging and searching system for the desktop
- pkgver = 526
+ pkgver = 527
pkgrel = 1
url = http://hydrusnetwork.github.io/hydrus/
arch = any
@@ -27,7 +27,7 @@ pkgbase = hydrus
depends = python-typing_extensions
depends = python-service-identity
depends = pyside6
- depends = hydrus-docs>=526
+ depends = hydrus-docs>=527
optdepends = ffmpeg: show duration and other information on video thumbnails
optdepends = miniupnpc: automatic port forwarding
optdepends = desktop-file-utils: to add Hydrus to your desktop environment menus
@@ -41,15 +41,15 @@ pkgbase = hydrus
optdepends = python-pyopenssl: to generate certificates for accessing client API and server via HTTPS
optdepends = swftools: to display SWF thumbnails
options = !strip
- source = hydrus::git+https://github.com/hydrusnetwork/hydrus.git#commit=7bfe474a5d7af0b5ea11343e7b91ec25fb7d0651
+ source = hydrus::git+https://github.com/hydrusnetwork/hydrus.git#commit=4b2b15e152e4bed900aa972c7d4b27f7bf242f29
source = paths-in-opt.patch
source = hydrus-client
source = hydrus-server
source = hydrus.desktop
sha256sums = SKIP
- sha256sums = b196485720ed874a22fe49a48ce92db423dda12824b2755071bbf47cfc891bc0
- sha256sums = d2cb826ce0dd1892ab95fc3b14dbe6bd312210f653d0aea31938eeb7e361fdc5
- sha256sums = 463841cc16059b516cc327cfbc30d3383e2236b085ba2d503e82f5be39444806
+ sha256sums = c332728ca119b1ed4e9a4f40de79087fa90f8754535718b506954d375541f9f0
+ sha256sums = 39d3404b75320be6a9e33dc256f4fc313c65fe11458e96bd5af6268c2f78eaf0
+ sha256sums = 5956d418d29fe19f54263acf47adce7c6d134d19ec65e2810d4517ce83529480
sha256sums = 9b8c2603a8040ae80152ff9a718ad3e8803fdc3029a939e3c0e932ea35ded923
pkgname = hydrus
diff --git a/PKGBUILD b/PKGBUILD
index bfa1c506c78c..9383ba265ed0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ options=(!strip) # Don't strip libs because there aren't any
pkgname=hydrus
_pkgname=hydrus
-pkgver=526
+pkgver=527
pkgrel=1
pkgdesc="Danbooru-like image tagging and searching system for the desktop"
arch=(any)
@@ -31,15 +31,15 @@ optdepends=('ffmpeg: show duration and other information on video thumbnails'
# 'python-pyparsing: currently unused'
# 'speedcopy: may speed up file transfers'
'swftools: to display SWF thumbnails')
-source=("${_pkgname}::git+https://github.com/hydrusnetwork/${_pkgname}.git#commit=7bfe474a5d7af0b5ea11343e7b91ec25fb7d0651"
+source=("${_pkgname}::git+https://github.com/hydrusnetwork/${_pkgname}.git#commit=4b2b15e152e4bed900aa972c7d4b27f7bf242f29"
paths-in-opt.patch
hydrus-client
hydrus-server
hydrus.desktop)
sha256sums=('SKIP'
- 'b196485720ed874a22fe49a48ce92db423dda12824b2755071bbf47cfc891bc0'
- 'd2cb826ce0dd1892ab95fc3b14dbe6bd312210f653d0aea31938eeb7e361fdc5'
- '463841cc16059b516cc327cfbc30d3383e2236b085ba2d503e82f5be39444806'
+ 'c332728ca119b1ed4e9a4f40de79087fa90f8754535718b506954d375541f9f0'
+ '39d3404b75320be6a9e33dc256f4fc313c65fe11458e96bd5af6268c2f78eaf0'
+ '5956d418d29fe19f54263acf47adce7c6d134d19ec65e2810d4517ce83529480'
'9b8c2603a8040ae80152ff9a718ad3e8803fdc3029a939e3c0e932ea35ded923')
prepare() {
@@ -59,7 +59,7 @@ package() {
# Create /opt/hydrus and copy hydrus files to there
install -m755 -d "${pkgdir}/opt/hydrus"
- cp -r hydrus static client.pyw server.py "${pkgdir}/opt/hydrus/"
+ cp -r hydrus static hydrus_client.py hydrus_server.py "${pkgdir}/opt/hydrus/"
# Remove unit tests
rm -rf "${pkgdir}/opt/hydrus/hydrus/test" "${pkgdir}/opt/hydrus/static/testing"
diff --git a/hydrus-client b/hydrus-client
index 16b14ba225f3..e3ee4e9ab70f 100644
--- a/hydrus-client
+++ b/hydrus-client
@@ -1,2 +1,2 @@
#!/bin/sh
-exec python -OO /opt/hydrus/client.pyw "$@"
+exec python -OO /opt/hydrus/hydrus_client.py "$@"
diff --git a/hydrus-server b/hydrus-server
index ea3cd3fce25a..9bc319d4d458 100644
--- a/hydrus-server
+++ b/hydrus-server
@@ -1,2 +1,2 @@
#!/bin/sh
-exec python -OO /opt/hydrus/server.py "$@"
+exec python -OO /opt/hydrus/hydrus_server.py "$@"
diff --git a/paths-in-opt.patch b/paths-in-opt.patch
index 273fe4c68ddc..0c80dc15c19c 100644
--- a/paths-in-opt.patch
+++ b/paths-in-opt.patch
@@ -1,18 +1,18 @@
diff --git a/hydrus/client/gui/ClientGUI.py b/hydrus/client/gui/ClientGUI.py
-index 8ed3a258..a63c53ac 100644
+index 2d2db51a..6096f3ec 100644
--- a/hydrus/client/gui/ClientGUI.py
+++ b/hydrus/client/gui/ClientGUI.py
@@ -6153,7 +6153,7 @@ class FrameGUI( CAC.ApplicationCommandProcessorMixin, ClientGUITopLevelWindows.M
python_executable = python_executable.replace( 'pythonw', 'python' )
-- server_script_path = os.path.join( HC.BASE_DIR, 'server.py' )
-+ server_script_path = '/opt/hydrus/server.py'
+- server_script_path = os.path.join( HC.BASE_DIR, 'hydrus_server.py' )
++ server_script_path = '/opt/hydrus/hydrus_server.py'
cmd = [ python_executable, server_script_path, db_param ]
diff --git a/hydrus/core/HydrusConstants.py b/hydrus/core/HydrusConstants.py
-index b38f7432..4d71fbd9 100644
+index 35765379..bbe24f67 100644
--- a/hydrus/core/HydrusConstants.py
+++ b/hydrus/core/HydrusConstants.py
@@ -11,34 +11,9 @@ import yaml