summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristophe LAVIE2021-06-29 09:46:04 +0200
committerChristophe LAVIE2021-06-29 09:46:04 +0200
commit41ee3325ae2af957b7ff87c4a38033461f02ef84 (patch)
treeae25b3081b5d08c78cece667db7d1c027cdf41ef
parentcc5851a4b58efedc2606be54c2e58a042f20299a (diff)
downloadaur-41ee3325ae2af957b7ff87c4a38033461f02ef84.tar.gz
version 5.1.5-245.2 : adobe-air-sdk dependencie revocation
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD19
2 files changed, 10 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ede1415a7773..d884945c6d98 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,12 @@
pkgbase = devolo-dlan-cockpit
pkgdesc = Display and configure settings of your devolo device
pkgver = 5.1.5.245
- pkgrel = 1
+ pkgrel = 2
url = https://www.devolo.com/support/downloads/download/devolo-cockpit.html
install = devolo-dlan-cockpit.install
arch = i686
arch = x86_64
license = nonfree
- depends = adobe-air-sdk>=2.6
depends = libgnome-keyring
source = https://www.devolo.fr/fileadmin/Web-Content/DE/products/hnw/devolo-cockpit/software/devolo-cockpit-v5-1-5-245-linux.run
source = devolonetsvc.service
@@ -15,4 +14,3 @@ pkgbase = devolo-dlan-cockpit
sha256sums = 6f187ca5c7a599b5394ea09cd68885168dbd19b5bd72df5ce083e721e2f0a12c
pkgname = devolo-dlan-cockpit
-
diff --git a/PKGBUILD b/PKGBUILD
index 1ea298cbd5cb..41c84df5edfb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
# Maintainer: Christophe LAVIE <christophe.lavie@laposte.net>
-# Contributor: Christophe LAVIE <christophe.lavie@laposte.net> 20/03/2021
+# Contributor: Christophe LAVIE <christophe.lavie@laposte.net> 28/06/2021
pkgname=devolo-dlan-cockpit
pkgver=5.1.5.245
-pkgrel=1
+pkgrel=2
name=devolo-cockpit-v${pkgver//./-}-linux.run
install=${pkgname}.install
pkgdesc="Display and configure settings of your devolo device"
arch=('i686' 'x86_64')
url="https://www.devolo.com/support/downloads/download/devolo-cockpit.html"
license=('nonfree')
-depends=( 'adobe-air-sdk>=2.6' 'libgnome-keyring')
+depends=( 'libgnome-keyring')
if [ "${CARCH}" = "x86_64" ]; then
_arch="amd64"
@@ -27,18 +27,17 @@ build() {
tail $name -n +$((skip+1)) | tar -x -C .
ar x "devolo-dlan-cockpit_${pkgver}-0_${_arch}.deb"
find . -name "adobeair*${_arch}.deb" -print | xargs ar x
- tar xJf data.tar.xz
+ tar xJf data.tar.lzma
sed -i 's/\.appdata\//~\/\.appdata\//g' "${srcdir}/opt/devolo/dlancockpit/bin/dlancockpit-run.sh"
echo "StartupWMClass=dlancockpit" >> "${srcdir}/usr/share/applications/devolo-dlan-cockpit.desktop"
}
package() {
- cp -r "${srcdir}/opt" "${srcdir}/usr" "${pkgdir}/"
- ln -s "/opt/adobe-air-sdk/runtimes/air/linux/Adobe AIR/" "${pkgdir}/opt/Adobe AIR"
- mkdir -p "${pkgdir}/var/lib/devolonetsvc"
- printf "<?xml version="1.0" encoding="utf-8"?>\n<data_collection><allowed>2</allowed></data_collection>" > "${srcdir}/config.xml"
- install -Dm644 "${srcdir}/config.xml" "${pkgdir}/var/lib/devolonetsvc/config.xml"
- install -Dm644 "${srcdir}/devolonetsvc.service" "${pkgdir}/usr/lib/systemd/system/devolonetsvc.service"
+ cp -r "${srcdir}/opt" "${srcdir}/usr" "${pkgdir}/"
+ mkdir -p "${pkgdir}/var/lib/devolonetsvc"
+ printf "<?xml version="1.0" encoding="utf-8"?>\n<data_collection><allowed>2</allowed></data_collection>" > "${srcdir}/config.xml"
+ install -Dm644 "${srcdir}/config.xml" "${pkgdir}/var/lib/devolonetsvc/config.xml"
+ install -Dm644 "${srcdir}/devolonetsvc.service" "${pkgdir}/usr/lib/systemd/system/devolonetsvc.service"
}
sha256sums=('1515e4726f8b2ae4a1514cc5c498dfe3c56d7db84cb6c627641499b9569f4954'