summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom van den Brink2021-06-19 10:21:34 +0200
committerTom van den Brink2021-06-19 10:21:34 +0200
commit423f2c4c2c116cc40101166b0da3bc4aa1e5eb93 (patch)
tree32a2c9b391a765bab4dcfc5fa65eee694e32c4dc
parente5448b654c3bd745316e6ace1ed9afd03e70e828 (diff)
downloadaur-423f2c4c2c116cc40101166b0da3bc4aa1e5eb93.tar.gz
Update to 0_99_7822 rel=1
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD6
-rwxr-xr-xmakeSmath.sh10
3 files changed, 11 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3896ac1f288e..122961962171 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = smath
pkgdesc = A mathematical program with many features and paper-like interface, similar to Mathcad
- pkgver = 0_99_7808
+ pkgver = 0_99_7822
pkgrel = 1
url = http://smath.info
install = smath.install
@@ -10,8 +10,7 @@ pkgbase = smath
license = CCPL
depends = mono
backup = opt/smath/settings.inf
- source = https://smath.com/file/or3Ts/SMathStudioDesktop.0_99_7808.Mono.tar.gz
- md5sums = 97dd0818b5d79b890b1c098edc8d0767
+ source = https://smath.com/file/oVRx7/SMathStudioDesktop.0_99_7822.Mono.tar.gz
+ md5sums = ebc96a19031857031069b5d2d208ac73
pkgname = smath
-
diff --git a/PKGBUILD b/PKGBUILD
index 6508e9d2849b..0c7c4f938bdc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,10 +8,10 @@
# http://smath.info
pkgname=smath
-pkgver=0_99_7808
+pkgver=0_99_7822
pkgrel=1
pkgdesc="A mathematical program with many features and paper-like interface, similar to Mathcad"
-_pkgcode=or3Ts
+_pkgcode=oVRx7
arch=('i686' 'x86_64')
url="http://smath.info"
license=('CCPL')
@@ -20,7 +20,7 @@ depends=('mono')
install=smath.install
backup=(opt/$pkgname/settings.inf)
source=("https://smath.com/file/${_pkgcode}/SMathStudioDesktop.${pkgver}.Mono.tar.gz")
-md5sums=('97dd0818b5d79b890b1c098edc8d0767')
+md5sums=('ebc96a19031857031069b5d2d208ac73')
DLAGENTS=("https::/usr/bin/wget --post-data RefMem=&PostBack=${_pkgcode} %u")
package() {
diff --git a/makeSmath.sh b/makeSmath.sh
index 887563b6a8ad..3adfe3bd459a 100755
--- a/makeSmath.sh
+++ b/makeSmath.sh
@@ -1,8 +1,8 @@
#!/bin/bash
-_pkgcode=5TGzK
-pkgver=0_99_7030
-pkgrel=2
+_pkgcode=oVRx7
+pkgver=0_99_7822
+pkgrel=1
wget --post-data "RefMem=&PostBack=${_pkgcode}" https://smath.com/file/${_pkgcode}/SMathStudioDesktop.${pkgver}.Mono.tar.gz
@@ -17,8 +17,8 @@ sed -i "23s/.*/md5sums=\(\'${_pkgmd5sum}\'\)/" PKGBUILD
rm SMathStudioDesktop.${pkgver}.Mono.tar.gz
makepkg --printsrcinfo > .SRCINFO
-#First do the git commit by hand
-git add PKGBUILD .SRCINFO
+
+git add PKGBUILD .SRCINFO makeSmath.sh
git commit -m "Update to ${pkgver} rel=${pkgrel}"
# git push