summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip Sequeira2022-07-08 02:43:39 -0400
committerPhilip Sequeira2022-07-08 02:43:39 -0400
commit430584bbcbed0399dfb73e51ceb3d26b17a10694 (patch)
tree9c70c525db1fb13e7456da1ea6fc25688106c6e6
parent95b81dc746448a815b8b7912f6a47796d639dd0c (diff)
downloadaur-430584bbcbed0399dfb73e51ceb3d26b17a10694.tar.gz
explicitly enable luajit, x11, wayland, libplacebo by default
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD22
2 files changed, 21 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9572ea31ff83..065c18398b15 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mpv-git
pkgdesc = Video player based on MPlayer/mplayer2 (git version)
- pkgver = 0.34.0_351_g45ff20986d
+ pkgver = 0.34.0_368_g6858fc7d80
pkgrel = 1
url = https://mpv.io
install = mpv.install
@@ -17,6 +17,13 @@ pkgbase = mpv-git
makedepends = vulkan-headers
depends = ffmpeg
depends = hicolor-icon-theme
+ depends = luajit
+ depends = libxinerama
+ depends = libxpresent
+ depends = libxss
+ depends = wayland
+ depends = libxkbcommon
+ depends = libplacebo
optdepends = yt-dlp: for video-sharing websites playback (preferred over youtube-dl)
optdepends = youtube-dl: for video-sharing websites playback
provides = mpv
diff --git a/PKGBUILD b/PKGBUILD
index 308fec9cf4de..c68aa91061ae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,13 +12,15 @@ _opt_features=(
#sdl2
#openal
- # Lua is automatically detected, so you don't need to enable these if you
- # already have it installed. If you have both lua52 and luajit installed, mpv
- # will use the former. Uncommenting luajit below will tell mpv to use that
- # even if lua52 is also installed.
+ # mpv supports lua52 and luajit, and will automatically enable Lua support if
+ # either is installed. If both are installed, it will choose lua52. The choice
+ # is made at compile time and only one of the two can be enabled. The two
+ # options below, when uncommented, will force selection of their respective
+ # implementations even if the other is installed, as well as adding the
+ # appropriate dependency.
#lua
- #luajit
+ luajit
# The rest of these are autodetected, and are just provided to set
# dependencies the first time you build. If you have the dependencies
@@ -26,8 +28,10 @@ _opt_features=(
#javascript
- #x11
- #wayland
+ x11
+ wayland
+
+ libplacebo # Vulkan and vo=gpu-next (latter sometimes needs libplacebo-git)
#uchardet
#rubberband
@@ -47,7 +51,7 @@ _opt_features=(
pkgname=mpv-git
_gitname=mpv
-pkgver=0.34.0_351_g45ff20986d
+pkgver=0.34.0_368_g6858fc7d80
pkgrel=1
pkgdesc='Video player based on MPlayer/mplayer2 (git version)'
arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
@@ -103,7 +107,7 @@ for feature in "${_opt_features[@]}"; do
depends+=('wayland' 'libxkbcommon')
_opt_extra_flags+=('-Dwayland=enabled')
;;
- sdl2|openal|uchardet|rubberband)
+ sdl2|openal|libplacebo|uchardet|rubberband)
depends+=("$feature")
_opt_extra_flags+=("-D${feature}=enabled")
;;