summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJingbei Li2020-07-31 23:19:35 +0800
committerJingbei Li2020-07-31 23:19:35 +0800
commit430f7ddf106531fdf0e94ccaf42485aafb42e816 (patch)
treeab7e909d5b8e4d934c8a395c54b6e1f044d1452f
parentd84d734be70559f9b3ad858b896397ad520819d8 (diff)
downloadaur-430f7ddf106531fdf0e94ccaf42485aafb42e816.tar.gz
upgraded to 1.7.0.rc1
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD5
2 files changed, 6 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 31502348aa26..eb8883dcb08b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mxnet
pkgdesc = Flexible and Efficient Library for Deep Learning
- pkgver = 1.7.0.rc0
+ pkgver = 1.7.0.rc1
pkgrel = 1
url = http://mxnet.io/
arch = x86_64
@@ -27,7 +27,7 @@ pkgbase = mxnet
depends = python-numpy
depends = python-requests
optdepends = python-graphviz
- source = mxnet::git+https://github.com/apache/incubator-mxnet#tag=1.7.0.rc0
+ source = mxnet::git+https://github.com/apache/incubator-mxnet#tag=1.7.0.rc1
source = git+https://github.com/dmlc/dlpack
source = git+https://github.com/dmlc/dmlc-core
source = git+https://github.com/google/googletest
diff --git a/PKGBUILD b/PKGBUILD
index 151a02ab756e..a914fb84a1b2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Carl Ã…kerlindh <carl.akerlindh at gmail dot com>
pkgbase=mxnet
pkgname=('mxnet' 'mxnet-cuda' 'mxnet-mkl' 'mxnet-mkl-cuda')
-pkgver=1.7.0.rc0
+pkgver=1.7.0.rc1
pkgrel=1
pkgdesc="Flexible and Efficient Library for Deep Learning"
arch=('x86_64')
@@ -104,6 +104,8 @@ prepare() {
cd "$srcdir/$pkgbase"
git submodule update --init --recursive
+ rm -rf 3rdparty/nvidia_cub
+
# https://github.com/apache/incubator-mxnet/pull/18357
git checkout 78e31d6 src/operator/tensor/elemwise_binary_broadcast_op_basic.cc
@@ -150,6 +152,7 @@ build() {
cuda_args=(
-DUSE_OPENCV:BOOL=OFF
-DUSE_NCCL:BOOL=ON
+ -DMXNET_CUDA_ARCH='5.0;6.0;7.0;7.5;8.0'
-DCMAKE_C_COMPILER=/opt/cuda/bin/gcc
-DCMAKE_CXX_COMPILER=/opt/cuda/bin/g++
)