summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Botting2018-11-05 15:41:29 +1100
committerAndy Botting2018-11-05 15:41:29 +1100
commit438f8bf495bd1092e6f5f34250e0f155483bbff7 (patch)
treeea5f46c2b7daafdcfc966feaa4788c766c6108e7
parent6d7a49fee3da019c5f8fe5b5f24b3cadee1aca4e (diff)
downloadaur-438f8bf495bd1092e6f5f34250e0f155483bbff7.tar.gz
Update to v1.30.0-1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
-rw-r--r--fix-expected-servers-test.patch20
3 files changed, 5 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 181813296a35..af6543eb6261 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-shade
pkgdesc = Simple client library for interacting with OpenStack clouds
- pkgver = 1.29.0
+ pkgver = 1.30.0
pkgrel = 1
url = http://docs.openstack.org/infra/shade
arch = any
@@ -60,10 +60,8 @@ pkgbase = python-shade
makedepends = git
makedepends = python-setuptools
makedepends = python2-setuptools
- source = git+https://git.openstack.org/openstack-infra/shade#tag=1.29.0
- source = fix-expected-servers-test.patch
+ source = git+https://git.openstack.org/openstack-infra/shade#tag=1.30.0
sha512sums = SKIP
- sha512sums = 17f10a4712b64824080671ac2f739fb4684b78fb84e639605b448fff6fefd43e48d6db9083b51c09b82a39cc6d232fc71c9e49a47ef0611ab98a1e7d1f320cda
pkgname = python-shade
depends = python-pbr
diff --git a/PKGBUILD b/PKGBUILD
index 54409f5884b9..80256823b587 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_module='shade'
pkgname=('python-shade' 'python2-shade')
-pkgver='1.29.0'
+pkgver='1.30.0'
pkgrel='1'
pkgdesc='Simple client library for interacting with OpenStack clouds'
arch=('any')
@@ -35,16 +35,13 @@ checkdepends=('python-pbr' 'python2-pbr'
'python-testtools' 'python2-testtools'
'python-stestr' 'python2-stestr'
'python-oslotest' 'python2-oslotest')
-source=("git+https://git.openstack.org/openstack-infra/${_module}#tag=${pkgver}"
- 'fix-expected-servers-test.patch')
-sha512sums=('SKIP'
- '17f10a4712b64824080671ac2f739fb4684b78fb84e639605b448fff6fefd43e48d6db9083b51c09b82a39cc6d232fc71c9e49a47ef0611ab98a1e7d1f320cda')
+source=("git+https://git.openstack.org/openstack-infra/${_module}#tag=${pkgver}")
+sha512sums=('SKIP')
prepare() {
# Fix test function name
cd "${srcdir}/${_module}"
sed -i 's/assertItemsEqual/assertCountEqual/g' shade/tests/unit/*.py
- patch -p1 -i "${srcdir}/fix-expected-servers-test.patch"
cp -a "${srcdir}/${_module}"{,-py2}
}
diff --git a/fix-expected-servers-test.patch b/fix-expected-servers-test.patch
deleted file mode 100644
index cc45d31c1060..000000000000
--- a/fix-expected-servers-test.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-diff --git a/shade/tests/unit/test_normalize.py b/shade/tests/unit/test_normalize.py
-index 08d135ae..ad37ff84 100644
---- a/shade/tests/unit/test_normalize.py
-+++ b/shade/tests/unit/test_normalize.py
-@@ -578,7 +578,6 @@ class TestUtils(base.RequestsMockTestCase):
- u'version': 4}]},
- 'adminPass': None,
- 'created': u'2015-08-01T19:52:16Z',
-- 'created_at': u'2015-08-01T19:52:16Z',
- 'disk_config': u'MANUAL',
- 'flavor': {u'id': u'bbcb7eb5-5c8d-498f-9d7e-307c575d3566'},
- 'has_config_drive': True,
-@@ -650,7 +649,6 @@ class TestUtils(base.RequestsMockTestCase):
- 'cloud': '_test_cloud_',
- 'config_drive': u'True',
- 'created': u'2015-08-01T19:52:16Z',
-- 'created_at': u'2015-08-01T19:52:16Z',
- 'disk_config': u'MANUAL',
- 'flavor': {u'id': u'bbcb7eb5-5c8d-498f-9d7e-307c575d3566'},
- 'has_config_drive': True,