summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdam Goldsmith2020-07-20 00:25:13 -0400
committerAdam Goldsmith2020-07-20 00:25:13 -0400
commit44671f540ff745e9756db39c775d1903e78b65c3 (patch)
treec3a38a1061f60f21ebc7699dcfc6dc28ccfc07a1
parent55c9c51c02d63edcf8c1370a41c9f408f29d9788 (diff)
downloadaur-44671f540ff745e9756db39c775d1903e78b65c3.tar.gz
Add .desktop file, add symlinks for icons
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD16
-rw-r--r--SideQuest.desktop10
3 files changed, 26 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 503bf2f61815..e60606c9ceec 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = sidequest-bin
pkgdesc = Easily sideload apps onto your standalone android VR headset
pkgver = 0.10.11
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/the-expanse/SideQuest
arch = x86_64
license = MIT
@@ -10,7 +10,9 @@ pkgbase = sidequest-bin
depends = nss
conflicts = sidequest
source = https://github.com/the-expanse/SideQuest/releases/download/v0.10.11/SideQuest-0.10.11.tar.xz
+ source = SideQuest.desktop
md5sums = ef447b5b9fbd0f518a3719c0e6b0af74
+ md5sums = 03297d2f1551ee6c9b11ac450bfdc55f
pkgname = sidequest-bin
diff --git a/PKGBUILD b/PKGBUILD
index aee5bf5354c3..5d695a82b6d3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,15 +4,17 @@
pkgname=sidequest-bin
_pkgname=sidequest
pkgver=0.10.11
-pkgrel=1
+pkgrel=2
pkgdesc="Easily sideload apps onto your standalone android VR headset"
arch=('x86_64')
url="https://github.com/the-expanse/SideQuest"
license=('MIT')
depends=(gtk3 libxss nss)
conflicts=("$_pkgname")
-source=("https://github.com/the-expanse/SideQuest/releases/download/v${pkgver}/SideQuest-${pkgver}.tar.xz")
-md5sums=('ef447b5b9fbd0f518a3719c0e6b0af74')
+source=("https://github.com/the-expanse/SideQuest/releases/download/v${pkgver}/SideQuest-${pkgver}.tar.xz"
+ "SideQuest.desktop")
+md5sums=('ef447b5b9fbd0f518a3719c0e6b0af74'
+ '03297d2f1551ee6c9b11ac450bfdc55f')
package() {
cd "$srcdir/SideQuest-${pkgver}"
@@ -23,5 +25,13 @@ package() {
install -dm755 "$pkgdir/usr/bin"
ln -s /opt/$_pkgname/sidequest "$pkgdir/usr/bin/sidequest"
+ for res in 256x256 16x16 1024x1024 32x32 48x48 128x128 24x24 64x64 512x512
+ do
+ install -dm755 "${pkgdir}/usr/share/icons/hicolor/$res/apps/"
+ ln -s "/opt/$_pkgname/resources/app.asar.unpacked/build/icons/$res.png" "${pkgdir}/usr/share/icons/hicolor/$res/apps/${_pkgname}.png"
+ done
+
install -Dm644 -t "$pkgdir/usr/share/licenses/$_pkgname" LICENSE*
+
+ install -Dm644 "$srcdir/SideQuest.desktop" "${pkgdir}/usr/share/applications/SideQuest.desktop"
}
diff --git a/SideQuest.desktop b/SideQuest.desktop
new file mode 100644
index 000000000000..26e9df93b881
--- /dev/null
+++ b/SideQuest.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name=SideQuest
+Comment=A tool to help simplify getting content onto Quest and Go and other VR headsets.
+Exec=sidequest %u
+Terminal=false
+Type=Application
+Icon=sidequest
+Categories=Development;Game;HardwareSettings
+StartupWMClass=SideQuest
+MimeType=x-scheme-handler/sidequest;