summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRicardo (XenGi) Band2020-01-15 19:41:41 +0100
committerRicardo (XenGi) Band2020-01-15 19:41:41 +0100
commit4480b09dd2a3eeea4c03728ee8e84a522c081e48 (patch)
tree0a6d50fbf801ed01bb978fe33098d8e4f7896193
parent9128a1a46ca7585d5a4c75a8309a3b6407527c34 (diff)
downloadaur-4480b09dd2a3eeea4c03728ee8e84a522c081e48.tar.gz
updated to v5.1.0; modified service file
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD11
-rw-r--r--rqlite.service2
-rw-r--r--rqlite@.service15
4 files changed, 30 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2462b4475f76..41aacaad3e13 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,17 @@
pkgbase = rqlite
pkgdesc = rqlite is a lightweight, distributed relational database, which uses SQLite as its storage engine
- pkgver = 5.0.0
- pkgrel = 3
+ pkgver = 5.1.0
+ pkgrel = 1
url = http://www.rqlite.com/
arch = x86_64
- source = https://github.com/rqlite/rqlite/releases/download/v5.0.0/rqlite-v5.0.0-linux-amd64.tar.gz
+ source = https://github.com/rqlite/rqlite/releases/download/v5.1.0/rqlite-v5.1.0-linux-amd64.tar.gz
source = rqlite.service
+ source = rqlite@.service
source = rqlite.sysusers
source = rqlite.tmpfiles
- sha256sums = 79eda823c82755977b998f5f9a33b738c32da932e41e08df2c0e500267644f83
- sha256sums = c74bc6b0eeadcdecb97236a5bc1ee4cd7312ac91067723dd935c5111e9bcb042
+ sha256sums = 540cda489049bcc85242e636950e82a7422fb207488253052aa93ab481cf3d84
+ sha256sums = 894ca04e9b699238841f69c131c772de8471c2ae42a13430e83730f4afd296c4
+ sha256sums = 3c759f9fab86ee41301f3c2772ae70fb4fac89e9080f0770cc6d5181c10c0b8c
sha256sums = c0132b51d5c28517545fb58ce4aa67b6e860020d662aa8317ecb6aab0264829a
sha256sums = 43c1094a6fdd04c18df738fdc85250f0cbcb87b2f8f23320f42f4ca0656f43fc
diff --git a/PKGBUILD b/PKGBUILD
index ae97691a355f..f8c41d2cc457 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,19 @@
# Maintainer: Ricardo Band <email@ricardo.band>
pkgname=rqlite
-pkgver=5.0.0
-pkgrel=3
+pkgver=5.1.0
+pkgrel=1
pkgdesc="rqlite is a lightweight, distributed relational database, which uses SQLite as its storage engine"
arch=(x86_64)
url="http://www.rqlite.com/"
licence=('MIT')
source=("https://github.com/${pkgname}/${pkgname}/releases/download/v${pkgver}/${pkgname}-v${pkgver}-linux-amd64.tar.gz"
"${pkgname}.service"
+ "${pkgname}@.service"
"${pkgname}.sysusers"
"${pkgname}.tmpfiles")
-sha256sums=('79eda823c82755977b998f5f9a33b738c32da932e41e08df2c0e500267644f83'
- 'c74bc6b0eeadcdecb97236a5bc1ee4cd7312ac91067723dd935c5111e9bcb042'
+sha256sums=('540cda489049bcc85242e636950e82a7422fb207488253052aa93ab481cf3d84'
+ '894ca04e9b699238841f69c131c772de8471c2ae42a13430e83730f4afd296c4'
+ '3c759f9fab86ee41301f3c2772ae70fb4fac89e9080f0770cc6d5181c10c0b8c'
'c0132b51d5c28517545fb58ce4aa67b6e860020d662aa8317ecb6aab0264829a'
'43c1094a6fdd04c18df738fdc85250f0cbcb87b2f8f23320f42f4ca0656f43fc')
@@ -20,6 +22,7 @@ package() {
install -Dm755 "${srcdir}/${pkgname}-v${pkgver}-linux-amd64/rqbench" "${pkgdir}/usr/bin/rqbench"
install -Dm755 "${srcdir}/${pkgname}-v${pkgver}-linux-amd64/rqlited" "${pkgdir}/usr/bin/rqlited"
install -Dm644 "${pkgname}.service" "${pkgdir}/usr/lib/systemd/system/${pkgname}.service"
+ install -Dm644 "${pkgname}@.service" "${pkgdir}/usr/lib/systemd/system/${pkgname}@.service"
install -Dm644 "${pkgname}.sysusers" "${pkgdir}/usr/lib/sysusers.d/${pkgname}.conf"
install -Dm644 "${pkgname}.tmpfiles" "${pkgdir}/usr/lib/tmpfiles.d/${pkgname}.conf"
}
diff --git a/rqlite.service b/rqlite.service
index f8b410d10e2a..e54833b78ac5 100644
--- a/rqlite.service
+++ b/rqlite.service
@@ -7,7 +7,7 @@ Wants=network-online.target
Type=simple
User=rqlite
Group=rqlite
-ExecStart=/usr/bin/rqlited /run/rqlite
+ExecStart=/usr/bin/rqlited -node-id $(cat /etc/machine-id) -http-addr 0.0.0.0:4001 -raft-addr 0.0.0.0:4002 /run/rqlite
Restart=always
WorkingDirectory=/run/rqlite
diff --git a/rqlite@.service b/rqlite@.service
new file mode 100644
index 000000000000..b1f0ed4023ae
--- /dev/null
+++ b/rqlite@.service
@@ -0,0 +1,15 @@
+[Unit]
+Description=
+After=network-online.target
+Wants=network-online.target
+
+[Service]
+Type=simple
+User=rqlite
+Group=rqlite
+ExecStart=/usr/bin/rqlited -node-id $(cat /etc/machine-id) -http-addr 0.0.0.0:4001 -raft-addr 0.0.0.0:4002 -disco-id %i /run/rqlite
+Restart=always
+WorkingDirectory=/run/rqlite
+
+[Install]
+WantedBy=multi-user.target