summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaciej Suminski2022-10-03 20:14:01 +0200
committerMaciej Suminski2022-10-03 20:14:01 +0200
commit452ecb8b1e867f9b4b2a6059a5bea50ea53e5c31 (patch)
tree2a44bb182c236cca49a9fb3c7d0b8d21d15f4255
parent43ea8154601dbc60f148c7857472348076151b4e (diff)
downloadaur-452ecb8b1e867f9b4b2a6059a5bea50ea53e5c31.tar.gz
Switched to cmake (by land_or)
-rw-r--r--PKGBUILD24
1 files changed, 15 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5f28af856efb..454b23bd4a00 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,17 @@
# Maintainer: Maciej Suminski <orson@orson.net.pl>
-# Contributors: milk
+# Contributor: milk
+# Contributor: land_or
# based on qjackctl-svn by robertfoster
pkgname=qjackctl-git
-pkgver=r1253.7b3c624
+pkgver=r1567.a4ed248
pkgrel=1
pkgdesc="A Qt front-end for the JACK low-latency audio server"
arch=('i686' 'x86_64')
license=('GPL2')
depends=('jack' 'hicolor-icon-theme' 'qt5-x11extras')
url="https://qjackctl.sourceforge.io/"
-makedepends=('git' 'qt5-tools')
+makedepends=('cmake' 'git' 'qt5-tools')
provides=('qjackctl')
conflicts=('qjackctl' 'qjackctl-svn')
# sf.net is the original repository, but has connection problems
@@ -24,15 +25,20 @@ pkgver() {
}
build() {
- cd "${srcdir}/${pkgname}"
- ./autogen.sh
- ./configure --prefix=/usr
- make
+ cmake -B build \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE='None' \
+ -S "$srcdir/${pkgname}"
+ cmake --build build
+}
+
+check() {
+ cd build
+ ctest --output-on-failure
}
package() {
- cd "$srcdir/${pkgname}"
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" cmake --install build
}
# vim:set ts=8 sts=2 sw=2 et: