summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Brulhart2020-05-17 23:58:53 +0200
committerSimon Brulhart2020-05-18 21:56:10 +0200
commit45811000088e512dd22fb5a1940d90bba289c22c (patch)
treefebeba2feb1908bc29dfe48be6fb6ea5e02deecc
parente3396eab4d626866707e970ad046bac71989dc02 (diff)
downloadaur-45811000088e512dd22fb5a1940d90bba289c22c.tar.gz
Update to v10.24
-rwxr-xr-x.SRCINFO10
-rw-r--r--PKGBUILD12
-rw-r--r--revert_bulk_append.patch33
-rw-r--r--revert_linkflags.patch39
4 files changed, 54 insertions, 40 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9cc32b22718a..1f71626b73cd 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = freefilesync
pkgdesc = Backup software to synchronize files and folders
- pkgver = 10.23
+ pkgver = 10.24
pkgrel = 1
url = https://freefilesync.org
arch = i686
@@ -10,17 +10,17 @@ pkgbase = freefilesync
depends = wxgtk
depends = curl
depends = lsb-release
- source = FreeFileSync_10.23_Source.zip::https://freefilesync.org/download/FreeFileSync_10.23_Source.zip
+ source = FreeFileSync_10.24_Source.zip::https://freefilesync.org/download/FreeFileSync_10.24_Source.zip
source = revert_xdg_config_path.patch
source = revert_bulk_append.patch
source = revert_linkflags.patch
source = FreeFileSync.desktop
source = RealTimeSync.desktop
source = dlagent
- sha256sums = 52c3cca748dc0aea1b778df73312a537824832f84028f0321dac47cf56c01632
+ sha256sums = fba28a46bcce434c8a9a171e1b3c954163bda8c28705249e9502aef668ca73dd
sha256sums = 0f9a9a6b2c3c460bbde7425bd62273c925259db1cc9dc18c6013aae99fb15cd8
- sha256sums = 92ba719d98af91a67325387ec32fae12c9f1eb0ace054b9db34ae6b6b6d9381c
- sha256sums = d3dedc100163ce00ae5889a6039a1fff11ae32b676ae5e83ae9182509f80638d
+ sha256sums = 474088f1eb7c8a25230e3d4e2f5b0ae81a65f526cd17a1c1d42e732a89ec6953
+ sha256sums = 2942c0e74be2b15cdd83e36fa524c3b6c68d4b4da2042f1b0cf7c13d3b806eac
sha256sums = 590d87707240529ca893199f852143f5d7c7266cb050e37e615900b013ac3d51
sha256sums = 82439b4b81b0a72652befad9b9db52ffbc0180f307c92205aa5ab344f9f82830
sha256sums = 1649e7ea66235c6f82daf9beb6b61b7765df54e9ef70f7f6fc1283f5c2b1e54a
diff --git a/PKGBUILD b/PKGBUILD
index 6333d7d34eaa..66889ba96dee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
# Maintainer: jooch <jooch AT gmx DOT com>
pkgname=freefilesync
-pkgver=10.23
+pkgver=10.24
pkgrel=1
pkgdesc="Backup software to synchronize files and folders"
arch=('i686' 'x86_64')
@@ -24,10 +24,10 @@ source=(
dlagent
)
-sha256sums=('52c3cca748dc0aea1b778df73312a537824832f84028f0321dac47cf56c01632'
+sha256sums=('fba28a46bcce434c8a9a171e1b3c954163bda8c28705249e9502aef668ca73dd'
'0f9a9a6b2c3c460bbde7425bd62273c925259db1cc9dc18c6013aae99fb15cd8'
- '92ba719d98af91a67325387ec32fae12c9f1eb0ace054b9db34ae6b6b6d9381c'
- 'd3dedc100163ce00ae5889a6039a1fff11ae32b676ae5e83ae9182509f80638d'
+ '474088f1eb7c8a25230e3d4e2f5b0ae81a65f526cd17a1c1d42e732a89ec6953'
+ '2942c0e74be2b15cdd83e36fa524c3b6c68d4b4da2042f1b0cf7c13d3b806eac'
'590d87707240529ca893199f852143f5d7c7266cb050e37e615900b013ac3d51'
'82439b4b81b0a72652befad9b9db52ffbc0180f307c92205aa5ab344f9f82830'
'1649e7ea66235c6f82daf9beb6b61b7765df54e9ef70f7f6fc1283f5c2b1e54a')
@@ -65,11 +65,11 @@ build() {
### FFS
cd "${srcdir}/FreeFileSync/Source"
- make EXENAME=FreeFileSync TMP_PATH="${srcdir}/FreeFileSync/tmp_ffs"
+ make exeName=FreeFileSync tmpPath="${srcdir}/FreeFileSync/tmp_ffs"
### RTS
cd "${srcdir}/FreeFileSync/Source/RealTimeSync"
- make EXENAME=RealTimeSync TMP_PATH="${srcdir}/FreeFileSync/tmp_rts"
+ make exeName=RealTimeSync tmpPath="${srcdir}/FreeFileSync/tmp_rts"
}
package() {
diff --git a/revert_bulk_append.patch b/revert_bulk_append.patch
index 45827a5c1df5..b583f5be78e9 100644
--- a/revert_bulk_append.patch
+++ b/revert_bulk_append.patch
@@ -1,26 +1,41 @@
diff -r -u a/FreeFileSync/Source/ui/command_box.cpp b/FreeFileSync/Source/ui/command_box.cpp
---- a/FreeFileSync/Source/ui/command_box.cpp 2019-08-15 19:36:52.000000000 +0200
-+++ b/FreeFileSync/Source/ui/command_box.cpp 2019-08-17 19:08:51.511285343 +0200
-@@ -130,7 +130,8 @@
+--- a/FreeFileSync/Source/ui/command_box.cpp 2020-05-17 19:15:19.000000000 +0200
++++ b/FreeFileSync/Source/ui/command_box.cpp 2020-05-17 20:04:55.554045299 +0200
+@@ -120,7 +120,8 @@
//this->Clear(); -> NO! emits yet another wxEVT_COMMAND_TEXT_UPDATED!!!
wxItemContainer::Clear(); //suffices to clear the selection items only!
-- this->Append(items);
+- this->Append(items); //expensive as fuck! => only call when absolutely needed!
+ for (const wxString& item : items)
+ this->Append(item);
//this->SetSelection(wxNOT_FOUND); //don't select anything
ChangeValue(value); //preserve main text!
diff -r -u a/FreeFileSync/Source/ui/folder_history_box.cpp b/FreeFileSync/Source/ui/folder_history_box.cpp
---- a/FreeFileSync/Source/ui/folder_history_box.cpp 2019-08-15 19:36:52.000000000 +0200
-+++ b/FreeFileSync/Source/ui/folder_history_box.cpp 2019-08-17 19:04:37.023593558 +0200
+--- a/FreeFileSync/Source/ui/folder_history_box.cpp 2020-05-17 19:15:19.000000000 +0200
++++ b/FreeFileSync/Source/ui/folder_history_box.cpp 2020-05-17 20:05:56.513333473 +0200
@@ -90,7 +90,8 @@
//this->Clear(); -> NO! emits yet another wxEVT_COMMAND_TEXT_UPDATED!!!
wxItemContainer::Clear(); //suffices to clear the selection items only!
-- this->Append(dirList);
-+ for (const wxString& dir : dirList)
-+ this->Append(dir);
+- this->Append(items); //expensive as fuck! => only call when absolutely needed!
++ for (const wxString& item : items)
++ this->Append(item);
//this->SetSelection(wxNOT_FOUND); //don't select anything
ChangeValue(folderPathPhrase); //preserve main text!
+diff -r -u a/wx+/choice_enum.h b/wx+/choice_enum.h
+--- a/wx+/choice_enum.h 2020-05-17 19:15:18.000000000 +0200
++++ b/wx+/choice_enum.h 2020-05-18 21:06:22.073914615 +0200
+@@ -79,7 +79,10 @@
+
+ if (items != itemsSetLast)
+ {
+- ctrl.Set(items); //expensive as fuck! => only call when absolutely needed!
++ ctrl.Clear();
++ for (auto item : items) {
++ ctrl.Append(item);
++ }
+ itemsSetLast = std::move(items);
+ }
+ //----------------------------------------------------------------- \ No newline at end of file
diff --git a/revert_linkflags.patch b/revert_linkflags.patch
index e2e9261397f5..a04620f8575c 100644
--- a/revert_linkflags.patch
+++ b/revert_linkflags.patch
@@ -1,36 +1,35 @@
-diff -r -u FreeFileSync_10.15_Source/FreeFileSync/Source/Makefile src/FreeFileSync/Source/Makefile
---- FreeFileSync_10.15_Source/FreeFileSync/Source/Makefile 2019-08-15 19:36:51.000000000 +0200
-+++ src/FreeFileSync/Source/Makefile 2019-08-17 19:44:59.706615730 +0200
+diff -r -u a/FreeFileSync/Source/Makefile b/FreeFileSync/Source/Makefile
+--- a/FreeFileSync/Source/Makefile 2020-05-17 19:15:17.000000000 +0200
++++ b/FreeFileSync/Source/Makefile 2020-05-18 21:46:55.650444123 +0200
@@ -4,7 +4,7 @@
-Wall -Wfatal-errors -Wmissing-include-dirs -Wswitch-enum -Wcast-align -Wshadow -Wnon-virtual-dtor \
-O3 -DNDEBUG `wx-config --cxxflags --debug=no` -pthread
--LINKFLAGS = -s -no-pie `wx-config --libs std, aui --debug=no` -pthread
-+LINKFLAGS = -s -no-pie `wx-config --libs std, aui --debug=no` -lz -pthread
+-linkFlags = -s -no-pie `wx-config --libs std, aui --debug=no` -pthread
++linkFlags = -s -no-pie `wx-config --libs std, aui --debug=no` -lz -pthread
- CXXFLAGS += `pkg-config --cflags openssl`
+ cxxFlags += `pkg-config --cflags openssl`
@@ -17,6 +17,7 @@
- LINKFLAGS += `pkg-config --libs libssh2`
+ linkFlags += `pkg-config --libs libssh2`
- CXXFLAGS += `pkg-config --cflags gtk+-2.0`
-+LINKFLAGS += `pkg-config --libs gtk+-2.0`
+ cxxFlags += `pkg-config --cflags gtk+-2.0`
++linkFlags += `pkg-config --libs gtk+-2.0`
#treat as system headers so that warnings are hidden:
- CXXFLAGS += -isystem/usr/include/gtk-2.0
-
-diff -r -u FreeFileSync_10.15_Source/FreeFileSync/Source/RealTimeSync/Makefile src/FreeFileSync/Source/RealTimeSync/Makefile
---- FreeFileSync_10.15_Source/FreeFileSync/Source/RealTimeSync/Makefile 2019-08-15 19:36:51.000000000 +0200
-+++ src/FreeFileSync/Source/RealTimeSync/Makefile 2019-08-17 19:45:29.529715592 +0200
+ cxxFlags += -isystem/usr/include/gtk-2.0
+
+diff -r -u a/FreeFileSync/Source/RealTimeSync/Makefile b/FreeFileSync/Source/RealTimeSync/Makefile
+--- a/FreeFileSync/Source/RealTimeSync/Makefile 2020-05-17 19:15:17.000000000 +0200
++++ b/FreeFileSync/Source/RealTimeSync/Makefile 2020-05-18 21:46:42.700571925 +0200
@@ -4,10 +4,11 @@
-Wall -Wfatal-errors -Wmissing-include-dirs -Wswitch-enum -Wcast-align -Wshadow -Wnon-virtual-dtor \
-O3 -DNDEBUG `wx-config --cxxflags --debug=no` -pthread
--LINKFLAGS = -s -no-pie `wx-config --libs std, aui --debug=no` -pthread
-+LINKFLAGS = -s -no-pie `wx-config --libs std, aui --debug=no` -lz -pthread
+-linkFlags = -s -no-pie `wx-config --libs std, aui --debug=no` -pthread
++linkFlags = -s -no-pie `wx-config --libs std, aui --debug=no` -lz -pthread
#Gtk - support "no button border"
- CXXFLAGS += `pkg-config --cflags gtk+-2.0`
-+LINKFLAGS += `pkg-config --libs gtk+-2.0`
+ cxxFlags += `pkg-config --cflags gtk+-2.0`
++linkFlags += `pkg-config --libs gtk+-2.0`
#treat as system headers so that warnings are hidden:
- CXXFLAGS += -isystem/usr/include/gtk-2.0
- \ No newline at end of file
+ cxxFlags += -isystem/usr/include/gtk-2.0