summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGeorge Rawlinson2021-01-12 11:11:03 +1300
committerGeorge Rawlinson2021-01-12 11:11:03 +1300
commit4804ccb6c71b7b9b10301f0c4ec10aa5a56d64f5 (patch)
tree45453f71a35f863c64a58e04451d45ff1be07a78
parentc212b609feac52431a61bb307f8204ac0c49b793 (diff)
downloadaur-4804ccb6c71b7b9b10301f0c4ec10aa5a56d64f5.tar.gz
upgpkg: bugdom 1.3.0-2
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
-rwxr-xr-xbugdom.sh4
3 files changed, 15 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0e6815afc0ca..05c422af88f5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = bugdom
pkgdesc = Save Bugdom from Thorax's evil Fire Ants
pkgver = 1.3.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/jorio/Bugdom
arch = x86_64
license = custom:CC-BY-NC-SA-4.0
@@ -14,10 +14,12 @@ pkgbase = bugdom
source = git+https://github.com/jorio/Pomme.git
source = git+https://github.com/jorio/Quesa.git
source = bugdom.desktop
+ source = bugdom.sh
b2sums = SKIP
b2sums = SKIP
b2sums = SKIP
b2sums = f8c230b4047950d3f5f733e795b6ea0082a59348bdf44716ed027f0b7ccd1472c5663f8c8dc19e4548a0cc628c17ffa1f52a5011eb6ee70a33afbeae4a2e9e8c
+ b2sums = 62176cb077576d5274818dfe1d297856ed2d284a7e137dda812682758655275a476c7449ec9d51929c6fbf804f1fea789e91d241ee7ffd14e9b02c418bc097ff
pkgname = bugdom
diff --git a/PKGBUILD b/PKGBUILD
index 208dd984ecd8..566f9acebe7b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=bugdom
pkgver=1.3.0
-pkgrel=1
+pkgrel=2
pkgdesc="Save Bugdom from Thorax's evil Fire Ants"
arch=(x86_64)
url="https://github.com/jorio/Bugdom"
@@ -12,11 +12,13 @@ makedepends=(cmake git)
source=("$pkgname::git+$url.git#tag=$pkgver"
"git+https://github.com/jorio/Pomme.git"
"git+https://github.com/jorio/Quesa.git"
- "$pkgname.desktop")
+ "$pkgname.desktop"
+ "$pkgname.sh")
b2sums=('SKIP'
'SKIP'
'SKIP'
- 'f8c230b4047950d3f5f733e795b6ea0082a59348bdf44716ed027f0b7ccd1472c5663f8c8dc19e4548a0cc628c17ffa1f52a5011eb6ee70a33afbeae4a2e9e8c')
+ 'f8c230b4047950d3f5f733e795b6ea0082a59348bdf44716ed027f0b7ccd1472c5663f8c8dc19e4548a0cc628c17ffa1f52a5011eb6ee70a33afbeae4a2e9e8c'
+ '62176cb077576d5274818dfe1d297856ed2d284a7e137dda812682758655275a476c7449ec9d51929c6fbf804f1fea789e91d241ee7ffd14e9b02c418bc097ff')
prepare() {
cd "$pkgname"
@@ -44,6 +46,9 @@ package() {
# move binary & assets
mv build/{Data,Bugdom} "$pkgdir/usr/lib/$pkgname"
+ # wrapper script for $PATH execution
+ install -Dm755 "$srcdir/$pkgname.sh" "$pkgdir/usr/bin/$pkgname"
+
# desktop file & icon
install -Dm644 -t "$pkgdir/usr/share/applications" "$srcdir/$pkgname.desktop"
install -Dm644 \
diff --git a/bugdom.sh b/bugdom.sh
new file mode 100755
index 000000000000..25c77ecddaf6
--- /dev/null
+++ b/bugdom.sh
@@ -0,0 +1,4 @@
+#!/usr/bin/sh
+
+cd /usr/lib/bugdom
+exec /usr/lib/bugdom/Bugdom