summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoão M. Bezerra2020-09-13 10:49:21 -0300
committerJoão M. Bezerra2020-09-13 10:49:21 -0300
commit490414b64a122c3c87a434f9341879deba1b34bd (patch)
tree775571b51f56a5e5ba23414f005afffdb1a7241b
parent65321dcaa8885506f14a8fc96e4c78e4430b9e8f (diff)
downloadaur-490414b64a122c3c87a434f9341879deba1b34bd.tar.gz
Renamed package to `sublime-text-3`
-rw-r--r--.SRCINFO24
-rw-r--r--LICENSE14
-rw-r--r--PKGBUILD22
3 files changed, 39 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cc11883904dd..c7e429566406 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,26 +1,24 @@
-pkgbase = sublime-text-3-imfix
- pkgdesc = Sophisticated text editor for code, html and prose - Stable build with support for CJK
+pkgbase = sublime-text-3
+ pkgdesc = Sophisticated text editor for code, html and prose - stable build
pkgver = 3.3211
- pkgrel = 2
+ pkgrel = 1
url = https://www.sublimetext.com/3
arch = x86_64
license = custom
depends = libpng
depends = gtk2
provides = sublime-text
- provides = sublime-text-dev
- provides = sublime-text-nightly
- provides = sublime-text-dev-imfix
- provides = sublime-text-dev-imfix2
- conflicts = sublime-text
- conflicts = sublime-text-dev
+ provides = sublime
+ conflicts = sublime-text-4-dev
+ conflicts = sublime-text-3-imfix
+ conflicts = sublime-text-imfix
conflicts = sublime-text-nightly
- conflicts = sublime-text-dev-imfix
- conflicts = sublime-text-dev-imfix2
+ conflicts = sublime-text-dev
+ conflicts = sublime-text2
source = https://download.sublimetext.com/sublime_text_3_build_3211_x64.tar.bz2
source = LICENSE
sha256sums = 0b3c8ca5e6df376c3c24a4b9ac2e3b391333f73b229bc6e87d0b4a5f636d74ee
- sha256sums = 8e4c48469bf3f35d0c0904e770c4e307d4965a8931e839c01c5765498a19cf01
+ sha256sums = 339dbd1b6ae3e699809afcdd6c690299e6fa0d385aa2ef658a52d336a3f8107f
-pkgname = sublime-text-3-imfix
+pkgname = sublime-text-3
diff --git a/LICENSE b/LICENSE
index 3e2f842607c7..981842a701f5 100644
--- a/LICENSE
+++ b/LICENSE
@@ -1,3 +1,13 @@
-Sublime Text may be downloaded and evaluated for free, however a license must be purchased for continued use.
-Licenses are per-user, rather than per-machine, so you can enjoy Sublime Text on as many computers and operating systems as you wish with your license.
+Maintainer note:
+Sublime Text is free to use, if you want access to the newer builds, with the package
+`sublime-text-4-dev` or `sublime-text-dev`, you'll need a paid license.
+
+Buying a license also supports the development of the editor.
+
+---
+
+Sublime Text may be downloaded and evaluated for free, however a license must be purchased for
+continued use. Licenses are per-user, rather than per-machine, so you can enjoy Sublime Text on as
+many computers and operating systems as you wish with your license.
+
For more information, please visit https://www.sublimetext.com/buy
diff --git a/PKGBUILD b/PKGBUILD
index ec77952f1ada..411ba05dee38 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,31 @@
# Maintainer: marcospb19 <marcospb19@hotmail.com>
-pkgname=sublime-text-3-imfix
+pkgname=sublime-text-3
pkgver=3.3211
-pkgrel=2
-pkgdesc="Sophisticated text editor for code, html and prose - Stable build with support for CJK"
+pkgrel=1
+pkgdesc="Sophisticated text editor for code, html and prose - stable build"
arch=('x86_64')
url='https://www.sublimetext.com/3'
license=('custom')
depends=('libpng' 'gtk2')
-conflicts=('sublime-text' 'sublime-text-dev' 'sublime-text-nightly' 'sublime-text-dev-imfix' 'sublime-text-dev-imfix2')
-provides=('sublime-text' 'sublime-text-dev' 'sublime-text-nightly' 'sublime-text-dev-imfix' 'sublime-text-dev-imfix2')
+
+replaces=('sublime-text-3-imfix')
+
+conflicts=('sublime-text-4-dev'
+ 'sublime-text-3-imfix'
+ 'sublime-text-imfix'
+ 'sublime-text-nightly'
+ 'sublime-text-dev'
+ 'sublime-text2')
+
+provides=('sublime-text' 'sublime')
+
source=(
"https://download.sublimetext.com/sublime_text_3_build_${pkgver:2}_x64.tar.bz2"
'LICENSE'
)
sha256sums=('0b3c8ca5e6df376c3c24a4b9ac2e3b391333f73b229bc6e87d0b4a5f636d74ee'
- '8e4c48469bf3f35d0c0904e770c4e307d4965a8931e839c01c5765498a19cf01')
+ '339dbd1b6ae3e699809afcdd6c690299e6fa0d385aa2ef658a52d336a3f8107f')
package() {
cd "${srcdir}"