summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike Javorski2020-11-20 17:21:56 -0800
committerMike Javorski2020-11-20 17:21:56 -0800
commit49621e8b01d440176091b9b40e567cb7782d7113 (patch)
treeee01786441ac71926a9292b0ed06a41a7704a41b
parent79890da0eed242682ece5eb9c9c4946aa58b53eb (diff)
downloadaur-49621e8b01d440176091b9b40e567cb7782d7113.tar.gz
New maintainer and update to latest version. Cheers sanerb!
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD20
2 files changed, 11 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cf3095143911..4bfc4f1ee2f0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = debianutils
pkgdesc = Miscellaneous utilities specific to Debian
- pkgver = 4.9.1
+ pkgver = 4.11.2
pkgrel = 1
url = http://packages.qa.debian.org/d/debianutils.html
arch = i686
@@ -8,11 +8,8 @@ pkgbase = debianutils
license = GPL
depends = run-parts
depends = which
- source = http://cdn-fastly.deb.debian.org/debian/pool/main/d/debianutils/debianutils_4.9.1.tar.xz
- source = debianutils_4.9.1.tar.xz.sig
- validpgpkeys = 748231EBCBD808A14F5E85D28C004C2F93481F6B
- sha512sums = b442950febe6df9e15ec04a6fec0ee8be12d3eac38dc3f9331438d871e3382f4e0f599da0eaeff0e7e9ba0fa5136ce3c3b51c6718e4d7f11c1675f745052a9b1
- sha512sums = SKIP
+ source = http://cdn-fastly.deb.debian.org/debian/pool/main/d/debianutils/debianutils_4.11.2.tar.xz
+ sha512sums = 0bd9098beee78b3c8dae839f0c29e9f142cbb22f2ced473cf7ae47a14d9493ba882c1829eba213780392a87a3223b3689729754c8ded80a091efaef3f6f903fd
pkgname = debianutils
diff --git a/PKGBUILD b/PKGBUILD
index c9107272c44d..c8bdbac5ee04 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,29 @@
-# Maintainer: brent s. <bts[at]square-r00t[dot]net>
-# Bug reports can be filed at https://bugs.square-r00t.net/index.php?project=3
-# News updates for packages can be followed at https://devblog.square-r00t.net
-validpgpkeys=('748231EBCBD808A14F5E85D28C004C2F93481F6B')
+# Maintainer: Mike Javorski <mike dot javorski at gmail dot com>
+# Contributor: brent s. <bts[at]square-r00t[dot]net>
# Contributor: Jochen Schalanda <jochen+aur (at) schalanda.name>
pkgname=debianutils
-pkgver=4.9.1
+pkgver=4.11.2
pkgrel=1
pkgdesc="Miscellaneous utilities specific to Debian"
arch=('i686' 'x86_64')
url="http://packages.qa.debian.org/d/debianutils.html"
license=('GPL')
depends=('run-parts' 'which')
-source=("http://cdn-fastly.deb.debian.org/debian/pool/main/d/${pkgname}/${pkgname}_${pkgver}.tar.xz"
- "${pkgname}_${pkgver}.tar.xz.sig")
-sha512sums=('b442950febe6df9e15ec04a6fec0ee8be12d3eac38dc3f9331438d871e3382f4e0f599da0eaeff0e7e9ba0fa5136ce3c3b51c6718e4d7f11c1675f745052a9b1'
- 'SKIP')
+source=("http://cdn-fastly.deb.debian.org/debian/pool/main/d/${pkgname}/${pkgname}_${pkgver}.tar.xz")
+sha512sums=('0bd9098beee78b3c8dae839f0c29e9f142cbb22f2ced473cf7ae47a14d9493ba882c1829eba213780392a87a3223b3689729754c8ded80a091efaef3f6f903fd')
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd "${srcdir}/${pkgname}"
./configure --prefix=/usr --sbindir=/usr/bin
make
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd "${srcdir}/${pkgname}"
make DESTDIR="$pkgdir" install
msg 'Remove files of "which" and "run-parts" package...'
- cd
+ cd -
find "${pkgdir}" -name which* -delete
find "${pkgdir}" -name run-parts* -delete
}