summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Kluger2023-04-23 19:00:14 +0000
committerAndy Kluger2023-04-23 19:00:14 +0000
commit498b234959bdad43a0a7a857b8d5f51eaff79e2b (patch)
tree0e32c123aebe363f75049f4ad380e73988b59a18
parentc4b960fa5b4580c910464faea260613128b0efcc (diff)
downloadaur-498b234959bdad43a0a7a857b8d5f51eaff79e2b.tar.gz
Update patch and version bump
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD9
-rw-r--r--dolphin-meld.patch16
3 files changed, 21 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f5da5b9d6a28..6c8761958e49 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = dolphin-meld
pkgdesc = KDE File Manager, using Meld rather than Kompare
- pkgver = 22.12.3
+ pkgver = 23.04.0
pkgrel = 1
url = https://apps.kde.org/dolphin/
arch = x86_64
@@ -21,16 +21,17 @@ pkgbase = dolphin-meld
optdepends = kdegraphics-thumbnailers: PDF and PS thumbnails
optdepends = konsole: terminal panel
optdepends = purpose: share context menu
- provides = dolphin=22.12.3
- conflicts = dolphin=22.12.3
- source = https://download.kde.org/stable/release-service/22.12.3/src/dolphin-22.12.3.tar.xz
- source = https://download.kde.org/stable/release-service/22.12.3/src/dolphin-22.12.3.tar.xz.sig
+ optdepends = kio-admin: for managing files as administrator
+ provides = dolphin=23.04.0
+ conflicts = dolphin=23.04.0
+ source = https://download.kde.org/stable/release-service/23.04.0/src/dolphin-23.04.0.tar.xz
+ source = https://download.kde.org/stable/release-service/23.04.0/src/dolphin-23.04.0.tar.xz.sig
source = dolphin-meld.patch
validpgpkeys = CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7
validpgpkeys = F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87
validpgpkeys = D81C0CB38EB725EF6691C385BB463350D6EF31EF
- sha256sums = 1aa7538f013d24fdf36633d413e7ac23dbdfec7a216de8d01865ce4754760b5a
+ sha256sums = cd49268a3b0309253587d424fbdffe25b26c951df7e6932a42f48cf34b006c50
sha256sums = SKIP
- sha256sums = 9bf8e1d53bb482e3cc2f3a114fb894fc3d0216ad2933d0c6e1f0b7df6d640b7a
+ sha256sums = a69abda1bd78cbaf3eb92ed645637fce1ea04a3528c90e22ab2abbdd809a0b15
pkgname = dolphin-meld
diff --git a/PKGBUILD b/PKGBUILD
index 283d73d0c550..c8cfc1400cdf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname=dolphin-meld
_pkgname=dolphin
-pkgver=22.12.3
+pkgver=23.04.0
pkgrel=1
pkgdesc='KDE File Manager, using Meld rather than Kompare'
arch=(x86_64)
@@ -18,13 +18,14 @@ conflicts=("$_pkgname=$pkgver")
depends=(baloo-widgets knewstuff kio-extras kcmutils kparts kactivities kuserfeedback)
makedepends=(extra-cmake-modules kdoctools)
optdepends=('kde-cli-tools: for editing file type options' 'ffmpegthumbs: video thumbnails' 'kdegraphics-thumbnailers: PDF and PS thumbnails'
- 'konsole: terminal panel' 'purpose: share context menu')
+ 'konsole: terminal panel' 'purpose: share context menu'
+ 'kio-admin: for managing files as administrator')
groups=(kde-applications kde-system)
source=(https://download.kde.org/stable/release-service/$pkgver/src/$_pkgname-$pkgver.tar.xz{,.sig}
dolphin-meld.patch)
-sha256sums=('1aa7538f013d24fdf36633d413e7ac23dbdfec7a216de8d01865ce4754760b5a'
+sha256sums=('cd49268a3b0309253587d424fbdffe25b26c951df7e6932a42f48cf34b006c50'
'SKIP'
- '9bf8e1d53bb482e3cc2f3a114fb894fc3d0216ad2933d0c6e1f0b7df6d640b7a')
+ 'a69abda1bd78cbaf3eb92ed645637fce1ea04a3528c90e22ab2abbdd809a0b15')
validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7 # Albert Astals Cid <aacid@kde.org>
F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87 # Christoph Feck <cfeck@kde.org>
D81C0CB38EB725EF6691C385BB463350D6EF31EF) # Heiko Becker <heiko.becker@kde.org>
diff --git a/dolphin-meld.patch b/dolphin-meld.patch
index 6e2a45e993db..2acb82663a92 100644
--- a/dolphin-meld.patch
+++ b/dolphin-meld.patch
@@ -2,16 +2,16 @@ diff --git a/src/dolphinmainwindow.cpp b/src/dolphinmainwindow.cpp
index 5741e8943..63253e681 100644
--- a/src/dolphinmainwindow.cpp
+++ b/src/dolphinmainwindow.cpp
-@@ -330,7 +330,7 @@ void DolphinMainWindow::slotSelectionChanged(const KFileItemList& selection)
+@@ -365,7 +365,7 @@ void DolphinMainWindow::slotSelectionChanged(const KFileItemList& selection)
const int selectedUrlsCount = m_tabWidget->currentTabPage()->selectedItemsCount();
- QAction* compareFilesAction = actionCollection()->action(QStringLiteral("compare_files"));
+ QAction *compareFilesAction = actionCollection()->action(QStringLiteral("compare_files"));
- if (selectedUrlsCount == 2) {
+ if (selectedUrlsCount == 2 || selectedUrlsCount == 3) {
compareFilesAction->setEnabled(isKompareInstalled());
} else {
compareFilesAction->setEnabled(false);
-@@ -925,7 +925,7 @@ void DolphinMainWindow::goHomeInNewTab()
+@@ -1058,7 +1058,7 @@ void DolphinMainWindow::goHomeInNewTab()
void DolphinMainWindow::compareFiles()
{
const KFileItemList items = m_tabWidget->currentTabPage()->selectedItems();
@@ -20,7 +20,7 @@ index 5741e8943..63253e681 100644
// The action is disabled in this case, but it could have been triggered
// via D-Bus, see https://bugs.kde.org/show_bug.cgi?id=325517
return;
-@@ -934,14 +934,20 @@ void DolphinMainWindow::compareFiles()
+@@ -1067,14 +1067,20 @@ void DolphinMainWindow::compareFiles()
QUrl urlA = items.at(0).url();
QUrl urlB = items.at(1).url();
@@ -43,16 +43,16 @@ index 5741e8943..63253e681 100644
job->start();
}
-@@ -1549,7 +1555,7 @@ void DolphinMainWindow::setupActions()
-
- QAction* compareFiles = actionCollection()->addAction(QStringLiteral("compare_files"));
+@@ -1846,7 +1852,7 @@ void DolphinMainWindow::setupActions()
+ // setup 'Tools' menu
+ QAction *compareFiles = actionCollection()->addAction(QStringLiteral("compare_files"));
compareFiles->setText(i18nc("@action:inmenu Tools", "Compare Files"));
- compareFiles->setIcon(QIcon::fromTheme(QStringLiteral("kompare")));
+ compareFiles->setIcon(QIcon::fromTheme(QStringLiteral("meld")));
compareFiles->setEnabled(false);
connect(compareFiles, &QAction::triggered, this, &DolphinMainWindow::compareFiles);
-@@ -2151,7 +2157,7 @@ bool DolphinMainWindow::isKompareInstalled() const
+@@ -2433,7 +2439,7 @@ bool DolphinMainWindow::isKompareInstalled() const
if (!initialized) {
// TODO: maybe replace this approach later by using a menu
// plugin like kdiff3plugin.cpp