summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThiago Perrotta2015-06-14 02:36:47 -0300
committerThiago Perrotta2015-06-14 02:36:47 -0300
commit49da78f33a8cc142982549a83ba1f87745dc05ee (patch)
tree5dd990d2a6d9c48d4e4d5b8fcb802604e2fe0770
downloadaur-49da78f33a8cc142982549a83ba1f87745dc05ee.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD25
-rw-r--r--otf-bitter.install15
3 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..13343d9f82ea
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = otf-bitter
+ pkgdesc = A font specially designed for comfortably reading on any computer or device.
+ pkgver = 1
+ pkgrel = 2
+ url = http://www.huertatipografica.com/fonts/bitter-ht
+ install = otf-bitter.install
+ arch = any
+ license = custom:OFL
+ makedepends = unzip
+ depends = fontconfig
+ depends = xorg-font-utils
+ conflicts = otf-google-fonts-hg
+ source = bitter.zip::http://www.fontsquirrel.com/fonts/download/bitter
+ md5sums = SKIP
+
+pkgname = otf-bitter
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..92998e9457a6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Thiago Perrotta <echo dGhpYWdvcGVycm90dGE5NUBnbWFpbC5jb20K | base64 -d >
+
+_fontname=bitter
+pkgname=otf-${_fontname}
+pkgver=1
+pkgrel=2
+pkgdesc='A font specially designed for comfortably reading on any computer or device.'
+arch=('any')
+url="http://www.huertatipografica.com/fonts/${_fontname}-ht"
+license=('custom:OFL')
+depends=('fontconfig' 'xorg-font-utils')
+makedepends=('unzip')
+conflicts=('otf-google-fonts-hg')
+install="${pkgname}.install"
+source=("${_fontname}.zip::http://www.fontsquirrel.com/fonts/download/${_fontname}")
+md5sums=('SKIP')
+
+package() {
+ cd "${srcdir}"
+ unzip -qqo "${_fontname}.zip"
+
+ install -Dm644 "SIL Open Font License.txt" "${pkgdir}/usr/share/licenses/${pkgname}/OFL"
+ install -d "${pkgdir}/usr/share/fonts/OTF/"
+ install -m644 *.otf "${pkgdir}/usr/share/fonts/OTF/"
+}
diff --git a/otf-bitter.install b/otf-bitter.install
new file mode 100644
index 000000000000..b80727d4a598
--- /dev/null
+++ b/otf-bitter.install
@@ -0,0 +1,15 @@
+post_install() {
+ echo -n "Updating font cache..."
+ fc-cache -fs >/dev/null
+ mkfontscale /usr/share/fonts/OTF
+ mkfontdir /usr/share/fonts/OTF
+ echo "done"
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}