summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Prager2022-05-26 16:59:16 +0200
committerMichael Prager2024-03-27 23:18:27 +0100
commit4acdc143403cdf46eb64c439212648e508090501 (patch)
tree7fe7be24fe8e98440f2da519c9586a748913174e
parent715c44c87936e8bf9a2fb0ccc4806d999267fab8 (diff)
downloadaur-4acdc143403cdf46eb64c439212648e508090501.tar.gz
Minor package tweaks
- updated pkgdesc - updated url from http to https - updated license from GPL to GPL2 - added descriptions to optdeps - provides golden-cheeta - removed !strip and !buildflags - reuse gc.png from package - GoldenCheetah.desktop: removed invalid .desktop file specification version - GoldenCheetah.desktop: added to categories Science and Sports - GoldenCheetah.desktop: updated comment - GoldenCheetah.desktop: added keywords Running and Thriathlon - removed hardcoded -j8 from make - update language files before building similar to travis script - call qmake-qt5 with -recursive similar to travis script - reduced g++ warnings similar to travis script - don't create empty usr/lib/udev/rules.d/ dir - gcconfig.pri: updated to be in sync with upstream - gcconfig.pri: removed non-working (because overridden) optimization cxxflag
-rw-r--r--GoldenCheetah.desktop9
-rw-r--r--PKGBUILD77
-rw-r--r--gc.pngbin189440 -> 0 bytes
-rw-r--r--gcconfig.pri19
4 files changed, 61 insertions, 44 deletions
diff --git a/GoldenCheetah.desktop b/GoldenCheetah.desktop
index 50acd7320045..7ace344e84e7 100644
--- a/GoldenCheetah.desktop
+++ b/GoldenCheetah.desktop
@@ -1,9 +1,10 @@
[Desktop Entry]
-Version=3.3.0
+Version=1.5
Type=Application
Name=GoldenCheetah
-Comment=Cycling Power Analysis Software.
+Comment=Performance Software for Cyclists, Runners, Triathletes and Coaches
TryExec=/usr/bin/GoldenCheetah
Exec=GoldenCheetah
-Icon=/usr/share/pixmaps/gc.png
-Keywords=Cycling;Training;Bike;Ride
+Icon=gc
+Categories=Science;Sports
+Keywords=Cycling;Training;Bike;Ride;Running;Triathlon
diff --git a/PKGBUILD b/PKGBUILD
index b2b170896d72..9be2c677d45d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,23 +2,53 @@
# Contributor: Ammann Max <maximilian.ammann@googlemail.com>
pkgname=golden-cheetah-git
pkgver=v3.6.RC3.r1.67352f6dc
-pkgrel=1
-pkgdesc="Cycling Power Analysis Software. We believe that cyclists and triathletes should be able to download their power data to the
-computer of their choice, analyze it in whatever way they see fit, and share their methods of
-analysis with others."
+pkgrel=3
+pkgdesc="Performance Software for Cyclists, Runners, Triathletes and Coaches"
arch=('i686' 'x86_64')
-url="http://www.goldencheetah.org/"
-license=('GPL')
-makedepends=(bison flex 'gcc' 'make' 'qt5-tools' sip4 pkgconf)
-depends=('qt5-base' 'qt5-svg' qt5-location qt5-declarative qt5-webchannel qt5-webengine qt5-sensors qt5-serialport qt5-webkit qt5-multimedia qt5-script qt5-connectivity qt5-charts vlc gsl)
-optdepends=('vlc' 'srmio' 'libftd2xx' 'libkml' 'libical' 'libusb-compat' 'libsamplerate' 'r')
-options=('!strip' '!buildflags' 'staticlibs')
+url="https://www.goldencheetah.org/"
+license=('GPL2')
+makedepends=(
+ 'bison'
+ 'flex'
+ 'gcc'
+ 'make'
+ 'qt5-tools'
+ 'sip4'
+ 'pkgconf')
+depends=(
+ 'qt5-base'
+ 'qt5-svg'
+ 'qt5-location'
+ 'qt5-declarative'
+ 'qt5-webchannel'
+ 'qt5-webengine'
+ 'qt5-sensors'
+ 'qt5-serialport'
+ 'qt5-webkit'
+ 'qt5-multimedia'
+ 'qt5-script'
+ 'qt5-connectivity'
+ 'qt5-charts'
+ 'vlc'
+ 'gsl')
+optdepends=(
+ 'vlc: for video playback in realtime'
+ 'srmio: for SRM powercontrol V downloads via serial'
+ 'libftd2xx: for Powertap downloads via USB'
+ 'libkml: for export to Google Earth'
+ 'libical: for diary integration with Google or MobileMe calendars'
+ 'libusb-compat: for using USB2 sticks in Train View'
+ 'libsamplerate'
+ 'r: for charts generation')
+options=('staticlibs')
conflicts=('golden-cheetah-rc' 'golden-cheetah-dev' 'golden-cheetah')
-source=('golden-cheetah::git+https://github.com/GoldenCheetah/GoldenCheetah.git' GoldenCheetah.desktop gc.png gcconfig.pri)
+provides=('golden-cheetah')
+source=('golden-cheetah::git+https://github.com/GoldenCheetah/GoldenCheetah.git'
+ 'GoldenCheetah.desktop'
+ 'gcconfig.pri')
sha256sums=('SKIP'
- '6c4f56ba53f2deadec5b16efdecd1311653c2dca2c0378f951672a9b7186f09d'
- 'e12471b7864adc877c34cd4cfb23451cae7648b9c8109f400f1af883d4c8cd4e'
- 'c018c5d36739a2a369d69f2fb0247b641b9e0da1ef29321058a2fad361fb6e4f')
+ '3ec79d7671a54ce34d6be3b5c2dbd051f423a3fc1529398337631d742765d7ad'
+ '7409dc95720bc309a082ef72bf2dab6cf458a7eaed901c9ead14ffc8f6d0f013')
pkgver() {
cd "${srcdir}/golden-cheetah"
@@ -27,24 +57,19 @@ pkgver() {
build() {
cd "${srcdir}/golden-cheetah/"
-
- cd "qwt/"
- cp qwtconfig.pri.in qwtconfig.pri
- qmake-qt5 QMAKE_DEFAULT_INCDIRS=
- make -j8
-
- cd "../src/"
- cp $srcdir/gcconfig.pri gcconfig.pri
- qmake-qt5 QMAKE_LRELEASE=/usr/bin/lrelease-qt5 QMAKE_DEFAULT_INCDIRS=
- make -j8
+ cp qwt/qwtconfig.pri.in qwt/qwtconfig.pri
+ cp "$srcdir/gcconfig.pri" src/gcconfig.pri
+ lupdate-pro src/src.pro
+ qmake-qt5 -recursive QMAKE_CXXFLAGS_WARN_ON+="-Wno-deprecated-declarations -Wno-unused-value" QMAKE_CFLAGS_WARN_ON+="-Wno-deprecated-declarations -Wno-unused-value"
+ make
}
package() {
mkdir -p "$pkgdir/usr/bin/"
cp "${srcdir}/golden-cheetah/src/GoldenCheetah" "$pkgdir/usr/bin/"
- mkdir -p "$pkgdir/usr/lib/udev/rules.d/"
+ #mkdir -p "$pkgdir/usr/lib/udev/rules.d/" # unused
mkdir -p "$pkgdir/usr/share/applications/"
cp "${srcdir}/GoldenCheetah.desktop" "$pkgdir/usr/share/applications/"
mkdir -p "$pkgdir/usr/share/pixmaps/"
- cp "${srcdir}/gc.png" "$pkgdir/usr/share/pixmaps/"
+ cp "${srcdir}/golden-cheetah/src/Resources/images/gc.png" "$pkgdir/usr/share/pixmaps/"
}
diff --git a/gc.png b/gc.png
deleted file mode 100644
index 386dfe99f482..000000000000
--- a/gc.png
+++ /dev/null
Binary files differ
diff --git a/gcconfig.pri b/gcconfig.pri
index 589b71e291ae..d8ba7e86355e 100644
--- a/gcconfig.pri
+++ b/gcconfig.pri
@@ -76,7 +76,7 @@ PKGCONFIG += python3 python3-embed
# We use g++ on all platforms so switch on auto vectorization amongst other
# things to speed up looping over ride file points
-QMAKE_CXXFLAGS += -O3
+#QMAKE_CXXFLAGS += -O3
# Let us know where flex and bison are installed.
# You may need to specify the full path if things don't work.
@@ -188,7 +188,7 @@ packagesExist(libusb) {
# if you want video playback on training mode then
# download and install vlc (videolan) from
-# ftp.videolan.org/pub/vlc/1.1.8 or http://download.videolan.org/vlc/ for
+# ftp.videolan.org/pub/vlc/3.0.8 or http://download.videolan.org/vlc/ for
# your platform there are sdks for Mac and Windows. On Linux you
# will need to use the latest distro (e.g. Meerkat
# on Ubuntu) to be sure apt-get installs the latest
@@ -213,12 +213,6 @@ packagesExist(libvlc) {
DEFINES += GC_VIDEO_NONE
}
-# *** Mac users NOTE ***
-# On MAC you don't need libvlc since we use the
-# native QTKit (OSX framework) for video playback
-# using Quicktime and on 10.6 or higher Quicktime X
-#
-
# if you want to resample with high fidelity we can use the
# libsamplerate libraries, this is used in RideFile::resample()
# if you don't resample (e.g. export or merge with new recording
@@ -282,12 +276,9 @@ macx {
#DEFINES += GC_DROPBOX_CLIENT_ID=\\\"xxxxxxxxxxxxxxx\\\"
#DEFINES += GC_DROPBOX_CLIENT_SECRET=\\\"xxxxxxxxxxxxxxx\\\"
-# if you have your own MAPQUEST KEY
-#DEFINES += GC_MAPQUESTAPI_KEY=\\\"xxxxxxxxxxxxxxxxxxxxxx\\\"
-
-# USING THE WITHINGS API (http://oauth.withings.com/api)
-#DEFINES += GC_WITHINGS_CONSUMER_KEY=\\\"xxxxxxxxxxxxxxx\\\"
-#DEFINES += GC_WITHINGS_CONSUMER_SECRET=\\\"xxxxxxxxxxxxxxx\\\"
+# USING THE WITHINGS API (http://oauth.withings.com/api, use https://www.goldencheetah.org as CALLBACK URL)
+#DEFINES += GC_NOKIA_CLIENT_ID=\\\"xxxxxxxxxxxxxxx\\\"
+#DEFINES += GC_NOKIA_CLIENT_SECRET=\\\"xxxxxxxxxxxxxxx\\\"
# What video playback do you want?
#DEFINES += GC_VIDEO_NONE # dont add any video playback support