summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin Morris2023-06-30 14:04:10 -0700
committerKevin Morris2023-06-30 14:04:40 -0700
commit4b484970f29a29e5b33da899894e48d75b0790eb (patch)
tree3f04e3dcd7bd8b8c79d90cff8b5863a42e95caf2
parent47d8be3f4e3c8e5057a942f45189d29e66c71bf2 (diff)
downloadaur-4b484970f29a29e5b33da899894e48d75b0790eb.tar.gz
Bump to release 1.5
Signed-off-by: Kevin Morris <kevr@0cost.org>
-rw-r--r--PKGBUILD6
-rw-r--r--hastebin.install9
2 files changed, 12 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fdbaa0fa3b36..679f73e09f29 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname='hastebin'
-release='1.4'
+release='1.5'
pkgver="${release}.0"
pkgrel=1
pkgdesc='Upload data to hastebin.com via stdin'
@@ -10,12 +10,12 @@ depends=('python' 'python-requests')
conflicts=("${pkgname}-git")
optdepends=('xclip: default --clip-command')
source=("${url}/archive/refs/tags/${release}.tar.gz")
+install='hastebin.install'
sha256sums=(
- 'a8b5d5164e11cc485e973c8f1d090553e78ff1dfcfe3f3664aa8cea37bef6bd8'
+ 'c85bb82389887758b6b8329805a368269247135a8a2e47067a0d9b40e4d08475'
)
package()
{
install -Dm755 "${srcdir}/${pkgname}-${release}/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
}
-
diff --git a/hastebin.install b/hastebin.install
new file mode 100644
index 000000000000..0f71abc96464
--- /dev/null
+++ b/hastebin.install
@@ -0,0 +1,9 @@
+post_upgrade()
+{
+ echo
+ echo "IMPORTANT:"
+ echo 'hastebin requires that $HASTEBIN_TOKEN or --token contain a valid '
+ echo 'Hastebin API token, which can be generated at '
+ echo 'https://www.toptal.com/developers/hastebin/documentation'
+ echo
+}