summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike Swanson2016-12-29 11:02:48 -0800
committerMike Swanson2016-12-29 11:02:48 -0800
commit4b668a06d911a623015060412c3a2cd131d78763 (patch)
treedc691c3857caef9e10b46bef0c17692237a13224
parent4f241fee1d2ce4edf3fc0e6ed22703e4171160f7 (diff)
downloadaur-4b668a06d911a623015060412c3a2cd131d78763.tar.gz
Update to 2.3.0
-rw-r--r--.SRCINFO24
-rw-r--r--.gitignore1
-rw-r--r--0001-i_sdlsound.c-fix-compilation-with-libsamplerate-0.1..patch53
-rw-r--r--PKGBUILD19
4 files changed, 25 insertions, 72 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 06475fbe1509..c640963e2d95 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,27 +1,27 @@
# Generated by mksrcinfo v8
-# Mon Oct 24 20:53:33 UTC 2016
+# Thu Dec 29 19:02:37 UTC 2016
pkgbase = chocolate-doom
pkgdesc = Historically-accurate Doom, Heretic, Hexen, and Strife ports.
- pkgver = 2.2.1
- pkgrel = 2
+ pkgver = 2.3.0
+ pkgrel = 1
url = http://www.chocolate-doom.org/
arch = i686
arch = x86_64
license = GPL2
makedepends = python
+ depends = libpng
depends = libsamplerate
depends = sdl_mixer
- depends = sdl_net
- source = http://chocolate-doom.org/downloads/2.2.1/chocolate-doom-2.2.1.tar.gz
- source = 0001-i_sdlsound.c-fix-compilation-with-libsamplerate-0.1..patch
- sha256sums = ad11e2871667c6fa0658abf2dcba0cd9b26fbd651ee8df55adfdc18ad8fd674a
- sha256sums = 2f54bccecbecfc57be96d75cdc73ca98c58107b6e583b00a1907dd8805f82158
+ source = http://chocolate-doom.org/downloads/2.3.0/chocolate-doom-2.3.0.tar.gz
+ source = http://chocolate-doom.org/downloads/2.3.0/chocolate-doom-2.3.0.tar.gz.asc
+ sha256sums = 3e6d1a82ac5c8b025a9695ce1e47d0dc6ed142ebb1129b1e4a70e2740f79150c
+ sha256sums = SKIP
pkgname = chocolate-doom
pkgdesc = Doom port accurately reproducing the original DOS EXEs.
+ depends = libpng
depends = libsamplerate
depends = sdl_mixer
- depends = sdl_net
depends = chocolate-common
optdepends = freedm: Free deathmatch game
optdepends = freedoom1: Free Ultimate Doom-compatible game (not vanilla compatible, but useful for mods)
@@ -29,24 +29,24 @@ pkgname = chocolate-doom
pkgname = chocolate-heretic
pkgdesc = Heretic port accurately reproducing the original DOS EXEs.
+ depends = libpng
depends = libsamplerate
depends = sdl_mixer
- depends = sdl_net
depends = chocolate-common
optdepends = blasphemer: Free Heretic-compatible game
pkgname = chocolate-hexen
pkgdesc = Hexen port accurately reproducing the original DOS EXEs.
+ depends = libpng
depends = libsamplerate
depends = sdl_mixer
- depends = sdl_net
depends = chocolate-common
pkgname = chocolate-strife
pkgdesc = Strife port accurately reproducing the original DOS EXEs.
+ depends = libpng
depends = libsamplerate
depends = sdl_mixer
- depends = sdl_net
depends = chocolate-common
pkgname = chocolate-common
diff --git a/.gitignore b/.gitignore
index 665307854be8..8eed6e23061c 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,6 @@
*.pkg.tar*
*.src.tar*
+*.asc
*.gz
src
pkg
diff --git a/0001-i_sdlsound.c-fix-compilation-with-libsamplerate-0.1..patch b/0001-i_sdlsound.c-fix-compilation-with-libsamplerate-0.1..patch
deleted file mode 100644
index 216bb6d005e0..000000000000
--- a/0001-i_sdlsound.c-fix-compilation-with-libsamplerate-0.1..patch
+++ /dev/null
@@ -1,53 +0,0 @@
-From 7b4e65f16aacb3c00e19817be35c8acba7865fec Mon Sep 17 00:00:00 2001
-From: Fabian Greffrath <fabian@greffrath.com>
-Date: Mon, 24 Oct 2016 15:30:18 +0200
-Subject: [PATCH] i_sdlsound.c: fix compilation with libsamplerate 0.1.9
-
-This new version has const-corrected the data_in field, fixes #788
----
- src/i_sdlsound.c | 8 +++++---
- 1 file changed, 5 insertions(+), 3 deletions(-)
-
-diff --git a/src/i_sdlsound.c b/src/i_sdlsound.c
-index 79a15db..2d7a620 100644
---- a/src/i_sdlsound.c
-+++ b/src/i_sdlsound.c
-@@ -339,6 +339,7 @@ static boolean ExpandSoundData_SRC(sfxinfo_t *sfxinfo,
- int length)
- {
- SRC_DATA src_data;
-+ float *data_in;
- uint32_t i, abuf_index=0, clipped=0;
- // uint32_t alen;
- int retn;
-@@ -346,7 +347,8 @@ static boolean ExpandSoundData_SRC(sfxinfo_t *sfxinfo,
- Mix_Chunk *chunk;
-
- src_data.input_frames = length;
-- src_data.data_in = malloc(length * sizeof(float));
-+ data_in = malloc(length * sizeof(float));
-+ src_data.data_in = data_in;
- src_data.src_ratio = (double)mixer_freq / samplerate;
-
- // We include some extra space here in case of rounding-up.
-@@ -362,7 +364,7 @@ static boolean ExpandSoundData_SRC(sfxinfo_t *sfxinfo,
- // Unclear whether 128 should be interpreted as "zero" or whether a
- // symmetrical range should be assumed. The following assumes a
- // symmetrical range.
-- src_data.data_in[i] = data[i] / 127.5 - 1;
-+ data_in[i] = data[i] / 127.5 - 1;
- }
-
- // Do the sound conversion
-@@ -430,7 +432,7 @@ static boolean ExpandSoundData_SRC(sfxinfo_t *sfxinfo,
- expanded[abuf_index++] = cvtval_i;
- }
-
-- free(src_data.data_in);
-+ free(data_in);
- free(src_data.data_out);
-
- if (clipped > 0)
---
-2.10.1
-
diff --git a/PKGBUILD b/PKGBUILD
index 48ed5760dc60..aabb1a50edc5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,17 +3,17 @@
pkgname=(chocolate-{doom,heretic,hexen,strife,common})
pkgbase=${pkgname[0]}
pkgdesc="Historically-accurate Doom, Heretic, Hexen, and Strife ports."
-pkgver=2.2.1
-pkgrel=2
+pkgver=2.3.0
+pkgrel=1
arch=('i686' 'x86_64')
url="http://www.chocolate-doom.org/"
license=('GPL2')
-depends=('libsamplerate' 'sdl_mixer' 'sdl_net')
+depends=('libpng' 'libsamplerate' 'sdl_mixer')
makedepends=('python')
-source=(http://chocolate-doom.org/downloads/${pkgver}/${pkgbase}-${pkgver}.tar.gz
- 0001-i_sdlsound.c-fix-compilation-with-libsamplerate-0.1..patch)
-sha256sums=('ad11e2871667c6fa0658abf2dcba0cd9b26fbd651ee8df55adfdc18ad8fd674a'
- '2f54bccecbecfc57be96d75cdc73ca98c58107b6e583b00a1907dd8805f82158')
+source=(http://chocolate-doom.org/downloads/${pkgver}/${pkgbase}-${pkgver}.tar.gz{,.asc})
+sha256sums=('3e6d1a82ac5c8b025a9695ce1e47d0dc6ed142ebb1129b1e4a70e2740f79150c'
+ 'SKIP')
+validpgpkeys=('6D2C117E0310664497AA9546F6C2EE9C23354344')
prepare() {
cd "${pkgbase}-${pkgver}"
@@ -55,6 +55,7 @@ package_chocolate-common() {
rm -rf applications/chocolate-{doom,heretic,hexen,strife}.desktop \
applications/screensavers
rm -rf appdata
+ rm -rf bash-completion
cd man/man6
rm -f chocolate-{doom,heretic,hexen,strife}{,-setup}.6
}
@@ -77,6 +78,7 @@ package_chocolate-doom() {
rm -rf doc/chocolate-{heretic,hexen,strife}
rm -rf applications/chocolate-{setup,heretic,hexen,strife}.desktop icons
rm -f appdata/chocolate-{heretic,hexen,strife}.appdata.xml
+ rm -f bash-completion/completions/chocolate-{heretic,hexen,strife}
rm -f man/man?/chocolate-{heretic,hexen,strife,setup,server}* \
man/man5/{heretic,hexen,strife}.cfg*
}
@@ -98,6 +100,7 @@ package_chocolate-heretic() {
rm -rf applications/chocolate-{setup,doom,hexen,strife}.desktop \
applications/screensavers icons
rm -f appdata/chocolate-{doom,hexen,strife}.appdata.xml
+ rm -f bash-completion/completions/chocolate-{doom,hexen,strife}
rm -f man/man?/chocolate-{doom,hexen,strife,setup,server}* \
man/man5/{default,hexen,strife}.cfg*
}
@@ -118,6 +121,7 @@ package_chocolate-hexen() {
rm -rf applications/chocolate-{setup,doom,heretic,strife}.desktop \
applications/screensavers icons
rm -f appdata/chocolate-{doom,heretic,strife}.appdata.xml
+ rm -f bash-completion/completions/chocolate-{doom,heretic,strife}
rm -f man/man?/chocolate-{doom,heretic,strife,setup,server}* \
man/man5/{default,heretic,strife}.cfg*
}
@@ -138,6 +142,7 @@ package_chocolate-strife() {
rm -rf applications/chocolate-{setup,doom,heretic,hexen}.desktop \
applications/screensavers icons
rm -f appdata/chocolate-{doom,heretic,hexen}.appdata.xml
+ rm -f bash-completion/completions/chocolate-{doom,heretic,hexen}
rm -f man/man?/chocolate-{doom,heretic,hexen,setup,server}* \
man/man5/{default,heretic,hexen}.cfg*
}