summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDamien Flament2017-03-07 00:54:53 +0100
committerDamien Flament2017-03-07 00:54:53 +0100
commit4b67200c9d6dc60196c1de92ef12761e1373bf4a (patch)
tree55d669009e8ca0eea034003b86d2737cf116d1ef
parent1ede7024a6f957fc763ec5c9acf2a2a2effd0e55 (diff)
downloadaur-4b67200c9d6dc60196c1de92ef12761e1373bf4a.tar.gz
The application is downloaded in the user home data directory.
XDG Base Directory specification is respected. The distributed statup script is not useful anymore.
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD39
2 files changed, 29 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d6ff0c6f84a5..ac252ba1be88 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = voxelshop
- pkgdesc = VoxelShop is an extremely intuitive and powerful cross-platform software to modify and create voxel objects was designed from the ground up in close collaboration with artists.
+ pkgdesc = An extremely intuitive and powerful cross-platform software to modify and create voxel objects which was designed from the ground up in close collaboration with artists.
pkgver = 1.8.02
pkgrel = 1
url = http://blackflux.com/node/11
arch = any
license = Apache
depends = java-runtime-common
+ depends = bash
source = voxelshop
source = https://github.com/simlu/voxelshop/releases/download/1.8.02/VoxelShop-java-all-os-fast.zip
sha256sums = 69ff1076bf585855c81862b06bf50bd67621ac435d0c0f4a2ac3d19aa31317aa
diff --git a/PKGBUILD b/PKGBUILD
index 8f35af77a5bb..d95e8d451683 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ pkgdesc='An extremely intuitive and powerful cross-platform software to modify a
url=http://blackflux.com/node/11
license=('Apache')
groups=()
-depends=('java-runtime-common')
+depends=('java-runtime-common' 'bash')
makedepends=()
optdepends=()
provides=()
@@ -18,24 +18,39 @@ backup=()
options=()
install=
changelog=
-source=(
- 'voxelshop'
- 'https://github.com/simlu/voxelshop/releases/download/1.8.02/VoxelShop-java-all-os-fast.zip'
-)
+source=('voxelshop'
+ 'https://github.com/simlu/voxelshop/releases/download/1.8.02/VoxelShop-java-all-os-fast.zip')
noextract=()
sha256sums=('69ff1076bf585855c81862b06bf50bd67621ac435d0c0f4a2ac3d19aa31317aa'
'86c1fd50ef32b17be92df37d6a5c2206e456d99bc7abe4da80a44f49d2a377d3')
arch=('any')
package() {
- # Install the package startup script
- install -D "${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+ # Install the distributed files in /opt
+ cd "${srcdir}/${_pkgname_upper}"
+
+ install -Dm755 -t "${pkgdir}/opt/${pkgname}" data/*
+
+ # Generate the startup script
+ install -d ${pkgdir}/usr/bin
+
+ cat <<_STARTUP_SCRIPT_ >${pkgdir}/usr/bin/${pkgname}
+#!/bin/bash
+
+cd /opt/${pkgname}
+declare -r DATA_DIR=\${XDG_DATA_HOME:-"\${HOME}/.local/share"}/${pkgname}
+
+# Update the Getdown configuration file
+install -CDm644 -t "\${DATA_DIR}" getdown.txt
+# Start the application using Getdown
+java -jar getdown-client.jar "\${DATA_DIR}"
+
+_STARTUP_SCRIPT_
+
+ chmod +x ${pkgdir}/usr/bin/${pkgname}
+
# Add a symlink to the startup script using the camel-cased package name
ln -s "${pkgname}" "${pkgdir}/usr/bin/${_pkgname_upper}"
-
- # Install the distributed files in /opt
- cd "${srcdir}/${_pkgname_upper}"
- install -Dt "${pkgdir}/opt/${pkgname}" start-linux.sh
- cp -R data "${pkgdir}/opt/${pkgname}"
}
+