summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGaoyang Zhang2022-04-19 12:48:28 +0800
committerGaoyang Zhang2022-04-19 12:48:28 +0800
commit4b6f25ac8eced7daaf613e124c7bf218c9fbe6cc (patch)
tree31f7d90e08b9fc948a9ed7d9b55723619ebae0d0
parent72a239c4d1f0ee99cd1597ac8a07da700a2c3886 (diff)
downloadaur-4b6f25ac8eced7daaf613e124c7bf218c9fbe6cc.tar.gz
fix: `check()` function did not invoke `cargo test` properly
Signed-off-by: Gaoyang Zhang <gy@blurgy.xyz>
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
2 files changed, 3 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2839b0eb04bf..dfdff039b7d2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = dt-cli
pkgdesc = Dotfile management and templating client
pkgver = 0.7.8
- pkgrel = 1
+ pkgrel = 2
url = https://dt.cli.rs
arch = any
license = MIT OR Apache 2.0
diff --git a/PKGBUILD b/PKGBUILD
index 137819aaea27..79fdf3b52593 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Gaoyang Zhang <gy@blurgy.xyz>
pkgname=dt-cli
pkgver=0.7.8
-pkgrel=1
+pkgrel=2
epoch=
pkgdesc="Dotfile management and templating client"
arch=("any")
@@ -39,7 +39,7 @@ build() {
check() {
cd "dt-$pkgver"
- cargo +stable test --bin=dt-cli --lib=dt-core --release --all-features --locked
+ cargo +stable test --lib --release --all-features --locked
}
package() {