summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEggz2024-01-01 15:33:37 +0100
committerEggz2024-01-01 15:33:37 +0100
commit4dfe9810f149b2f511910492b3ae263131e1b4bc (patch)
tree0009aafb09015008a0d18b478c2fa05186f67296
parent00c9a95167e246195f55a3ebfd553e5b5bf97bd5 (diff)
downloadaur-4dfe9810f149b2f511910492b3ae263131e1b4bc.tar.gz
Updated
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD30
-rw-r--r--config.x86_642
-rw-r--r--linux.install37
4 files changed, 7 insertions, 71 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b123169d2166..b91911bfd7d0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = linux-amd-znver2
- pkgver = 6.6.v.8
+ pkgver = 6.6.v.9
pkgrel = 1
url = https://www.kernel.org/
arch = x86_64
@@ -14,22 +14,19 @@ pkgbase = linux-amd-znver2
makedepends = lzop
makedepends = gcc>=9.1
options = !strip
- source = git+https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git#tag=v6.6.8
+ source = git+https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git#tag=v6.6.9
source = config.x86_64
source = linux-amd-znver2.preset
- source = linux.install
source = https://raw.githubusercontent.com/graysky2/kernel_compiler_patch/20230105/more-uarches-for-kernel-5.17+.patch
source = flushbyasid.patch
sha256sums = SKIP
- sha256sums = cf02c70d7988f25ee33df7b9e48afd11dbb0a85cd61b50629d70bb57738dfe07
+ sha256sums = 6091d4e92e6903ee5805db9cdc8d659612ff4cfb6136ebe6abb5ec7fbb5619c1
sha256sums = a7dda487e8277bfdf0dd0a6f578b219ae97de84b00df1822330e808c378df907
- sha256sums = d590e751ab4cf424b78fd0d57e53d187f07401a68c8b468d17a5f39a337dacf0
sha256sums = 81ad663925a0aa5b5332a69bae7227393664bb81ee2e57a283e7f16e9ff75efe
sha256sums = 0878a970035793ca761c6f7499fb37cf04e6d9892758ca3fb9b99f846febfaf0
pkgname = linux-amd-znver2
pkgdesc = Linux kernel aimed at the znver2 AMD Ryzen CPU based hardware
- install = linux.install
depends = coreutils
depends = linux-firmware
depends = kmod
diff --git a/PKGBUILD b/PKGBUILD
index 450ce14dd29d..b3b5f1cb30c1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,10 +2,10 @@
pkgbase=linux-amd-znver2
_srcname=linux
-gitver=v6.6.8
+gitver=v6.6.9
patchver=20230105
patchname=more-uarches-for-kernel-5.17+.patch
-pkgver=6.6.v.8
+pkgver=6.6.v.9
pkgrel=1
arch=('x86_64')
url="https://www.kernel.org/"
@@ -18,8 +18,6 @@ source=("git+https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git#ta
'config.x86_64'
# standard config files for mkinitcpio ramdisk
"${pkgbase}.preset"
- # linux package install directives for pacman
- 'linux.install'
# patch from our graysky archlinux colleague
"https://raw.githubusercontent.com/graysky2/kernel_compiler_patch/$patchver/$patchname"
# nested KVM svm patch
@@ -27,11 +25,9 @@ source=("git+https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git#ta
)
sha256sums=('SKIP'
#config.x86_64
- 'cf02c70d7988f25ee33df7b9e48afd11dbb0a85cd61b50629d70bb57738dfe07'
+ '6091d4e92e6903ee5805db9cdc8d659612ff4cfb6136ebe6abb5ec7fbb5619c1'
#.preset file
'a7dda487e8277bfdf0dd0a6f578b219ae97de84b00df1822330e808c378df907'
- #linux install file
- 'd590e751ab4cf424b78fd0d57e53d187f07401a68c8b468d17a5f39a337dacf0'
#grayskypatch
'81ad663925a0aa5b5332a69bae7227393664bb81ee2e57a283e7f16e9ff75efe'
#flushbyasid.patch
@@ -53,9 +49,6 @@ prepare() {
exit 2
fi
- # don't run depmod on 'make install'. We'll do this ourselves in packaging
- sed -i '2iexit 0' scripts/depmod.sh
-
# Implement all packaged patches and reverts.
msg2 "Implementing custom kernel patches/reverts"
while read patch; do
@@ -90,7 +83,6 @@ _package() {
depends=('coreutils' 'linux-firmware' 'kmod' 'lzop')
optdepends=('crda: to set the correct wireless channels of your country')
backup=("etc/mkinitcpio.d/${pkgbase}.preset")
- install=linux.install
cd "${_srcname}"
@@ -105,14 +97,6 @@ _package() {
make LOCALVERSION= INSTALL_MOD_PATH="${pkgdir}" modules_install
cp arch/$KARCH/boot/bzImage "${pkgdir}/boot/vmlinuz-${pkgbase}"
- # set correct depmod command for install
- cp -f "${startdir}/${install}" "${startdir}/${install}.pkg"
- true && install=${install}.pkg
- sed \
- -e "s/KERNEL_NAME=.*/KERNEL_NAME=${_kernelname}/" \
- -e "s/KERNEL_VERSION=.*/KERNEL_VERSION=${_kernver}/" \
- -i "${startdir}/${install}"
-
# install mkinitcpio preset file for kernel
install -D -m644 "${srcdir}/${pkgbase}.preset" "${pkgdir}/etc/mkinitcpio.d/${pkgbase}.preset"
sed \
@@ -126,14 +110,6 @@ _package() {
rm -f "${pkgdir}"/lib/modules/${_kernver}/build
# remove the firmware
rm -rf "${pkgdir}/lib/firmware"
- # make room for external modules
- ln -s "../extramodules-${_basekernel}${_kernelname:--ARCH}" "${pkgdir}/lib/modules/${_kernver}/extramodules"
- # add real version for building modules and running depmod from post_install/upgrade
- mkdir -p "${pkgdir}/lib/modules/extramodules-${_basekernel}${_kernelname:--ARCH}"
- echo "${_kernver}" > "${pkgdir}/lib/modules/extramodules-${_basekernel}${_kernelname:--ARCH}/version"
-
- # Now we call depmod...
- depmod -b "${pkgdir}" -F System.map "${_kernver}"
# move module tree /lib -> /usr/lib
mkdir -p "${pkgdir}/usr"
diff --git a/config.x86_64 b/config.x86_64
index 5c310196345a..c0e64acb2066 100644
--- a/config.x86_64
+++ b/config.x86_64
@@ -1,6 +1,6 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/x86 6.6.8 Kernel Configuration
+# Linux/x86 6.6.9 Kernel Configuration
#
CONFIG_CC_VERSION_TEXT="gcc (GCC) 13.2.1 20230801"
CONFIG_CC_IS_GCC=y
diff --git a/linux.install b/linux.install
deleted file mode 100644
index ef42413835ac..000000000000
--- a/linux.install
+++ /dev/null
@@ -1,37 +0,0 @@
-# arg 1: the new package version
-# arg 2: the old package version
-
-KERNEL_NAME=
-KERNEL_VERSION=
-
-post_install () {
- # updating module dependencies
- echo ">>> Updating module dependencies. Please wait ..."
- depmod ${KERNEL_VERSION}
- echo ">>> Generating initial ramdisk, using mkinitcpio. Please wait..."
- mkinitcpio -p linux${KERNEL_NAME}
-}
-
-post_upgrade() {
- if findmnt --fstab -uno SOURCE /boot &>/dev/null && ! mountpoint -q /boot; then
- echo "WARNING: /boot appears to be a separate partition but is not mounted."
- fi
-
- # updating module dependencies
- echo ">>> Updating module dependencies. Please wait ..."
- depmod ${KERNEL_VERSION}
- echo ">>> Generating initial ramdisk, using mkinitcpio. Please wait..."
- mkinitcpio -p linux${KERNEL_NAME}
-
- if [ $(vercmp $2 3.13) -lt 0 ]; then
- echo ">>> WARNING: AT keyboard support is no longer built into the kernel."
- echo ">>> In order to use your keyboard during early init, you MUST"
- echo ">>> include the 'keyboard' hook in your mkinitcpio.conf."
- fi
-}
-
-post_remove() {
- # also remove the compat symlinks
- rm -f boot/initramfs-linux${KERNEL_NAME}.img
- rm -f boot/initramfs-linux${KERNEL_NAME}-fallback.img
-}