summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames Harvey2015-08-01 23:53:00 +0000
committerJames Harvey2015-08-01 23:53:00 +0000
commit4e7e5395a3d6448e71d0e6af40a31a019441f781 (patch)
treec0398f0bdbeeb5b0109bee0d1e22bbbfd93d1d4d
downloadaur-4e7e5395a3d6448e71d0e6af40a31a019441f781.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD61
-rw-r--r--bash-git-prompt.install30
-rw-r--r--removed_spacing.patch30
4 files changed, 141 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dfa2db6417c7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = bash-git-prompt
+ pkgdesc = Informative git prompt for bash and fish
+ pkgver = 2.3.5
+ pkgrel = 1
+ url = https://github.com/magicmonty/bash-git-prompt
+ install = bash-git-prompt.install
+ arch = any
+ license = custom:BSD 2 Clause (NetBSD)
+ makedepends = git
+ depends = bash
+ optdepends = fish: git prompt in fish support
+ source = git+https://github.com/magicmonty/bash-git-prompt
+ source = bash-git-prompt.install
+ source = removed_spacing.patch
+ md5sums = SKIP
+ md5sums = 1e762bd413b6efdec225928da5aa6451
+ md5sums = 513706d4f97f775a60325bc31574d197
+
+pkgname = bash-git-prompt
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f9733ebb599b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,61 @@
+# $Id$
+# Maintainer: James Harvey <jamespharvey20@gmail.com>
+
+
+
+# Upstream has extra spacing, necessary in other distributions
+# If you want to remove these, uncomment (remove the # on) the line below
+#_install_removed_spacing_patch=1
+
+
+
+pkgname=bash-git-prompt
+pkgver=2.3.5
+pkgrel=1
+pkgdesc="Informative git prompt for bash and fish"
+arch=('any')
+url="https://github.com/magicmonty/bash-git-prompt"
+depends=('bash')
+optdepends=('fish: git prompt in fish support')
+makedepends=('git')
+license=('custom:BSD 2 Clause (NetBSD)')
+source=("git+https://github.com/magicmonty/${pkgname}"
+ 'bash-git-prompt.install'
+ 'removed_spacing.patch')
+md5sums=('SKIP'
+ '1e762bd413b6efdec225928da5aa6451'
+ '513706d4f97f775a60325bc31574d197')
+install='bash-git-prompt.install'
+
+prepare() {
+ cd ${srcdir}/${pkgname}
+ git checkout tags/${pkgver}
+
+ if [ -n "$_install_removed_spacing_patch" ]; then
+ echo "Installing removed_spacing.patch..."
+ patch -p1 -i ${srcdir}/removed_spacing.patch
+ else
+ echo "NOT installing removed_spacing.patch..."
+ fi
+}
+
+package() {
+ cd ${srcdir}/${pkgname}
+
+ install -Dm644 gitprompt.fish ${pkgdir}/usr/lib/bash-git-prompt/gitprompt.fish
+ install -Dm755 git-prompt-help.sh ${pkgdir}/usr/lib/bash-git-prompt/git-prompt-help.sh
+ install -Dm755 gitprompt.sh ${pkgdir}/usr/lib/bash-git-prompt/gitprompt.sh
+ install -Dm755 gitstatus.sh ${pkgdir}/usr/lib/bash-git-prompt/gitstatus.sh
+ install -Dm644 LICENSE.txt ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.txt
+ install -Dm644 prompt-colors.sh ${pkgdir}/usr/lib/bash-git-prompt/prompt-colors.sh
+ install -Dm644 README.md ${pkgdir}/usr/lib/bash-git-prompt/README.md
+
+ cd themes
+ install -Dm644 Custom.bgptemplate ${pkgdir}/usr/lib/${pkgname}/themes/Custom.bgptemplate
+ install -Dm644 Default.bgptheme ${pkgdir}/usr/lib/${pkgname}/themes/Default.bgptheme
+ install -Dm644 Default_NoExitState.bgptheme ${pkgdir}/usr/lib/${pkgname}/themes/Default_NoExitState.bgptheme
+ install -Dm644 Single_line.bgptheme ${pkgdir}/usr/lib/${pkgname}/themes/Single_line.bgptheme
+ install -Dm644 Single_line_openSUSE.bgptheme ${pkgdir}/usr/lib/${pkgname}/themes/Single_line_openSUSE.bgptheme
+ install -Dm644 Solarized.bgptheme ${pkgdir}/usr/lib/${pkgname}/themes/Solarized.bgptheme
+ install -Dm644 Solarized_NoExitState.bgptheme ${pkgdir}/usr/lib/${pkgname}/themes/Solarized_NoExitState.bgptheme
+}
diff --git a/bash-git-prompt.install b/bash-git-prompt.install
new file mode 100644
index 000000000000..9596c0fe74cd
--- /dev/null
+++ b/bash-git-prompt.install
@@ -0,0 +1,30 @@
+post_install() {
+ echo "bash-git-prompt
+
+ NOTE: To use bash-git-prompt, you should add the following to your
+ /etc/bash.bashrc or ~/.bashrc:
+
+ if [ -f %{/usr/lib/bash-git-prompt/gitprompt.sh ]; then
+ # GIT_PROMPT_ONLY_IN_REPO=1
+ GIT_PROMPT_THEME=Default
+ source /usr/lib/bash-git-prompt/gitprompt.sh
+ fi
+
+"
+}
+
+post_remove() {
+ echo "bash-git-prompt
+
+ NOTE: Any already running shells that were using bash-git-prompt will give a
+ bunch of errors with every new prompt line, until you start new shells
+ by doing one of the following:
+
+ * Restarting your shells (relogging in each of them)
+ * Starting new shells (running "bash" in each of them)
+ * Rebooting
+
+ ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
+
+"
+}
diff --git a/removed_spacing.patch b/removed_spacing.patch
new file mode 100644
index 000000000000..823dcdf941ac
--- /dev/null
+++ b/removed_spacing.patch
@@ -0,0 +1,30 @@
+diff -rupN bash-git-prompt/themes/Default.bgptheme bash-git-prompt-removed-spacing/themes/Default.bgptheme
+--- bash-git-prompt/themes/Default.bgptheme 2015-08-01 23:31:22.105038716 +0000
++++ bash-git-prompt-removed-spacing/themes/Default.bgptheme 2015-08-01 23:43:18.399408812 +0000
+@@ -43,12 +43,12 @@ define_undefined_git_prompt_colors() {
+
+ if [[ -z ${GIT_PROMPT_BRANCH} ]]; then GIT_PROMPT_BRANCH="${Magenta}"; fi # the git branch that is active in the current directory
+ if [[ -z ${GIT_PROMPT_STAGED} ]]; then GIT_PROMPT_STAGED="${Red}●"; fi # the number of staged files/directories
+- if [[ -z ${GIT_PROMPT_CONFLICTS} ]]; then GIT_PROMPT_CONFLICTS="${Red}✖ "; fi # the number of files in conflict
+- if [[ -z ${GIT_PROMPT_CHANGED} ]]; then GIT_PROMPT_CHANGED="${Blue}✚ "; fi # the number of changed files
++ if [[ -z ${GIT_PROMPT_CONFLICTS} ]]; then GIT_PROMPT_CONFLICTS="${Red}✖"; fi # the number of files in conflict
++ if [[ -z ${GIT_PROMPT_CHANGED} ]]; then GIT_PROMPT_CHANGED="${Blue}✚"; fi # the number of changed files
+
+ if [[ -z ${GIT_PROMPT_REMOTE} ]]; then GIT_PROMPT_REMOTE=" "; fi # the remote branch name (if any) and the symbols for ahead and behind
+ if [[ -z ${GIT_PROMPT_UNTRACKED} ]]; then GIT_PROMPT_UNTRACKED="${Cyan}…"; fi # the number of untracked files/dirs
+- if [[ -z ${GIT_PROMPT_STASHED} ]]; then GIT_PROMPT_STASHED="${BoldBlue}⚑ "; fi # the number of stashed files/dir
++ if [[ -z ${GIT_PROMPT_STASHED} ]]; then GIT_PROMPT_STASHED="${BoldBlue}⚑"; fi # the number of stashed files/dir
+ if [[ -z ${GIT_PROMPT_CLEAN} ]]; then GIT_PROMPT_CLEAN="${BoldGreen}✔"; fi # a colored flag indicating a "clean" repo
+
+ # For the command indicator, the placeholder _LAST_COMMAND_STATE_
+@@ -72,8 +72,8 @@ define_undefined_git_prompt_colors() {
+ if [[ -z ${GIT_PROMPT_END_ROOT} ]]; then GIT_PROMPT_END_ROOT=" \n${White}${Time12a}${ResetColor} # "; fi
+
+ # Please do not add colors to these symbols
+- if [[ -z ${GIT_PROMPT_SYMBOLS_AHEAD} ]]; then GIT_PROMPT_SYMBOLS_AHEAD="↑·"; fi # The symbol for "n versions ahead of origin"
+- if [[ -z ${GIT_PROMPT_SYMBOLS_BEHIND} ]]; then GIT_PROMPT_SYMBOLS_BEHIND="↓·"; fi # The symbol for "n versions behind of origin"
++ if [[ -z ${GIT_PROMPT_SYMBOLS_AHEAD} ]]; then GIT_PROMPT_SYMBOLS_AHEAD="↑"; fi # The symbol for "n versions ahead of origin"
++ if [[ -z ${GIT_PROMPT_SYMBOLS_BEHIND} ]]; then GIT_PROMPT_SYMBOLS_BEHIND="↓"; fi # The symbol for "n versions behind of origin"
+ if [[ -z ${GIT_PROMPT_SYMBOLS_PREHASH} ]]; then GIT_PROMPT_SYMBOLS_PREHASH=":"; fi # Written before hash of commit, if no name could be found
+ if [[ -z ${GIT_PROMPT_SYMBOLS_NO_REMOTE_TRACKING} ]]; then GIT_PROMPT_SYMBOLS_NO_REMOTE_TRACKING="L"; fi # This symbol is written after the branch, if the branch is not tracked
+ }