summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Schendel2024-03-20 23:54:02 +0100
committerChristian Schendel2024-03-20 23:54:02 +0100
commit4f4bf82ae419d99b60015dbc1cc796bfedc973af (patch)
tree5edeef1c3683cbbaa0a7579266243ca0eabaa83e
parent94b3a2355657aad1cc7fca39540a96169ded4db6 (diff)
downloadaur-4f4bf82ae419d99b60015dbc1cc796bfedc973af.tar.gz
Update dependency gnome-shell<=1:40
modified: .SRCINFO modified: PKGBUILD
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD50
2 files changed, 35 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5cdd1ce8f8a8..3852950b0e7e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = yaru-remix-git
pkgdesc = Yaru-remix is a fork of Yaru theme
pkgver = r6.a1fdac60
- pkgrel = 4
+ pkgrel = 5
epoch = 1
url = https://github.com/Muqtxdir/yaru-remix
arch = any
@@ -29,7 +29,7 @@ pkgname = yaru-remix-gtk-theme-git
pkgname = yaru-remix-gnome-shell-theme-git
pkgdesc = Yaru-remix gnome shell theme
- depends = gnome-shell
+ depends = gnome-shell<=1.40
provides = yaru-remix-gnome-shell-theme
conflicts = yaru-remix-gnome-shell-theme
diff --git a/PKGBUILD b/PKGBUILD
index 6d4e5dd38789..d427f7f9e249 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,13 +5,17 @@ pkgname=(yaru-remix-gtk-theme-git
yaru-remix-icon-theme-git
yaru-remix-wallpaper-git)
pkgver=r6.a1fdac60
-pkgrel=4
+pkgrel=5
epoch=1
pkgdesc="Yaru-remix is a fork of Yaru theme"
arch=(any)
url="https://github.com/Muqtxdir/${pkgbase%-git}"
license=('GPL3' 'LGPL3' 'LGPL2.1' 'CCPL:by-nc-sa')
-makedepends=(meson sassc git)
+makedepends=(
+ 'meson'
+ 'sassc'
+ 'git'
+)
options=('!strip' '!buildflags' 'staticlibs')
source=("${pkgbase%-git}::git+${url}.git")
sha256sums=('SKIP')
@@ -54,39 +58,51 @@ _delete_all_from_pkgdir_except() {
}
package_yaru-remix-gtk-theme-git() {
- pkgdesc="Yaru-remix gtk theme"
- depends=(gtk3 gdk-pixbuf2 gtk-engine-murrine gnome-themes-extra)
- provides=(yaru-remix-gtk-theme)
- conflicts=(yaru-remix-gtk-theme-git)
+ pkgdesc="Yaru-remix gtk theme"
+ depends=(
+ 'gtk3'
+ 'gdk-pixbuf2'
+ 'gtk-engine-murrine'
+ 'gnome-themes-extra'
+ )
+ provides=('yaru-remix-gtk-theme')
+ conflicts=('yaru-remix-gtk-theme-git')
DESTDIR="$pkgdir" ninja -C build install 2>&1 >> install.log
_delete_all_from_pkgdir_except "gtk-theme"
}
package_yaru-remix-gnome-shell-theme-git() {
- pkgdesc="Yaru-remix gnome shell theme"
- depends=(gnome-shell)
- provides=(yaru-remix-gnome-shell-theme)
- conflicts=(yaru-remix-gnome-shell-theme)
+ pkgdesc="Yaru-remix gnome shell theme"
+ depends=(
+ 'gnome-shell<=1.40'
+ )
+ provides=('yaru-remix-gnome-shell-theme')
+ conflicts=('yaru-remix-gnome-shell-theme')
DESTDIR="$pkgdir" ninja -C build install 2>&1 >> install.log
_delete_all_from_pkgdir_except "gnome-shell-theme"
}
package_yaru-remix-icon-theme-git() {
- pkgdesc="Yaru-remix icon theme"
- depends=(hicolor-icon-theme gtk-update-icon-cache librsvg humanity-icon-theme)
- provides=(yaru-remix-icon-theme)
- conflicts=(yaru-remix-icon-theme)
+ pkgdesc="Yaru-remix icon theme"
+ depends=(
+ 'hicolor-icon-theme'
+ 'gtk-update-icon-cache'
+ 'librsvg'
+ 'humanity-icon-theme'
+ )
+ provides=('yaru-remix-icon-theme')
+ conflicts=('yaru-remix-icon-theme')
DESTDIR="$pkgdir" ninja -C build install 2>&1 >> install.log
_delete_all_from_pkgdir_except "icon-theme"
}
package_yaru-remix-wallpaper-git() {
- pkgdesc="Yaru-remix wallpaper theme"
- provides=(yaru-remix-wallpaper)
- conflicts=(yaru-remix-wallpaper)
+ pkgdesc="Yaru-remix wallpaper theme"
+ provides=('yaru-remix-wallpaper')
+ conflicts=('yaru-remix-wallpaper')
DESTDIR="$pkgdir" ninja -C build install 2>&1 >> install.log
_delete_all_from_pkgdir_except "wallpaper"