summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntiCompositeNumber2020-04-25 21:15:40 -0400
committerAntiCompositeNumber2020-04-25 21:41:05 -0400
commit4f9eff8581a44c240917cf8c4d50a532de736ce7 (patch)
tree114510b0daffe17f3977df382ffb2fabc6f66140
parenteceee226233fcad702df1785b2cf42594fab3579 (diff)
downloadaur-4f9eff8581a44c240917cf8c4d50a532de736ce7.tar.gz
tarball-based pkg for 3.4.10, with backported yaml fix
-rw-r--r--PKGBUILD38
-rw-r--r--huggle-extensions.patch26
2 files changed, 20 insertions, 44 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3d65ff63030b..8c32493157c2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,46 +11,22 @@ license=('GPL')
depends=('qt5-multimedia' 'qt5-webengine' 'yaml-cpp')
makedepends=('cmake' 'ninja')
source=(
- "${pkgname}_${pkgver}::git+https://github.com/huggle/huggle3-qt-lx.git#tag=${pkgver}"
- "git+https://github.com/grumpy-irc/libirc.git"
- "git+https://github.com/huggle/mass-delivery.git"
- "git+https://github.com/huggle/enwiki.git"
- "git+https://github.com/huggle/extension-thanks.git"
- "git+https://github.com/huggle/extension-splitter-helper.git"
- "git+https://github.com/huggle/extension-review.git"
- "git+https://github.com/huggle/extension-mass-delete.git"
- "git+https://github.com/huggle/extension-scoring.git"
- "git+https://github.com/huggle/extension-flow"
- "huggle-extensions.patch"
+ "https://github.com/huggle/huggle3-qt-lx/releases/download/${pkgver}/${pkgname}_${pkgver}.tar.gz"
"huggle-yaml.patch"
+ "huggle-extensions.patch"
)
-sha256sums=('SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP'
- 'SKIP' 'SKIP')
+sha256sums=('7dbf2c943f80eac551839535df68d1af4c19d52a026a9140a1b2fcf63f5a2249'
+ 'e66bb7ba73b72b08d478715d44baf096c87291e05997ad4786c1515b6574f2bb'
+ '823cbf583c00722bfe5ecd74a57ee7e3ef942ecb95a1704e65c226e7a2624497')
prepare() {
cd "${pkgname}_${pkgver}"
- git submodule init src/extensions
- git submodule init src/3rd/libirc
- git config submodule.src/3rd/libirc.url "${srcdir}/libirc"
- git config submodule.src/extensions/mass-delivery.url "${srcdir}/mass-delivery"
- git config submodule.src/extensions/enwiki.url "${srcdir}/enwiki"
- git config submodule.src/extensions/extension-thanks.url "${srcdir}/extension-thanks"
- git config submodule.src/extensions/extension-splitter-helper.url \
- "${srcdir}/extension-splitter-helper"
- git config submodule.src/extensions/extension-review.url "${srcdir}/extension-review"
- git config submodule.src/extensions/extension-mass-delete.url \
- "${srcdir}/extension-mass-delete"
- git config submodule.src/extensions/extension-scoring.url "${srcdir}/extension-scoring"
- git config submodule.src/extensions/extension-flow.url "${srcdir}/extension-flow"
- git submodule update
- git submodule foreach 'git reset --hard'
+ # Patch extension directory to /usr/lib/huggle/extensions (T251049)
patch --forward --strip=1 --input="../huggle-extensions.patch"
+ # Backport dependency fix from master, remove in 3.4.11
patch --forward --strip=1 --input="../huggle-yaml.patch"
- cd "src/huggle_core"
- ./update.sh
}
-
build() {
export CFLAGS+=" ${CPPFLAGS}"
export CXXFLAGS+=" ${CPPFLAGS}"
diff --git a/huggle-extensions.patch b/huggle-extensions.patch
index bccda22e564c..1812f1fa8284 100644
--- a/huggle-extensions.patch
+++ b/huggle-extensions.patch
@@ -110,16 +110,16 @@ index 3e1a4319..8d69cb3b 100644
#elif defined HUGGLE_WIN
// This is needed by yaml cpp library, otherwise it won't build with MSVC
#define YAML_CPP_DLL
-#diff --git a/src/huggle_core/definitions.hpp b/src/huggle_core/definitions.hpp
-#index 1fc5b1f..dc7a4d9 100644
-#--- a/src/huggle_core/definitions.hpp
-#+++ b/src/huggle_core/definitions.hpp
-#@@ -216,7 +216,7 @@ namespace std { typedef decltype(nullptr) nullptr_t; }
-# #define HUGGLE_GLOBAL_EXTENSION_PATH QCoreApplication::applicationDirPath() + "/extensions"
-# #elif defined __linux__
-# #define HUGGLE_UPDATER_PLATFORM_TYPE "linux"
-#- #define HUGGLE_GLOBAL_EXTENSION_PATH "/usr/local/share/huggle/extensions"
-#+ #define HUGGLE_GLOBAL_EXTENSION_PATH "/usr/lib/huggle/extensions/"
-# #elif defined HUGGLE_WIN
-# // This is needed by yaml cpp library, otherwise it won't build with MSVC
-# #define YAML_CPP_DLL
+diff --git a/src/huggle_core/definitions.hpp b/src/huggle_core/definitions.hpp
+index 1fc5b1f..dc7a4d9 100644
+--- a/src/huggle_core/definitions.hpp
++++ b/src/huggle_core/definitions.hpp
+@@ -216,7 +216,7 @@ namespace std { typedef decltype(nullptr) nullptr_t; }
+ #define HUGGLE_GLOBAL_EXTENSION_PATH QCoreApplication::applicationDirPath() + "/extensions"
+ #elif defined __linux__
+ #define HUGGLE_UPDATER_PLATFORM_TYPE "linux"
+- #define HUGGLE_GLOBAL_EXTENSION_PATH "/usr/local/share/huggle/extensions"
++ #define HUGGLE_GLOBAL_EXTENSION_PATH "/usr/lib/huggle/extensions"
+ #elif defined HUGGLE_WIN
+ // This is needed by yaml cpp library, otherwise it won't build with MSVC
+ #define YAML_CPP_DLL