summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgardenapple2020-08-06 14:27:13 +0300
committergardenapple2020-08-06 14:27:13 +0300
commit517deec8c44106e08a6eae2ff4b25ffbccfbb1a7 (patch)
tree69a17ff1a871189341d12546f51f77e253b94d61
parentbbec7a5ad136c19df03310728e8d10be3c428051 (diff)
downloadaur-517deec8c44106e08a6eae2ff4b25ffbccfbb1a7.tar.gz
Removed patch for icon paths, fixed in upstream
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD16
-rw-r--r--fahcontrol-icon-path-linux.patch20
3 files changed, 6 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index afe9e6f3b6b1..d3454ec1a045 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = fahcontrol-gtk3-git
pkgdesc = Graphical monitor and control utility for the Folding@home client (python3/GTK3 fork)
- pkgver = r156.7ae5c23
- pkgrel = 2
+ pkgver = r160.b818486
+ pkgrel = 1
url = https://foldingathome.org
arch = any
license = GPL3
@@ -14,9 +14,7 @@ pkgbase = fahcontrol-gtk3-git
provides = fahcontrol
conflicts = fahcontrol
source = fahcontrol-gtk3-git::git+https://github.com/cdberkstresser/fah-control.git
- source = fahcontrol-icon-path-linux.patch
sha256sums = SKIP
- sha256sums = 1ca22992df83904d8a3a1049138a3022409ab877d73be0eaedf77c40e55d4c39
pkgname = fahcontrol-gtk3-git
diff --git a/PKGBUILD b/PKGBUILD
index 32f7ecb34648..b888274004d7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Contributor: katt <magunasu.b97@gmail.com>
pkgname=fahcontrol-gtk3-git
-pkgver=r156.7ae5c23
-pkgrel=2
+pkgver=r160.b818486
+pkgrel=1
pkgdesc='Graphical monitor and control utility for the Folding@home client (python3/GTK3 fork)'
url='https://foldingathome.org'
arch=('any')
@@ -14,10 +14,8 @@ optdepends=('fahviewer: 3D simulation viewer')
provides=('fahcontrol')
conflicts=('fahcontrol')
#changelog="src/${pkgname}/CHANGELOG.md"
-source=("${pkgname}::git+https://github.com/cdberkstresser/fah-control.git"
- "fahcontrol-icon-path-linux.patch")
-sha256sums=('SKIP'
- '1ca22992df83904d8a3a1049138a3022409ab877d73be0eaedf77c40e55d4c39')
+source=("${pkgname}::git+https://github.com/cdberkstresser/fah-control.git")
+sha256sums=('SKIP')
pkgver() {
cd "$pkgname"
@@ -26,12 +24,6 @@ pkgver() {
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-prepare() {
- # This patch is a hack, not cross-platform at all
- # (I know nothing about Python or GTK so this is the best I can do for now)
- patch "${pkgname}/fah/FAHControl.py" fahcontrol-icon-path-linux.patch || true
-}
-
build() {
cd "${pkgname}"
python setup.py build
diff --git a/fahcontrol-icon-path-linux.patch b/fahcontrol-icon-path-linux.patch
deleted file mode 100644
index ea6fd257281e..000000000000
--- a/fahcontrol-icon-path-linux.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- fahcontrol-gtk3-git/fah/FAHControl.py 2020-08-02 22:42:01.389885129 +0300
-+++ fahcontrol-gtk3-git/fah/FAHControl.py.old 2020-08-02 22:10:12.183013169 +0300
-@@ -204,7 +204,7 @@
- self.mono_font = Pango.FontDescription('Monospace')
-
- # Default icon
-- self.window.set_default_icon_from_file(os.path.dirname(os.path.abspath(__file__)) + '/../images/FAHControl.ico')
-+ self.window.set_default_icon_from_file('/usr/share/pixmaps/FAHControl.ico')
-
- # Filter glade
- if len(glade) < 1024:
-@@ -296,7 +296,7 @@
-
- # About Dialog
- icon = builder.get_object('about_icon',)
-- icon.set_from_file(os.path.dirname(os.path.abspath(__file__)) + '/../images/FAHControl.ico')
-+ icon.set_from_file('/usr/share/pixmaps/FAHControl.ico')
-
- about_version = builder.get_object('about_version')
- about_version.set_markup('<b>Version: %s</b>' % version)